|
|
|
@ -1,7 +1,7 @@
|
|
|
|
|
--- gix-archive-0.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ gix-archive-0.15.0/Cargo.toml 2024-09-07T18:05:21.490769+00:00
|
|
|
|
|
@@ -76,7 +76,7 @@
|
|
|
|
|
version = "1.0.26"
|
|
|
|
|
--- gix-archive-0.19.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ gix-archive-0.19.0/Cargo.toml 2025-01-22T19:05:55.626544+00:00
|
|
|
|
|
@@ -77,7 +77,7 @@
|
|
|
|
|
version = "2.0.0"
|
|
|
|
|
|
|
|
|
|
[dependencies.zip]
|
|
|
|
|
-version = "2.1.0"
|
|
|
|
@ -9,18 +9,18 @@
|
|
|
|
|
features = ["deflate"]
|
|
|
|
|
optional = true
|
|
|
|
|
default-features = false
|
|
|
|
|
--- gix-archive-0.15.0/src/write.rs
|
|
|
|
|
+++ gix-archive-0.15.0/src/write.rs
|
|
|
|
|
@@ -126,7 +127,7 @@ where
|
|
|
|
|
--- gix-archive-0.19.0/src/write.rs
|
|
|
|
|
+++ gix-archive-0.19.0/src/write.rs
|
|
|
|
|
@@ -126,7 +126,7 @@ where
|
|
|
|
|
NextFn: FnMut(&mut Stream) -> Result<Option<Entry<'_>>, gix_worktree_stream::entry::Error>,
|
|
|
|
|
{
|
|
|
|
|
let compression_level = match opts.format {
|
|
|
|
|
- Format::Zip { compression_level } => compression_level.map(|lvl| lvl as i64),
|
|
|
|
|
- Format::Zip { compression_level } => compression_level.map(i64::from),
|
|
|
|
|
+ Format::Zip { compression_level } => compression_level.map(|lvl| lvl as i32),
|
|
|
|
|
_other => return write_stream(stream, next_entry, out, opts),
|
|
|
|
|
};
|
|
|
|
|
|
|
|
|
|
@@ -149,7 +150,7 @@ where
|
|
|
|
|
@@ -149,7 +149,7 @@ where
|
|
|
|
|
zdt.minute().try_into().expect("non-negative"),
|
|
|
|
|
zdt.second().try_into().expect("non-negative"),
|
|
|
|
|
)
|
|
|
|
@ -29,7 +29,7 @@
|
|
|
|
|
while let Some(entry) = next_entry(stream)? {
|
|
|
|
|
append_zip_entry(
|
|
|
|
|
&mut ar,
|
|
|
|
|
@@ -173,10 +174,10 @@ fn append_zip_entry<W: std::io::Write + std::io::Seek>(
|
|
|
|
|
@@ -173,10 +173,10 @@ fn append_zip_entry<W: std::io::Write + std::io::Seek>(
|
|
|
|
|
mut entry: gix_worktree_stream::Entry<'_>,
|
|
|
|
|
buf: &mut Vec<u8>,
|
|
|
|
|
mtime: zip::DateTime,
|
|
|
|
|