import rust-gix-archive-0.19.0-1.el10

i10ce changed/i10ce/rust-gix-archive-0.19.0-1.el10
MSVSphere Packaging Team 5 days ago
parent 74e0b6c51d
commit 6343a94023
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

2
.gitignore vendored

@ -1 +1 @@
SOURCES/gix-archive-0.15.0.crate
SOURCES/gix-archive-0.19.0.crate

@ -1 +1 @@
7001f789556d6eef083123ec0c345358943b9bb2 SOURCES/gix-archive-0.15.0.crate
7d711d2211abb65724fc3aa14628b20418d3ca4e SOURCES/gix-archive-0.19.0.crate

@ -1,7 +1,7 @@
--- gix-archive-0.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gix-archive-0.15.0/Cargo.toml 2024-09-07T18:05:21.490769+00:00
@@ -76,7 +76,7 @@
version = "1.0.26"
--- gix-archive-0.19.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gix-archive-0.19.0/Cargo.toml 2025-01-22T19:05:55.626544+00:00
@@ -77,7 +77,7 @@
version = "2.0.0"
[dependencies.zip]
-version = "2.1.0"
@ -9,18 +9,18 @@
features = ["deflate"]
optional = true
default-features = false
--- gix-archive-0.15.0/src/write.rs
+++ gix-archive-0.15.0/src/write.rs
@@ -126,7 +127,7 @@ where
--- gix-archive-0.19.0/src/write.rs
+++ gix-archive-0.19.0/src/write.rs
@@ -126,7 +126,7 @@ where
NextFn: FnMut(&mut Stream) -> Result<Option<Entry<'_>>, gix_worktree_stream::entry::Error>,
{
let compression_level = match opts.format {
- Format::Zip { compression_level } => compression_level.map(|lvl| lvl as i64),
- Format::Zip { compression_level } => compression_level.map(i64::from),
+ Format::Zip { compression_level } => compression_level.map(|lvl| lvl as i32),
_other => return write_stream(stream, next_entry, out, opts),
};
@@ -149,7 +150,7 @@ where
@@ -149,7 +149,7 @@ where
zdt.minute().try_into().expect("non-negative"),
zdt.second().try_into().expect("non-negative"),
)
@ -29,7 +29,7 @@
while let Some(entry) = next_entry(stream)? {
append_zip_entry(
&mut ar,
@@ -173,10 +174,10 @@ fn append_zip_entry<W: std::io::Write + std::io::Seek>(
@@ -173,10 +173,10 @@ fn append_zip_entry<W: std::io::Write + std::io::Seek>(
mut entry: gix_worktree_stream::Entry<'_>,
buf: &mut Vec<u8>,
mtime: zip::DateTime,

@ -1,5 +1,5 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
@ -8,16 +8,16 @@
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
# Generated by rust2rpm 27
# * Deactivate tests because of a missing dev-dependency (gix-testtools)
# * See https://github.com/Byron/gitoxide/discussions/900 for more information
%bcond_with check
%bcond check 0
%global debug_package %{nil}
%global crate gix-archive
Name: rust-gix-archive
Version: 0.15.0
Version: 0.19.0
Release: %autorelease
Summary: Archive generation from of a worktree stream
@ -132,10 +132,16 @@ use the "zip" feature of the "%{crate}" crate.
%endif
%changelog
## START: Generated by rpmautospec
* Wed Jan 22 2025 blinxen <h-k-81@hotmail.com> - 0.19.0-1
- Update to version 0.19.0 (rhbz#2321141)
* Sun Jan 19 2025 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_42_Mass_Rebuild
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.15.0-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Tue Sep 10 2024 blinxen <h-k-81@hotmail.com> - 0.15.0-1
- Update to version 0.15.0 (rhbz#2307375)

Loading…
Cancel
Save