commit
74e0b6c51d
@ -0,0 +1 @@
|
||||
SOURCES/gix-archive-0.15.0.crate
|
@ -0,0 +1 @@
|
||||
7001f789556d6eef083123ec0c345358943b9bb2 SOURCES/gix-archive-0.15.0.crate
|
@ -0,0 +1,44 @@
|
||||
--- gix-archive-0.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ gix-archive-0.15.0/Cargo.toml 2024-09-07T18:05:21.490769+00:00
|
||||
@@ -76,7 +76,7 @@
|
||||
version = "1.0.26"
|
||||
|
||||
[dependencies.zip]
|
||||
-version = "2.1.0"
|
||||
+version = "0.6.6"
|
||||
features = ["deflate"]
|
||||
optional = true
|
||||
default-features = false
|
||||
--- gix-archive-0.15.0/src/write.rs
|
||||
+++ gix-archive-0.15.0/src/write.rs
|
||||
@@ -126,7 +127,7 @@ where
|
||||
NextFn: FnMut(&mut Stream) -> Result<Option<Entry<'_>>, gix_worktree_stream::entry::Error>,
|
||||
{
|
||||
let compression_level = match opts.format {
|
||||
- Format::Zip { compression_level } => compression_level.map(|lvl| lvl as i64),
|
||||
+ Format::Zip { compression_level } => compression_level.map(|lvl| lvl as i32),
|
||||
_other => return write_stream(stream, next_entry, out, opts),
|
||||
};
|
||||
|
||||
@@ -149,7 +150,7 @@ where
|
||||
zdt.minute().try_into().expect("non-negative"),
|
||||
zdt.second().try_into().expect("non-negative"),
|
||||
)
|
||||
- .map_err(|err| Error::InvalidModificationTime(Box::new(err)))?;
|
||||
+ .map_err(|_| Error::InvalidModificationTime(Box::new(zip::result::DateTimeRangeError)))?;
|
||||
while let Some(entry) = next_entry(stream)? {
|
||||
append_zip_entry(
|
||||
&mut ar,
|
||||
@@ -173,10 +174,10 @@ fn append_zip_entry<W: std::io::Write + std::io::Seek>(
|
||||
mut entry: gix_worktree_stream::Entry<'_>,
|
||||
buf: &mut Vec<u8>,
|
||||
mtime: zip::DateTime,
|
||||
- compression_level: Option<i64>,
|
||||
+ compression_level: Option<i32>,
|
||||
tree_prefix: Option<&bstr::BString>,
|
||||
) -> Result<(), Error> {
|
||||
- let file_opts = zip::write::FileOptions::<'_, ()>::default()
|
||||
+ let file_opts = zip::write::FileOptions::default()
|
||||
.compression_method(zip::CompressionMethod::Deflated)
|
||||
.compression_level(compression_level)
|
||||
.large_file(entry.bytes_remaining().map_or(true, |len| len > u32::MAX as usize))
|
@ -0,0 +1,6 @@
|
||||
[tests]
|
||||
run = ["none"]
|
||||
comments = [
|
||||
"Deactivate tests because of a missing dev-dependency (gix-testtools)",
|
||||
"See https://github.com/Byron/gitoxide/discussions/900 for more information"
|
||||
]
|
@ -0,0 +1,162 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.2)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 26
|
||||
# * Deactivate tests because of a missing dev-dependency (gix-testtools)
|
||||
# * See https://github.com/Byron/gitoxide/discussions/900 for more information
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate gix-archive
|
||||
|
||||
Name: rust-gix-archive
|
||||
Version: 0.15.0
|
||||
Release: %autorelease
|
||||
Summary: Archive generation from of a worktree stream
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/gix-archive
|
||||
Source: %{crates_source}
|
||||
# Set zip version to 0.6 since that is the only version that is available at
|
||||
# the moment
|
||||
Patch: decrease-zip-version.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Archive generation from of a worktree stream.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
# We exclude the tests directory because they contain bash scripts
|
||||
# and the automatic Requires detection falsely adds bash as a required dependency.
|
||||
# Tests are disabled anyway so this should have no effect.
|
||||
%exclude %{crate_instdir}/tests
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+document-features-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+document-features-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "document-features" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+document-features-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tar-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tar-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tar" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tar-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+tar_gz-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+tar_gz-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "tar_gz" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+tar_gz-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zip-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zip-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zip" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zip-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.15.0-1
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Tue Sep 10 2024 blinxen <h-k-81@hotmail.com> - 0.15.0-1
|
||||
- Update to version 0.15.0 (rhbz#2307375)
|
||||
|
||||
* Thu Jul 25 2024 blinxen <h-k-81@hotmail.com> - 0.13.2-1
|
||||
- Update to version 0.13.2 (rhbz#2299561)
|
||||
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Sun Jul 07 2024 blinxen <h-k-81@hotmail.com> - 0.13.1-1
|
||||
- Update to version 0.13.1 (rhbz#2274892)
|
||||
|
||||
* Fri Apr 05 2024 blinxen <h-k-81@hotmail.com> - 0.11.0-1
|
||||
- Update to version 0.11.0 (rhbz#2253264)
|
||||
|
||||
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Fri Oct 13 2023 blinxen <h-k-81@hotmail.com> - 0.6.0-1
|
||||
- Update to version 0.6.0
|
||||
|
||||
* Wed Oct 04 2023 blinxen <h-k-81@hotmail.com> - 0.4.0-1
|
||||
- Initial package (rhbz#2242178)
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue