remove dependencies on compiler internals

epel9
Fabio Valentini 4 years ago
parent 86be88aa10
commit 68c6fdcd25
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -0,0 +1,9 @@
[DEFAULT]
unwanted-features =
compiler_builtins
core
rustc-dep-of-std
std
stdweb
test-in-browser
wasm-bindgen

@ -1,23 +1,18 @@
--- getrandom-0.1.15/Cargo.toml 2020-09-10T10:21:20+00:00
+++ getrandom-0.1.15/Cargo.toml 2020-10-07T13:48:42.774022+00:00
@@ -41,21 +41,11 @@
dummy = []
+++ getrandom-0.1.15/Cargo.toml 2020-11-28T13:48:16.106903+00:00
@@ -42,8 +42,6 @@
rustc-dep-of-std = ["compiler_builtins", "core"]
std = []
-test-in-browser = ["wasm-bindgen"]
test-in-browser = ["wasm-bindgen"]
-[target."cfg(target_os = \"wasi\")".dependencies.wasi]
-version = "0.9"
+
[target."cfg(unix)".dependencies.libc]
version = "0.2.64"
default-features = false
-[target.wasm32-unknown-unknown.dependencies.stdweb]
-version = "0.4.18"
-optional = true
-[target.wasm32-unknown-unknown.dependencies.wasm-bindgen]
-version = "0.2.29"
-optional = true
@@ -54,8 +52,6 @@
[target.wasm32-unknown-unknown.dependencies.wasm-bindgen]
version = "0.2.29"
optional = true
-[target.wasm32-unknown-unknown.dev-dependencies.wasm-bindgen-test]
-version = "0.2"
[badges.appveyor]

@ -1,4 +1,4 @@
# Generated by rust2rpm 13
# Generated by rust2rpm 16
%bcond_without check
%global debug_package %{nil}
@ -6,7 +6,7 @@
Name: rust-%{crate}0.1
Version: 0.1.15
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Small cross-platform library for retrieving random data from system source
# Upstream license specification: MIT OR Apache-2.0
@ -55,30 +55,6 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+compiler_builtins-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compiler_builtins-devel %{_description}
This package contains library source intended for building other packages
which use "compiler_builtins" feature of "%{crate}" crate.
%files -n %{name}+compiler_builtins-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+core-devel %{_description}
This package contains library source intended for building other packages
which use "core" feature of "%{crate}" crate.
%files -n %{name}+core-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+dummy-devel
Summary: %{summary}
BuildArch: noarch
@ -103,30 +79,6 @@ which use "log" feature of "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustc-dep-of-std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc-dep-of-std-devel %{_description}
This package contains library source intended for building other packages
which use "rustc-dep-of-std" feature of "%{crate}" crate.
%files -n %{name}+rustc-dep-of-std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -146,5 +98,8 @@ which use "std" feature of "%{crate}" crate.
%endif
%changelog
* Sat Nov 28 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.15-2
- Remove dependencies on compiler internals.
* Wed Oct 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.15-1
- Initial compat package for getrandom 0.1

Loading…
Cancel
Save