parent
10a544d210
commit
86be88aa10
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/getrandom-0.1.15.crate
|
@ -0,0 +1,25 @@
|
||||
--- getrandom-0.1.15/Cargo.toml 2020-09-10T10:21:20+00:00
|
||||
+++ getrandom-0.1.15/Cargo.toml 2020-10-07T13:48:42.774022+00:00
|
||||
@@ -41,21 +41,11 @@
|
||||
dummy = []
|
||||
rustc-dep-of-std = ["compiler_builtins", "core"]
|
||||
std = []
|
||||
-test-in-browser = ["wasm-bindgen"]
|
||||
-[target."cfg(target_os = \"wasi\")".dependencies.wasi]
|
||||
-version = "0.9"
|
||||
+
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2.64"
|
||||
default-features = false
|
||||
-[target.wasm32-unknown-unknown.dependencies.stdweb]
|
||||
-version = "0.4.18"
|
||||
-optional = true
|
||||
|
||||
-[target.wasm32-unknown-unknown.dependencies.wasm-bindgen]
|
||||
-version = "0.2.29"
|
||||
-optional = true
|
||||
-[target.wasm32-unknown-unknown.dev-dependencies.wasm-bindgen-test]
|
||||
-version = "0.2"
|
||||
[badges.appveyor]
|
||||
repository = "rust-random/getrandom"
|
||||
|
@ -0,0 +1,150 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate getrandom
|
||||
|
||||
Name: rust-%{crate}0.1
|
||||
Version: 0.1.15
|
||||
Release: 1%{?dist}
|
||||
Summary: Small cross-platform library for retrieving random data from system source
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/getrandom
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * No wasi / wasm deps
|
||||
Patch0: getrandom-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Small cross-platform library for retrieving random data from system source.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+compiler_builtins-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+compiler_builtins-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "compiler_builtins" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+compiler_builtins-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "core" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+core-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+dummy-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+dummy-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "dummy" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+dummy-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+log-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+log-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "log" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+log-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustc-dep-of-std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustc-dep-of-std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "rustc-dep-of-std" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustc-dep-of-std-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "std" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Oct 07 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.15-1
|
||||
- Initial compat package for getrandom 0.1
|
Loading…
Reference in new issue