Update to 0.2.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 63da648334
commit 14c45d4c91
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/futures-util-0.2.1.crate
/futures-util-0.2.2.crate

@ -0,0 +1,41 @@
--- futures-util-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-util-preview-0.2.2/Cargo.toml 2018-09-11T07:23:42.837228+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-util-preview"
+name = "futures-util"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "Common utilities and extension traits for the futures-rs library.\n"
@@ -26,23 +26,23 @@
version = "1.4"
default-features = false
-[dependencies.futures-channel-preview]
+[dependencies.futures-channel]
version = "0.2.2"
default-features = false
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
-[dependencies.futures-io-preview]
+[dependencies.futures-io]
version = "0.2.2"
default-features = false
-[dependencies.futures-sink-preview]
+[dependencies.futures-sink]
version = "0.2.2"
default-features = false
[features]
bench = []
-default = ["std", "futures-core-preview/either", "futures-sink-preview/either"]
-std = ["futures-core-preview/std", "futures-io-preview/std", "futures-sink-preview/std", "either/use_std"]
+default = ["std", "futures-core/either", "futures-sink/either"]
+std = ["futures-core/std", "futures-io/std", "futures-sink/std", "either/use_std"]

@ -5,26 +5,30 @@
%global debug_package %{nil}
%global crate futures-util
%global real_crate futures-util-preview
Name: rust-%{crate}
Version: 0.2.1
Release: 2%{?dist}
Version: 0.2.2
Release: 1%{?dist}
Summary: Common utilities and extension traits for the futures-rs library
# https://github.com/rust-lang-nursery/futures-rs/issues/1015
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-util
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
URL: https://crates.io/crates/futures-util-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-util-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(either) >= 1.4.0 with crate(either) < 2.0.0)
BuildRequires: (crate(futures-channel) >= 0.2.1 with crate(futures-channel) < 0.3.0)
BuildRequires: (crate(futures-core) >= 0.2.1 with crate(futures-core) < 0.3.0)
BuildRequires: (crate(futures-io) >= 0.2.1 with crate(futures-io) < 0.3.0)
BuildRequires: (crate(futures-sink) >= 0.2.1 with crate(futures-sink) < 0.3.0)
BuildRequires: (crate(futures-channel) >= 0.2.2 with crate(futures-channel) < 0.3.0)
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
BuildRequires: (crate(futures-io) >= 0.2.2 with crate(futures-io) < 0.3.0)
BuildRequires: (crate(futures-sink) >= 0.2.2 with crate(futures-sink) < 0.3.0)
%description
%{summary}.
@ -40,9 +44,7 @@ This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{crate}-%{version} -p1
# https://github.com/rust-lang-nursery/futures-rs/pull/1016
find -type f -name '*.rs' -executable -exec chmod -x {} +
%autosetup -n %{real_crate}-%{version} -p1
%cargo_prep
%build
@ -57,9 +59,13 @@ find -type f -name '*.rs' -executable -exec chmod -x {} +
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1 +1 @@
SHA512 (futures-util-0.2.1.crate) = 22bbb05f7e3f79c7696dd46ae036968dc193a36dc298802c1b22375f5ea317f948dd71ee59dde71aad0d7bf3d074c682ebc8c1fa0716432410430886ea57df32
SHA512 (futures-util-0.2.2.crate) = 8bc674653415e0ac3458db682d2ecfa836a9a5b18db45bc1e9d5129e9da25645b18e8c92cbd2280e49502af5c7d7b50574c471dc2863fa1f314a3f57b2aa647e

Loading…
Cancel
Save