Update to 8.7.1

Signed-off-by: Michel Lind <salimma@fedoraproject.org>
epel9 imports/e9/rust-fd-find-8.7.1-1.el9
Michel Lind 1 year ago
parent 1a57d05b33
commit 8dd9680a51
No known key found for this signature in database
GPG Key ID: 8B229D2F7CCC04F2

1
.gitignore vendored

@ -12,3 +12,4 @@
/fd-find-8.1.1.crate
/fd-find-8.2.1.crate
/fd-find-8.7.0.crate
/fd-find-8.7.1.crate

@ -1,17 +1,6 @@
From 583c52363f28fadb26e28cab12b9595308b87104 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Fri, 3 Mar 2023 11:55:20 +0100
Subject: [PATCH] Remove usage of jemallocator
---
src/main.rs | 14 --------------
1 file changed, 14 deletions(-)
diff --git a/src/main.rs b/src/main.rs
index 567058c..7de2bce 100644
--- a/src/main.rs
+++ b/src/main.rs
@@ -33,20 +33,6 @@ use crate::filter::OwnerFilter;
@@ -33,21 +33,6 @@ use crate::filter::OwnerFilter;
use crate::filter::TimeFilter;
use crate::regex_helper::{pattern_has_uppercase_char, pattern_matches_strings_with_leading_dot};
@ -22,6 +11,7 @@ index 567058c..7de2bce 100644
- not(target_os = "android"),
- not(target_os = "macos"),
- not(target_os = "freebsd"),
- not(target_os = "openbsd"),
- not(all(target_env = "musl", target_pointer_width = "32")),
- not(target_arch = "riscv64"),
- feature = "use-jemalloc"
@ -32,6 +22,3 @@ index 567058c..7de2bce 100644
// vivid --color-mode 8-bit generate molokai
const DEFAULT_LS_COLORS: &str = "
ow=0:or=0;38;5;16;48;5;203:no=0:ex=1;38;5;203:cd=0;38;5;203;48;5;236:mi=0;38;5;16;48;5;203:*~=0;38;5;243:st=0:pi=0;38;5;16;48;5;81:fi=0:di=0;38;5;81:so=0;38;5;16;48;5;203:bd=0;38;5;81;48;5;236:tw=0:ln=0;38;5;203:*.m=0;38;5;48:*.o=0;38;5;243:*.z=4;38;5;203:*.a=1;38;5;203:*.r=0;38;5;48:*.c=0;38;5;48:*.d=0;38;5;48:*.t=0;38;5;48:*.h=0;38;5;48:*.p=0;38;5;48:*.cc=0;38;5;48:*.ll=0;38;5;48:*.jl=0;38;5;48:*css=0;38;5;48:*.md=0;38;5;185:*.gz=4;38;5;203:*.nb=0;38;5;48:*.mn=0;38;5;48:*.go=0;38;5;48:*.xz=4;38;5;203:*.so=1;38;5;203:*.rb=0;38;5;48:*.pm=0;38;5;48:*.bc=0;38;5;243:*.py=0;38;5;48:*.as=0;38;5;48:*.pl=0;38;5;48:*.rs=0;38;5;48:*.sh=0;38;5;48:*.7z=4;38;5;203:*.ps=0;38;5;186:*.cs=0;38;5;48:*.el=0;38;5;48:*.rm=0;38;5;208:*.hs=0;38;5;48:*.td=0;38;5;48:*.ui=0;38;5;149:*.ex=0;38;5;48:*.js=0;38;5;48:*.cp=0;38;5;48:*.cr=0;38;5;48:*.la=0;38;5;243:*.kt=0;38;5;48:*.ml=0;38;5;48:*.vb=0;38;5;48:*.gv=0;38;5;48:*.lo=0;38;5;243:*.hi=0;38;5;243:*.ts=0;38;5;48:*.ko=1;38;5;203:*.hh=0;38;5;48:*.pp=0;38;5;48:*.di=0;38;5;48:*.bz=4;38;5;203:*.fs=0;38;5;48:*.png=0;38;5;208:*.zsh=0;38;5;48:*.mpg=0;38;5;208:*.pid=0;38;5;243:*.xmp=0;38;5;149:*.iso=4;38;5;203:*.m4v=0;38;5;208:*.dot=0;38;5;48:*.ods=0;38;5;186:*.inc=0;38;5;48:*.sxw=0;38;5;186:*.aif=0;38;5;208:*.git=0;38;5;243:*.gvy=0;38;5;48:*.tbz=4;38;5;203:*.log=0;38;5;243:*.txt=0;38;5;185:*.ico=0;38;5;208:*.csx=0;38;5;48:*.vob=0;38;5;208:*.pgm=0;38;5;208:*.pps=0;38;5;186:*.ics=0;38;5;186:*.img=4;38;5;203:*.fon=0;38;5;208:*.hpp=0;38;5;48:*.bsh=0;38;5;48:*.sql=0;38;5;48:*TODO=1:*.php=0;38;5;48:*.pkg=4;38;5;203:*.ps1=0;38;5;48:*.csv=0;38;5;185:*.ilg=0;38;5;243:*.ini=0;38;5;149:*.pyc=0;38;5;243:*.psd=0;38;5;208:*.htc=0;38;5;48:*.swp=0;38;5;243:*.mli=0;38;5;48:*hgrc=0;38;5;149:*.bst=0;38;5;149:*.ipp=0;38;5;48:*.fsi=0;38;5;48:*.tcl=0;38;5;48:*.exs=0;38;5;48:*.out=0;38;5;243:*.jar=4;38;5;203:*.xls=0;38;5;186:*.ppm=0;38;5;208:*.apk=4;38;5;203:*.aux=0;38;5;243:*.rpm=4;38;5;203:*.dll=1;38;5;203:*.eps=0;38;5;208:*.exe=1;38;5;203:*.doc=0;38;5;186:*.wma=0;38;5;208:*.deb=4;38;5;203:*.pod=0;38;5;48:*.ind=0;38;5;243:*.nix=0;38;5;149:*.lua=0;38;5;48:*.epp=0;38;5;48:*.dpr=0;38;5;48:*.htm=0;38;5;185:*.ogg=0;38;5;208:*.bin=4;38;5;203:*.otf=0;38;5;208:*.yml=0;38;5;149:*.pro=0;38;5;149:*.cxx=0;38;5;48:*.tex=0;38;5;48:*.fnt=0;38;5;208:*.erl=0;38;5;48:*.sty=0;38;5;243:*.bag=4;38;5;203:*.rst=0;38;5;185:*.pdf=0;38;5;186:*.pbm=0;38;5;208:*.xcf=0;38;5;208:*.clj=0;38;5;48:*.gif=0;38;5;208:*.rar=4;38;5;203:*.elm=0;38;5;48:*.bib=0;38;5;149:*.tsx=0;38;5;48:*.dmg=4;38;5;203:*.tmp=0;38;5;243:*.bcf=0;38;5;243:*.mkv=0;38;5;208:*.svg=0;38;5;208:*.cpp=0;38;5;48:*.vim=0;38;5;48:*.bmp=0;38;5;208:*.ltx=0;38;5;48:*.fls=0;38;5;243:*.flv=0;38;5;208:*.wav=0;38;5;208:*.m4a=0;38;5;208:*.mid=0;38;5;208:*.hxx=0;38;5;48:*.pas=0;38;5;48:*.wmv=0;38;5;208:*.tif=0;38;5;208:*.kex=0;38;5;186:*.mp4=0;38;5;208:*.bak=0;38;5;243:*.xlr=0;38;5;186:*.dox=0;38;5;149:*.swf=0;38;5;208:*.tar=4;38;5;203:*.tgz=4;38;5;203:*.cfg=0;38;5;149:*.xml=0;
--
2.39.2

@ -1,30 +1,21 @@
--- fd-find-8.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ fd-find-8.7.0/Cargo.toml 2023-04-19T14:25:00.184230+00:00
@@ -63,7 +63,6 @@
"color",
"wrap_help",
"cargo",
- "unstable-grouped",
"derive",
]
@@ -131,17 +130,9 @@
--- fd-find-8.7.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ fd-find-8.7.1/Cargo.toml 2023-10-27T04:29:57.025911+00:00
@@ -125,17 +125,11 @@
version = "0.9"
[features]
-base = ["use-jemalloc"]
+base = []
completions = ["clap_complete"]
-default = [
default = [
- "use-jemalloc",
- "completions",
-]
"completions",
]
-use-jemalloc = ["jemallocator"]
-
-[target."cfg(all(not(windows), not(target_os = \"android\"), not(target_os = \"macos\"), not(target_os = \"freebsd\"), not(all(target_env = \"musl\", target_pointer_width = \"32\")), not(target_arch = \"riscv64\")))".dependencies.jemallocator]
-version = "0.5.0"
-[target."cfg(all(not(windows), not(target_os = \"android\"), not(target_os = \"macos\"), not(target_os = \"freebsd\"), not(target_os = \"openbsd\"), not(all(target_env = \"musl\", target_pointer_width = \"32\")), not(target_arch = \"riscv64\")))".dependencies.jemallocator]
-version = "0.5.4"
-optional = true
+default = ["completions"]
[target."cfg(all(unix, not(target_os = \"redox\")))".dependencies.libc]
version = "0.2"

@ -4,20 +4,18 @@
%global crate fd-find
Name: rust-fd-find
Version: 8.7.0
Version: 8.7.1
Release: %autorelease
Summary: Fd is a simple, fast and user-friendly alternative to find
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/fd-find
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop jemallocator dependency
# * remove stabilized but previously unstable "clap/unstable-grouped" feature
Patch: fd-find-fix-metadata.diff
# * drop jemallocator from code
Patch: 0001-Remove-usage-of-jemallocator.patch
Patch: fd-find-8.7.1-remove_usage_of_jemallocator.diff
BuildRequires: rust-packaging >= 23
@ -61,8 +59,7 @@ License: MIT AND Unicode-DFS-2016
%build
%cargo_build
# write license summary and breakdown
%cargo_license_summary
%{cargo_license_summary}
%{cargo_license} > LICENSE.dependencies
# generate shell completions
./target/release/fd --gen-completions bash > fd.bash

@ -1 +1 @@
SHA512 (fd-find-8.7.0.crate) = 0e33cfeff0b85d6c93efae0668d095c736ee1fc9a2502e3c62eb30e2ae1ad87476484163cd8881f5e0a9dd7b6ad3087e9b53756cd7a9b937383bbf7ec54ecd55
SHA512 (fd-find-8.7.1.crate) = 6a8a21e3c44ba01b3becea919876bab8833663767803705f4101ce050e57530fd0ed57a9f4d7a16aa5708e409128bfce47be8cef0cbaf9145c360355e919aa17

Loading…
Cancel
Save