Update to version 0.4.68+curl-8.4.0; Fixes RHBZ#2242878

epel9
Fabio Valentini 1 year ago
parent ce6ffa0005
commit 4f94d0e3c9
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -38,3 +38,4 @@
/curl-sys-0.4.63+curl-8.1.2.crate /curl-sys-0.4.63+curl-8.1.2.crate
/curl-sys-0.4.65+curl-8.2.1.crate /curl-sys-0.4.65+curl-8.2.1.crate
/curl-sys-0.4.66+curl-8.3.0.crate /curl-sys-0.4.66+curl-8.3.0.crate
/curl-sys-0.4.68+curl-8.4.0.crate

@ -1,17 +1,17 @@
From b0143ab5f65f5ddc83ca25a4a730fefd0b3cbf77 Mon Sep 17 00:00:00 2001 From e5f806557a9a83492b3000942fa0833316d066cd Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com> From: Fabio Valentini <decathorpe@gmail.com>
Date: Tue, 19 Sep 2023 21:03:22 +0200 Date: Tue, 17 Oct 2023 13:21:16 +0200
Subject: [PATCH] unconditionally use pkg-config to link with system libcurl Subject: [PATCH] unconditionally use pkg-config to link with system libcurl
--- ---
build.rs | 583 +------------------------------------------------------ build.rs | 584 +------------------------------------------------------
1 file changed, 5 insertions(+), 578 deletions(-) 1 file changed, 5 insertions(+), 579 deletions(-)
diff --git a/build.rs b/build.rs diff --git a/build.rs b/build.rs
index b373795..497789c 100644 index 74f601b..497789c 100644
--- a/build.rs --- a/build.rs
+++ b/build.rs +++ b/build.rs
@@ -1,607 +1,34 @@ @@ -1,608 +1,34 @@
-use std::env; -use std::env;
-use std::fs; -use std::fs;
-use std::path::{Path, PathBuf}; -use std::path::{Path, PathBuf};
@ -114,7 +114,7 @@ index b373795..497789c 100644
- .replace("@LIBCURL_LIBS@", "") - .replace("@LIBCURL_LIBS@", "")
- .replace("@SUPPORT_FEATURES@", "") - .replace("@SUPPORT_FEATURES@", "")
- .replace("@SUPPORT_PROTOCOLS@", "") - .replace("@SUPPORT_PROTOCOLS@", "")
- .replace("@CURLVERSION@", "8.3.0"), - .replace("@CURLVERSION@", "8.4.0"),
- ) - )
- .unwrap(); - .unwrap();
- -
@ -457,6 +457,7 @@ index b373795..497789c 100644
- if target.contains("-apple-") { - if target.contains("-apple-") {
- println!("cargo:rustc-link-lib=framework=Security"); - println!("cargo:rustc-link-lib=framework=Security");
- println!("cargo:rustc-link-lib=framework=CoreFoundation"); - println!("cargo:rustc-link-lib=framework=CoreFoundation");
- println!("cargo:rustc-link-lib=framework=CoreServices");
- println!("cargo:rustc-link-lib=framework=SystemConfiguration"); - println!("cargo:rustc-link-lib=framework=SystemConfiguration");
- } - }
-} -}

@ -1,6 +1,15 @@
--- curl-sys-0.4.66+curl-8.3.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- curl-sys-0.4.68+curl-8.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.66+curl-8.3.0/Cargo.toml 2023-09-19T18:57:08.513558+00:00 +++ curl-sys-0.4.68+curl-8.4.0/Cargo.toml 2023-10-17T11:13:59.847744+00:00
@@ -73,13 +73,6 @@ @@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.68+curl-8.4.0"
+version = "0.4.68"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@@ -73,15 +73,10 @@
version = "0.9.64" version = "0.9.64"
optional = true optional = true
@ -14,3 +23,7 @@
[badges.appveyor] [badges.appveyor]
repository = "alexcrichton/curl-rust" repository = "alexcrichton/curl-rust"
[badges.travis-ci]
repository = "alexcrichton/curl-rust"
+
+

@ -1,14 +1,5 @@
--- curl-sys-0.4.66+curl-8.3.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- curl-sys-0.4.68+curl-8.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.66+curl-8.3.0/Cargo.toml 2023-09-19T18:58:10.795767+00:00 +++ curl-sys-0.4.68+curl-8.4.0/Cargo.toml 2023-10-17T11:14:46.252970+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.66+curl-8.3.0"
+version = "0.4.66"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@@ -29,20 +29,6 @@ @@ -29,20 +29,6 @@
[dependencies.libc] [dependencies.libc]
version = "0.2.2" version = "0.2.2"

@ -1,19 +1,19 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate curl-sys %global crate curl-sys
%global crate_version 0.4.66+curl-8.3.0 %global upstream_version 0.4.68+curl-8.4.0
Name: rust-curl-sys Name: rust-curl-sys
Version: 0.4.66 Version: 0.4.68
Release: %autorelease Release: %autorelease
Summary: Native bindings to the libcurl library Summary: Native bindings to the libcurl library
License: MIT License: MIT
URL: https://crates.io/crates/curl-sys URL: https://crates.io/crates/curl-sys
Source: %{crates_source %{crate} %{crate_version}} Source: %{crates_source %{crate} %{upstream_version}}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: curl-sys-fix-metadata-auto.diff Patch: curl-sys-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * remove curl version suffix from crate version # * remove curl version suffix from crate version
@ -26,7 +26,7 @@ Patch: curl-sys-fix-metadata.diff
# * unconditionally use pkg-config to link with system libcurl # * unconditionally use pkg-config to link with system libcurl
Patch: 0001-unconditionally-use-pkg-config-to-link-with-system-l.patch Patch: 0001-unconditionally-use-pkg-config-to-link-with-system-l.patch
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Native bindings to the libcurl library.} Native bindings to the libcurl library.}
@ -156,7 +156,7 @@ use the "upkeep_7_62_0" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{crate_version} -p1 %autosetup -n %{crate}-%{upstream_version} -p1
# remove bundled curl sources # remove bundled curl sources
rm -vr curl/ rm -vr curl/
%cargo_prep %cargo_prep

@ -1,5 +0,0 @@
[DEFAULT]
buildrequires =
pkgconfig(libcurl)
lib.requires =
pkgconfig(libcurl)

@ -0,0 +1,4 @@
[requires]
build = ["pkgconfig(libcurl)"]
lib = ["pkgconfig(libcurl)"]

@ -1 +1 @@
SHA512 (curl-sys-0.4.66+curl-8.3.0.crate) = 2b13381ac0a88e46e0ec009bc5cc7e1ea71c94ea4156d002952e6ecb990e29ddcdb2947b2b7e21fb280823318cb93a8eceeb6e9de438917e65d91a0aa5d297ce SHA512 (curl-sys-0.4.68+curl-8.4.0.crate) = 1ce2e0c60618be5147e6c26bef1a2128934908e0fe728f7610eabfbcb02f5407408230f0dbba3c9c45d63b12da4f01f6b4a972456f8efb12e64ecd0c3356bbc0

Loading…
Cancel
Save