Update to version 0.15.1; Fixes RHBZ#2111568

epel9
Fabio Valentini 3 years ago
parent edd13b0ede
commit 90146b447d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -13,3 +13,4 @@
/console-0.14.0.crate /console-0.14.0.crate
/console-0.14.1.crate /console-0.14.1.crate
/console-0.15.0.crate /console-0.15.0.crate
/console-0.15.1.crate

@ -0,0 +1,25 @@
--- console-0.15.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ console-0.15.1/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -62,22 +62,5 @@
windows-console-colors = [
"ansi-parsing",
"regex",
- "winapi-util",
]
-[target."cfg(windows)".dependencies.encode_unicode]
-version = "0.3"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = [
- "winbase",
- "winuser",
- "consoleapi",
- "processenv",
- "wincon",
-]
-
-[target."cfg(windows)".dependencies.winapi-util]
-version = "0.1.3"
-optional = true

@ -1,17 +0,0 @@
--- console-0.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ console-0.15.0/Cargo.toml 2022-01-12T13:38:01.449677+00:00
@@ -43,14 +43,3 @@
[features]
ansi-parsing = ["regex"]
default = ["unicode-width", "ansi-parsing"]
-windows-console-colors = ["ansi-parsing", "winapi-util"]
-[target."cfg(windows)".dependencies.encode_unicode]
-version = "0.3"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winbase", "winuser", "consoleapi", "processenv", "wincon"]
-
-[target."cfg(windows)".dependencies.winapi-util]
-version = "0.1.3"
-optional = true

@ -1,25 +1,23 @@
# Generated by rust2rpm 20 # Generated by rust2rpm 22
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate console %global crate console
Name: rust-%{crate} Name: rust-console
Version: 0.15.0 Version: 0.15.1
Release: %autorelease Release: %autorelease
Summary: Terminal and console abstraction for Rust Summary: Terminal and console abstraction for Rust
# Upstream license specification: MIT
License: MIT License: MIT
URL: https://crates.io/crates/console URL: https://crates.io/crates/console
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Automatically generated patch to strip foreign dependencies
# * drop windows-specific dependencies Patch: console-fix-metadata-auto.diff
Patch0: console-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Terminal and console abstraction for Rust.} Terminal and console abstraction for Rust.}
@ -36,9 +34,10 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license %{crate_instdir}/LICENSE
%doc CHANGELOG.md README.md %doc %{crate_instdir}/CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -50,7 +49,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ansi-parsing-devel %package -n %{name}+ansi-parsing-devel
Summary: %{summary} Summary: %{summary}
@ -62,7 +61,7 @@ This package contains library source intended for building other packages which
use the "ansi-parsing" feature of the "%{crate}" crate. use the "ansi-parsing" feature of the "%{crate}" crate.
%files -n %{name}+ansi-parsing-devel %files -n %{name}+ansi-parsing-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+regex-devel %package -n %{name}+regex-devel
Summary: %{summary} Summary: %{summary}
@ -74,7 +73,7 @@ This package contains library source intended for building other packages which
use the "regex" feature of the "%{crate}" crate. use the "regex" feature of the "%{crate}" crate.
%files -n %{name}+regex-devel %files -n %{name}+regex-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unicode-width-devel %package -n %{name}+unicode-width-devel
Summary: %{summary} Summary: %{summary}
@ -86,7 +85,7 @@ This package contains library source intended for building other packages which
use the "unicode-width" feature of the "%{crate}" crate. use the "unicode-width" feature of the "%{crate}" crate.
%files -n %{name}+unicode-width-devel %files -n %{name}+unicode-width-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -0,0 +1,3 @@
[DEFAULT]
unwanted-features =
windows-console-colors

@ -1 +1 @@
SHA512 (console-0.15.0.crate) = 70bd6abfafa533903f273ec3b34da6783856bd1abedaf139fddafac0dbb03fa9154f8e1e1bef01fd8de3c53100bbaa93313518c42f8ce51217c23ef34d3f9d62 SHA512 (console-0.15.1.crate) = af00a4c8c7ffdd4e6f6c638b52dd4e829b90235b63256215ce04ffc9e3fec8384a032ca664fc4f00a912ce6b5db04990cdf7f60873fe657bf99e811525acc8c2

Loading…
Cancel
Save