Update to version 0.4.27; Fixes RHBZ#2235737

epel9
Fabio Valentini 2 years ago
parent a41706ddd5
commit a08af28fb5
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -19,3 +19,4 @@
/chrono-0.4.24.crate /chrono-0.4.24.crate
/chrono-0.4.25.crate /chrono-0.4.25.crate
/chrono-0.4.26.crate /chrono-0.4.26.crate
/chrono-0.4.27.crate

@ -1,20 +1,13 @@
--- chrono-0.4.26/Cargo.toml 1970-01-01T00:00:01+00:00 --- chrono-0.4.27/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.26/Cargo.toml 2023-05-31T11:36:00.457992+00:00 +++ chrono-0.4.27/Cargo.toml 2023-08-29T21:05:55.635779+00:00
@@ -107,7 +107,6 @@ @@ -125,34 +125,11 @@
alloc = []
clock = [
"std",
- "winapi",
"iana-time-zone",
]
default = [
@@ -124,36 +123,10 @@
"alloc", "alloc",
] ]
wasmbind = [ wasmbind = [
- "wasm-bindgen", - "wasm-bindgen",
- "js-sys", - "js-sys",
] ]
-winapi = ["windows-targets"]
- -
-[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys] -[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys]
-version = "0.3" -version = "0.3"
@ -29,19 +22,17 @@
- -
-[target."cfg(target_os = \"android\")".dependencies.android-tzdata] -[target."cfg(target_os = \"android\")".dependencies.android-tzdata]
-version = "0.1.1" -version = "0.1.1"
-optional = true
+winapi = []
[target."cfg(unix)".dependencies.iana-time-zone] [target."cfg(unix)".dependencies.iana-time-zone]
version = "0.1.45" version = "0.1.45"
features = ["fallback"] features = ["fallback"]
optional = true optional = true
-[target."cfg(windows)".dependencies.winapi] -[target."cfg(windows)".dependencies.windows-targets]
-version = "0.3.0" -version = "0.48"
-features = [
- "std",
- "minwinbase",
- "minwindef",
- "timezoneapi",
- "sysinfoapi",
-]
-optional = true -optional = true
-
-[target."cfg(windows)".dev-dependencies.windows-bindgen]
-version = "0.51"

@ -1,5 +1,5 @@
--- chrono-0.4.26/Cargo.toml 1970-01-01T00:00:01+00:00 --- chrono-0.4.27/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.26/Cargo.toml 2023-05-31T11:36:51.237220+00:00 +++ chrono-0.4.27/Cargo.toml 2023-08-29T21:07:07.280031+00:00
@@ -41,26 +41,9 @@ @@ -41,26 +41,9 @@
[lib] [lib]
name = "chrono" name = "chrono"
@ -27,15 +27,20 @@
optional = true optional = true
[dependencies.num-traits] [dependencies.num-traits]
@@ -103,7 +86,6 @@ @@ -102,20 +85,15 @@
version = "1"
[features] [features]
__doctest = [] -__doctest = []
-__internal_bench = ["criterion"] -__internal_bench = ["criterion"]
alloc = [] alloc = []
clock = [ clock = [
"std", "std",
@@ -113,7 +95,6 @@ - "winapi",
"iana-time-zone",
- "android-tzdata",
]
default = [
"clock", "clock",
"std", "std",
"oldtime", "oldtime",
@ -43,12 +48,13 @@
] ]
libc = [] libc = []
oldtime = ["time"] oldtime = ["time"]
@@ -122,8 +103,6 @@ @@ -124,9 +102,6 @@
"pure-rust-locales", "pure-rust-locales",
"alloc", "alloc",
] ]
-wasmbind = [ -wasmbind = [
-] -]
-winapi = []
[target."cfg(unix)".dependencies.iana-time-zone] [target."cfg(unix)".dependencies.iana-time-zone]
version = "0.1.45" version = "0.1.45"

@ -5,18 +5,17 @@
%global crate chrono %global crate chrono
Name: rust-chrono Name: rust-chrono
Version: 0.4.26 Version: 0.4.27
Release: %autorelease Release: %autorelease
Summary: Date and time library for Rust Summary: Date and time library for Rust
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/chrono URL: https://crates.io/crates/chrono
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip foreign dependencies
Patch: chrono-fix-metadata-auto.diff Patch: chrono-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * remove WASM-specific features # * remove WASM- and doc-specific features
# * drop unused, benchmark-only criterion dev-dependency to speed up builds # * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch: chrono-fix-metadata.diff Patch: chrono-fix-metadata.diff

@ -1,4 +1,2 @@
[DEFAULT] [DEFAULT]
all-features = true all-features = true
unwanted-features =
__doctest

@ -1 +1 @@
SHA512 (chrono-0.4.26.crate) = 2b66faf4d8374cfb0485710ceb2c9c1ce63aa6f9670e405a0810af4aca01c57d8dcd198a1f4cad498d5efd89e00003ba1b4f0bab599422af4f9bd6fb74494c47 SHA512 (chrono-0.4.27.crate) = 19c86589c11905ca16d68e59b500717329d08a9a431bbb51eabc2e1b15d1ab8902188e05337b0ec6fccc0c268a073c4e280dbd6605e80d4d4fcb17a4fdc5d9f0

Loading…
Cancel
Save