parent
67243c99ae
commit
d1be2887a2
@ -1,169 +0,0 @@
|
||||
diff -Naur a/patched-crates/below-common/Cargo.toml b/patched-crates/below-common/Cargo.toml
|
||||
--- a/patched-crates/below-common/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
|
||||
+++ b/patched-crates/below-common/Cargo.toml 2021-11-11 10:55:02.722814393 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below-common"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/below-common/src/dateutil.rs b/patched-crates/below-common/src/dateutil.rs
|
||||
--- a/patched-crates/below-common/src/dateutil.rs 2021-11-11 10:54:23.798601187 -0800
|
||||
+++ b/patched-crates/below-common/src/dateutil.rs 2021-11-11 10:55:02.723814398 -0800
|
||||
@@ -302,7 +302,7 @@
|
||||
let mut default_format = String::new();
|
||||
let mut date_with_defaults = date.clone();
|
||||
let mut use_now = false;
|
||||
- for part in ["S", "M", "HI", "d", "mb", "Yy"] {
|
||||
+ for part in ["S", "M", "HI", "d", "mb", "Yy"].iter() {
|
||||
if part
|
||||
.chars()
|
||||
.any(|ch| naive_format.contains(&format!("%{}", ch)))
|
||||
diff -Naur a/patched-crates/below-config/Cargo.toml b/patched-crates/below-config/Cargo.toml
|
||||
--- a/patched-crates/below-config/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
|
||||
+++ b/patched-crates/below-config/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below-config"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/below_derive/Cargo.toml b/patched-crates/below_derive/Cargo.toml
|
||||
--- a/patched-crates/below_derive/Cargo.toml 2021-11-11 10:54:23.802601209 -0800
|
||||
+++ b/patched-crates/below_derive/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below_derive"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/below-dump/Cargo.toml b/patched-crates/below-dump/Cargo.toml
|
||||
--- a/patched-crates/below-dump/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
|
||||
+++ b/patched-crates/below-dump/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below-dump"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/below-model/Cargo.toml b/patched-crates/below-model/Cargo.toml
|
||||
--- a/patched-crates/below-model/Cargo.toml 2021-11-11 10:54:23.799601192 -0800
|
||||
+++ b/patched-crates/below-model/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below-model"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/below-render/Cargo.toml b/patched-crates/below-render/Cargo.toml
|
||||
--- a/patched-crates/below-render/Cargo.toml 2021-11-11 10:54:23.800601198 -0800
|
||||
+++ b/patched-crates/below-render/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below-render"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/below-store/Cargo.toml b/patched-crates/below-store/Cargo.toml
|
||||
--- a/patched-crates/below-store/Cargo.toml 2021-11-11 10:54:23.800601198 -0800
|
||||
+++ b/patched-crates/below-store/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below-store"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/below-view/Cargo.toml b/patched-crates/below-view/Cargo.toml
|
||||
--- a/patched-crates/below-view/Cargo.toml 2021-11-11 10:54:23.801601203 -0800
|
||||
+++ b/patched-crates/below-view/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "below-view"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/cgroupfs/Cargo.toml b/patched-crates/cgroupfs/Cargo.toml
|
||||
--- a/patched-crates/cgroupfs/Cargo.toml 2021-11-11 10:54:23.807601236 -0800
|
||||
+++ b/patched-crates/cgroupfs/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "cgroupfs"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/fb_procfs/Cargo.toml b/patched-crates/fb_procfs/Cargo.toml
|
||||
--- a/patched-crates/fb_procfs/Cargo.toml 2021-11-11 10:54:23.838601406 -0800
|
||||
+++ b/patched-crates/fb_procfs/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
|
||||
@@ -10,7 +10,7 @@
|
||||
# See Cargo.toml.orig for the original contents.
|
||||
|
||||
[package]
|
||||
-edition = "2021"
|
||||
+edition = "2018"
|
||||
name = "fb_procfs"
|
||||
version = "0.4.1"
|
||||
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
|
||||
diff -Naur a/patched-crates/libbpf-cargo/Cargo.toml b/patched-crates/libbpf-cargo/Cargo.toml
|
||||
--- a/patched-crates/libbpf-cargo/Cargo.toml 2021-11-11 10:54:23.848601461 -0800
|
||||
+++ b/patched-crates/libbpf-cargo/Cargo.toml 2021-11-11 10:55:28.898957781 -0800
|
||||
@@ -35,7 +35,7 @@
|
||||
version = "0.12"
|
||||
|
||||
[dependencies.libbpf-sys]
|
||||
-version = "0.5.0-2"
|
||||
+version = "0.4.0-2"
|
||||
|
||||
[dependencies.memmap2]
|
||||
version = "0.3"
|
||||
diff -Naur a/patched-crates/libbpf-rs/Cargo.toml b/patched-crates/libbpf-rs/Cargo.toml
|
||||
--- a/patched-crates/libbpf-rs/Cargo.toml 2021-11-11 10:54:23.856601505 -0800
|
||||
+++ b/patched-crates/libbpf-rs/Cargo.toml 2021-11-11 10:55:48.192063468 -0800
|
||||
@@ -24,7 +24,7 @@
|
||||
version = "1.3"
|
||||
|
||||
[dependencies.libbpf-sys]
|
||||
-version = "0.5.0-2"
|
||||
+version = "0.4.0-2"
|
||||
|
||||
[dependencies.nix]
|
||||
version = "0.22"
|
||||
diff -Naur a/patched-crates/libbpf-rs/src/object.rs b/patched-crates/libbpf-rs/src/object.rs
|
||||
--- a/patched-crates/libbpf-rs/src/object.rs 2021-11-11 10:54:23.857601510 -0800
|
||||
+++ b/patched-crates/libbpf-rs/src/object.rs 2021-11-11 10:56:05.745159628 -0800
|
||||
@@ -67,9 +67,6 @@
|
||||
pin_root_path: ptr::null(),
|
||||
attach_prog_fd: 0,
|
||||
kconfig: ptr::null(),
|
||||
- btf_custom_path: ptr::null(),
|
||||
- __bindgen_padding_0: <[u8; 6]>::default(),
|
||||
- __bindgen_padding_1: <[u8; 4]>::default(),
|
||||
}
|
||||
}
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA512 (below-0.4.1.crate) = 1e67ad09248c8ae457932857fbee21375d1ea71020ba8254e08f1d43473ef400ac31189771e4ae02b6e199cec1a12fed6d4cde0320224ff844a39c12668e0375
|
||||
SHA512 (below-0.4.1-vendor.tar.gz) = 7d93a19ec33feae4ae7649bfc8125a958a4b4cb0899d047f132f48e503bff6b9daac3ef298926d3e690431ef6a482d8d2c0bf2fa45904fbc18234a376e5043ce
|
||||
SHA512 (below-0.5.0.crate) = 7fd12aae0b912756a5ac3cee289d1b8390349f046cbf18a32dc61b7b41ab0809154133eff63cd04637f0d2ae3cdb25b5c7e2016452ed840205f5b7db57403c61
|
||||
SHA512 (below-0.5.0-vendor.tar.gz) = 61d9bfcb0243c08f6fe4f16f4dcbebafb946b1e62857d4182aaa99325bf72e7ecc8209c6ddd05c0e120f0bcc3cff128fe60ad9fb33cd560a996cb424ad74a7ed
|
||||
|
Loading…
Reference in new issue