You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-below/below-patched-crates.patch

170 lines
6.5 KiB

diff -Naur a/patched-crates/below-common/Cargo.toml b/patched-crates/below-common/Cargo.toml
--- a/patched-crates/below-common/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-common/Cargo.toml 2021-11-11 10:55:02.722814393 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below-common"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-common/src/dateutil.rs b/patched-crates/below-common/src/dateutil.rs
--- a/patched-crates/below-common/src/dateutil.rs 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-common/src/dateutil.rs 2021-11-11 10:55:02.723814398 -0800
@@ -302,7 +302,7 @@
let mut default_format = String::new();
let mut date_with_defaults = date.clone();
let mut use_now = false;
- for part in ["S", "M", "HI", "d", "mb", "Yy"] {
+ for part in ["S", "M", "HI", "d", "mb", "Yy"].iter() {
if part
.chars()
.any(|ch| naive_format.contains(&format!("%{}", ch)))
diff -Naur a/patched-crates/below-config/Cargo.toml b/patched-crates/below-config/Cargo.toml
--- a/patched-crates/below-config/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-config/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below-config"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below_derive/Cargo.toml b/patched-crates/below_derive/Cargo.toml
--- a/patched-crates/below_derive/Cargo.toml 2021-11-11 10:54:23.802601209 -0800
+++ b/patched-crates/below_derive/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below_derive"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-dump/Cargo.toml b/patched-crates/below-dump/Cargo.toml
--- a/patched-crates/below-dump/Cargo.toml 2021-11-11 10:54:23.798601187 -0800
+++ b/patched-crates/below-dump/Cargo.toml 2021-11-11 10:55:02.723814398 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below-dump"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-model/Cargo.toml b/patched-crates/below-model/Cargo.toml
--- a/patched-crates/below-model/Cargo.toml 2021-11-11 10:54:23.799601192 -0800
+++ b/patched-crates/below-model/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below-model"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-render/Cargo.toml b/patched-crates/below-render/Cargo.toml
--- a/patched-crates/below-render/Cargo.toml 2021-11-11 10:54:23.800601198 -0800
+++ b/patched-crates/below-render/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below-render"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-store/Cargo.toml b/patched-crates/below-store/Cargo.toml
--- a/patched-crates/below-store/Cargo.toml 2021-11-11 10:54:23.800601198 -0800
+++ b/patched-crates/below-store/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below-store"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/below-view/Cargo.toml b/patched-crates/below-view/Cargo.toml
--- a/patched-crates/below-view/Cargo.toml 2021-11-11 10:54:23.801601203 -0800
+++ b/patched-crates/below-view/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "below-view"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/cgroupfs/Cargo.toml b/patched-crates/cgroupfs/Cargo.toml
--- a/patched-crates/cgroupfs/Cargo.toml 2021-11-11 10:54:23.807601236 -0800
+++ b/patched-crates/cgroupfs/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "cgroupfs"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/fb_procfs/Cargo.toml b/patched-crates/fb_procfs/Cargo.toml
--- a/patched-crates/fb_procfs/Cargo.toml 2021-11-11 10:54:23.838601406 -0800
+++ b/patched-crates/fb_procfs/Cargo.toml 2021-11-11 10:55:02.724814404 -0800
@@ -10,7 +10,7 @@
# See Cargo.toml.orig for the original contents.
[package]
-edition = "2021"
+edition = "2018"
name = "fb_procfs"
version = "0.4.1"
authors = ["Daniel Xu <dlxu@fb.com>", "Facebook"]
diff -Naur a/patched-crates/libbpf-cargo/Cargo.toml b/patched-crates/libbpf-cargo/Cargo.toml
--- a/patched-crates/libbpf-cargo/Cargo.toml 2021-11-11 10:54:23.848601461 -0800
+++ b/patched-crates/libbpf-cargo/Cargo.toml 2021-11-11 10:55:28.898957781 -0800
@@ -35,7 +35,7 @@
version = "0.12"
[dependencies.libbpf-sys]
-version = "0.5.0-2"
+version = "0.4.0-2"
[dependencies.memmap2]
version = "0.3"
diff -Naur a/patched-crates/libbpf-rs/Cargo.toml b/patched-crates/libbpf-rs/Cargo.toml
--- a/patched-crates/libbpf-rs/Cargo.toml 2021-11-11 10:54:23.856601505 -0800
+++ b/patched-crates/libbpf-rs/Cargo.toml 2021-11-11 10:55:48.192063468 -0800
@@ -24,7 +24,7 @@
version = "1.3"
[dependencies.libbpf-sys]
-version = "0.5.0-2"
+version = "0.4.0-2"
[dependencies.nix]
version = "0.22"
diff -Naur a/patched-crates/libbpf-rs/src/object.rs b/patched-crates/libbpf-rs/src/object.rs
--- a/patched-crates/libbpf-rs/src/object.rs 2021-11-11 10:54:23.857601510 -0800
+++ b/patched-crates/libbpf-rs/src/object.rs 2021-11-11 10:56:05.745159628 -0800
@@ -67,9 +67,6 @@
pin_root_path: ptr::null(),
attach_prog_fd: 0,
kconfig: ptr::null(),
- btf_custom_path: ptr::null(),
- __bindgen_padding_0: <[u8; 6]>::default(),
- __bindgen_padding_1: <[u8; 4]>::default(),
}
}