commit
c14f7d61e1
@ -0,0 +1 @@
|
||||
quazip-*.tar.gz
|
@ -1,21 +0,0 @@
|
||||
# Makefile for source rpm: quazip
|
||||
# $Id$
|
||||
NAME := quazip
|
||||
SPECFILE = $(firstword $(wildcard *.spec))
|
||||
|
||||
define find-makefile-common
|
||||
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$d/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
|
||||
endef
|
||||
|
||||
MAKEFILE_COMMON := $(shell $(find-makefile-common))
|
||||
|
||||
ifeq ($(MAKEFILE_COMMON),)
|
||||
# attept a checkout
|
||||
define checkout-makefile-common
|
||||
test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
|
||||
endef
|
||||
|
||||
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
|
||||
endif
|
||||
|
||||
include $(MAKEFILE_COMMON)
|
@ -0,0 +1,25 @@
|
||||
diff -up quazip/quazip/CMakeLists.txt.orig quazip/quazip/CMakeLists.txt
|
||||
--- quazip/quazip/CMakeLists.txt.orig 2018-07-17 11:06:16.243887366 +0200
|
||||
+++ quazip/quazip/CMakeLists.txt 2018-07-17 11:17:10.088864720 +0200
|
||||
@@ -15,18 +15,16 @@ qt_wrap_cpp(MOC_SRCS ${PUBLIC_HEADERS})
|
||||
set(SRCS ${SRCS} ${MOC_SRCS})
|
||||
|
||||
add_library(${QUAZIP_LIB_TARGET_NAME} SHARED ${SRCS})
|
||||
-add_library(quazip_static STATIC ${SRCS})
|
||||
|
||||
# Windows uses .lib extension for both static and shared library
|
||||
# *nix systems use different extensions for SHARED and STATIC library and by convention both libraries have the same name
|
||||
if (NOT WIN32)
|
||||
- set_target_properties(quazip_static PROPERTIES OUTPUT_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
||||
+ set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES OUTPUT_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
||||
endif ()
|
||||
|
||||
-set_target_properties(${QUAZIP_LIB_TARGET_NAME} quazip_static PROPERTIES VERSION 1.0.0 SOVERSION 1 DEBUG_POSTFIX d)
|
||||
+set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES VERSION 1.0.0 SOVERSION 1 DEBUG_POSTFIX d)
|
||||
# Link against ZLIB_LIBRARIES if needed (on Windows this variable is empty)
|
||||
target_link_libraries(${QUAZIP_LIB_TARGET_NAME} ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
|
||||
-target_link_libraries(quazip_static ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
|
||||
|
||||
install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
|
||||
-install(TARGETS ${QUAZIP_LIB_TARGET_NAME} quazip_static LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
|
||||
+install(TARGETS ${QUAZIP_LIB_TARGET_NAME} LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
|
@ -0,0 +1,22 @@
|
||||
From f323e478b1c05f470393bb57b486c0d871cf4736 Mon Sep 17 00:00:00 2001
|
||||
From: Aleix Pol <aleixpol@kde.org>
|
||||
Date: Thu, 31 Jan 2019 18:19:30 +0100
|
||||
Subject: [PATCH] Install the FindQuaZip.cmake in the right prefix
|
||||
|
||||
It should go wherever CMAKE_INSTALL_PREFIX is installing.
|
||||
This fixes the build on flatpak and should also fix it for other cross
|
||||
compilation setups.
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 539caa4..a43fefe 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -60,4 +60,4 @@ set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
|
||||
|
||||
add_subdirectory(quazip)
|
||||
|
||||
-install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_ROOT}/Modules)
|
||||
+install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION share/cmake)
|
@ -0,0 +1,230 @@
|
||||
Name: quazip
|
||||
Version: 0.7.6
|
||||
Release: 5%{?dist}
|
||||
Summary: Qt/C++ wrapper for the minizip library
|
||||
License: GPLv2+ or LGPLv2+
|
||||
URL: https://github.com/stachenov/quazip
|
||||
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
|
||||
Patch0: quazip-0.7.6-fix_static.patch
|
||||
Patch1: quazip-0.7.6-install-right-prefix.patch
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: qt4-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: doxygen graphviz
|
||||
|
||||
|
||||
%description
|
||||
QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package that
|
||||
can be used to access ZIP archives. It uses Trolltech's Qt toolkit.
|
||||
|
||||
QuaZIP allows you to access files inside ZIP archives using QIODevice API,
|
||||
and - yes! - that means that you can also use QTextStream, QDataStream or
|
||||
whatever you would like to use on your zipped files.
|
||||
|
||||
QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both reading
|
||||
from and writing to ZIP archives.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: qt4-devel%{?_isa}
|
||||
Requires: zlib-devel%{?_isa}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries, header files and documentation
|
||||
for developing applications that use %{name}.
|
||||
|
||||
%package qt5
|
||||
Summary: Qt5 wrapper for the minizip library
|
||||
%description qt5
|
||||
QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package that
|
||||
can be used to access ZIP archives. It uses Trolltech's Qt toolkit.
|
||||
|
||||
QuaZIP allows you to access files inside ZIP archives using QIODevice API,
|
||||
and - yes! - that means that you can also use QTextStream, QDataStream or
|
||||
whatever you would like to use on your zipped files.
|
||||
|
||||
QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both reading
|
||||
from and writing to ZIP archives.
|
||||
|
||||
%package qt5-devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}-qt5%{?_isa} = %{version}-%{release}
|
||||
Requires: qt5-qtbase-devel%{?_isa}
|
||||
Requires: zlib-devel%{?_isa}
|
||||
|
||||
%description qt5-devel
|
||||
The %{name}-devel package contains libraries, header files and documentation
|
||||
for developing applications that use %{name}.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
mkdir build-qt4
|
||||
pushd build-qt4
|
||||
%cmake .. -DBUILD_WITH_QT4:BOOL=ON
|
||||
|
||||
%make_build
|
||||
popd
|
||||
|
||||
mkdir build-qt5
|
||||
pushd build-qt5
|
||||
%cmake .. -DBUILD_WITH_QT4:BOOL=OFF
|
||||
|
||||
%make_build
|
||||
popd
|
||||
|
||||
doxygen Doxyfile
|
||||
for file in doc/html/*; do
|
||||
touch -r Doxyfile $file
|
||||
done
|
||||
|
||||
%install
|
||||
make install/fast DESTDIR=%{buildroot} -C build-qt5
|
||||
make install/fast DESTDIR=%{buildroot} -C build-qt4
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files
|
||||
%doc NEWS.txt README.md
|
||||
%license COPYING
|
||||
%{_libdir}/libquazip.so.1*
|
||||
|
||||
%files devel
|
||||
%doc doc/html
|
||||
%{_includedir}/quazip/
|
||||
%{_libdir}/libquazip.so
|
||||
%{_datadir}/cmake/FindQuaZip.cmake
|
||||
|
||||
%files qt5
|
||||
%doc NEWS.txt README.md
|
||||
%license COPYING
|
||||
%{_libdir}/libquazip5.so.1*
|
||||
|
||||
%files qt5-devel
|
||||
%doc doc/html
|
||||
%{_includedir}/quazip5/
|
||||
%{_libdir}/libquazip5.so
|
||||
%{_datadir}/cmake/FindQuaZip5.cmake
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Oct 21 2019 Felipe Borges <feborges@redhat.com> - 0.7.6-5
|
||||
- Add patch to fix FindQuaZip.cmake install path
|
||||
|
||||
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue Mar 26 2019 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-3
|
||||
- Add zlib-devel - rhbz#1634468
|
||||
|
||||
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Jul 17 2018 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-1
|
||||
- Update to 0.7.6
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Mon Feb 13 2017 Nicolas Chauvet <kwizart@gmail.com> - 0.7.3-1
|
||||
- Update to 0.7.3
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Apr 12 2016 Nicolas Chauvet <kwizart@gmail.com> - 0.7.2-1
|
||||
- Update to 0.7.2
|
||||
- Add patch to fix build with qt5 (disable static version)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Apr 19 2015 Rex Dieter <rdieter@fedoraproject.org> 0.7.1-2
|
||||
- quazip qt5 support (#1197484)
|
||||
|
||||
* Thu Jan 08 2015 Nicolas Chauvet <kwizart@gmail.com> - 0.7.1-1
|
||||
- Update to 0.7.1
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Tue Jul 29 2014 Nicolas Chauvet <kwizart@gmail.com> - 0.7-1
|
||||
- Update to 0.7.0
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed Feb 12 2014 Nicolas Chauvet <kwizart@gmail.com> - 0.6.2-1
|
||||
- Update to 0.6.2
|
||||
|
||||
* Sun Jan 26 2014 Nicolas Chauvet <kwizart@gmail.com> - 0.6.1-1
|
||||
- Update to 0.6.1
|
||||
- Clean spec file
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Sun Mar 03 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.5.1-1
|
||||
- Update to 0.5.1
|
||||
|
||||
* Sun Sep 09 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.5-1
|
||||
- Update to 0.5
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.4.4-1
|
||||
- Update to 0.4.4
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Sat Dec 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.4.3-1
|
||||
- Update to 0.4.3
|
||||
|
||||
* Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.4.2-1
|
||||
- Update to 0.4.2
|
||||
- Rebase ld patch
|
||||
|
||||
* Mon Jul 25 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.4.1-1
|
||||
- Update to 0.4.1
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Sat Jul 24 2010 Chen Lei <supercyper@163.com> - 0.3-2
|
||||
- add BR:graphviz for building apidocs
|
||||
|
||||
* Sat Jul 24 2010 Chen Lei <supercyper@163.com> - 0.3-1
|
||||
- update to 0.3
|
||||
|
||||
* Wed Feb 3 2010 Chen Lei <supercyper@163.com> - 0.2.3-5
|
||||
- quazip-devel must Requires minizip-devel
|
||||
|
||||
* Sun Jan 31 2010 Chen Lei <supercyper@163.com> - 0.2.3-4
|
||||
- change license to GPLv2+ or LGPLv2+
|
||||
|
||||
* Sun Jan 31 2010 Chen Lei <supercyper@163.com> - 0.2.3-3
|
||||
- use %%doc for packaging documentations
|
||||
|
||||
* Sun Jan 31 2010 Chen Lei <supercyper@163.com> - 0.2.3-2
|
||||
- use system-wide minizip library
|
||||
|
||||
* Sun Jan 31 2010 Chen Lei <supercyper@163.com> - 0.2.3-1
|
||||
- initial rpm build
|
Loading…
Reference in new issue