This was proposed upstream in https://github.com/stachenov/quazip/pull/20 For context: we are building Flatpaks from RPMs[0], and Quazip gets pulled in as dependency for keepassxc. [0] https://docs.fedoraproject.org/en-US/flatpak/tutorial/ Fixes rhbz#1761528epel9
parent
0218038226
commit
9febbfea47
@ -0,0 +1,22 @@
|
||||
From f323e478b1c05f470393bb57b486c0d871cf4736 Mon Sep 17 00:00:00 2001
|
||||
From: Aleix Pol <aleixpol@kde.org>
|
||||
Date: Thu, 31 Jan 2019 18:19:30 +0100
|
||||
Subject: [PATCH] Install the FindQuaZip.cmake in the right prefix
|
||||
|
||||
It should go wherever CMAKE_INSTALL_PREFIX is installing.
|
||||
This fixes the build on flatpak and should also fix it for other cross
|
||||
compilation setups.
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 539caa4..a43fefe 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -60,4 +60,4 @@ set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
|
||||
|
||||
add_subdirectory(quazip)
|
||||
|
||||
-install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_ROOT}/Modules)
|
||||
+install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION share/cmake)
|
Loading…
Reference in new issue