|
|
@ -1,9 +1,22 @@
|
|
|
|
|
|
|
|
From 1b8dae76d36167b9f3e0748968d9b6ee1da3bc20 Mon Sep 17 00:00:00 2001
|
|
|
|
|
|
|
|
From: Justin Ross <jross@apache.org>
|
|
|
|
|
|
|
|
Date: Tue, 8 Aug 2017 13:58:38 -0700
|
|
|
|
|
|
|
|
Subject: [PATCH] PROTON-1526: Ensure the module .so file has no prefix; remove
|
|
|
|
|
|
|
|
version-based rename
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
---
|
|
|
|
|
|
|
|
proton-c/bindings/perl/CMakeLists.txt | 14 +++-----------
|
|
|
|
|
|
|
|
1 file changed, 3 insertions(+), 11 deletions(-)
|
|
|
|
|
|
|
|
|
|
|
|
diff --git a/proton-c/bindings/perl/CMakeLists.txt b/proton-c/bindings/perl/CMakeLists.txt
|
|
|
|
diff --git a/proton-c/bindings/perl/CMakeLists.txt b/proton-c/bindings/perl/CMakeLists.txt
|
|
|
|
index 1356ccea..ed61d864 100644
|
|
|
|
index 1356cce..744e812 100644
|
|
|
|
--- a/proton-c/bindings/perl/CMakeLists.txt
|
|
|
|
--- a/proton-c/bindings/perl/CMakeLists.txt
|
|
|
|
+++ b/proton-c/bindings/perl/CMakeLists.txt
|
|
|
|
+++ b/proton-c/bindings/perl/CMakeLists.txt
|
|
|
|
@@ -56,18 +56,9 @@ list(APPEND SWIG_MODULE_cproton_perl_EXTRA_DEPS
|
|
|
|
@@ -54,20 +54,12 @@ list(APPEND SWIG_MODULE_cproton_perl_EXTRA_DEPS
|
|
|
|
|
|
|
|
${PROTON_HEADERS}
|
|
|
|
|
|
|
|
)
|
|
|
|
swig_add_module(cproton_perl perl perl.i)
|
|
|
|
swig_add_module(cproton_perl perl perl.i)
|
|
|
|
|
|
|
|
+set_target_properties(cproton_perl PROPERTIES PREFIX "")
|
|
|
|
swig_link_libraries(cproton_perl ${BINDING_DEPS} ${PERL_LIBRARY})
|
|
|
|
swig_link_libraries(cproton_perl ${BINDING_DEPS} ${PERL_LIBRARY})
|
|
|
|
|
|
|
|
|
|
|
|
-if ((${CMAKE_MAJOR_VERSION} EQUAL 2) AND (${CMAKE_MINOR_VERSION} LESS 8))
|
|
|
|
-if ((${CMAKE_MAJOR_VERSION} EQUAL 2) AND (${CMAKE_MINOR_VERSION} LESS 8))
|
|
|
@ -23,3 +36,6 @@ index 1356ccea..ed61d864 100644
|
|
|
|
|
|
|
|
|
|
|
|
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.pm
|
|
|
|
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.pm
|
|
|
|
DESTINATION ${PERL_VENDORARCH_DIR}
|
|
|
|
DESTINATION ${PERL_VENDORARCH_DIR}
|
|
|
|
|
|
|
|
--
|
|
|
|
|
|
|
|
1.8.3.1
|
|
|
|
|
|
|
|
|