You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
qpid-proton/0001-PROTON-1526-Ensure-the...

42 lines
1.5 KiB

From 1b8dae76d36167b9f3e0748968d9b6ee1da3bc20 Mon Sep 17 00:00:00 2001
From: Justin Ross <jross@apache.org>
Date: Tue, 8 Aug 2017 13:58:38 -0700
Subject: [PATCH] PROTON-1526: Ensure the module .so file has no prefix; remove
version-based rename
---
proton-c/bindings/perl/CMakeLists.txt | 14 +++-----------
1 file changed, 3 insertions(+), 11 deletions(-)
diff --git a/proton-c/bindings/perl/CMakeLists.txt b/proton-c/bindings/perl/CMakeLists.txt
index 1356cce..744e812 100644
--- a/proton-c/bindings/perl/CMakeLists.txt
+++ b/proton-c/bindings/perl/CMakeLists.txt
@@ -54,20 +54,12 @@ list(APPEND SWIG_MODULE_cproton_perl_EXTRA_DEPS
${PROTON_HEADERS}
)
swig_add_module(cproton_perl perl perl.i)
+set_target_properties(cproton_perl PROPERTIES PREFIX "")
swig_link_libraries(cproton_perl ${BINDING_DEPS} ${PERL_LIBRARY})
-if ((${CMAKE_MAJOR_VERSION} EQUAL 2) AND (${CMAKE_MINOR_VERSION} LESS 8))
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.so
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.so
DESTINATION ${PERL_VENDORARCH_DIR}/auto/cproton_perl
- COMPONENT Perl
- )
-else()
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libcproton_perl.so
- RENAME cproton_perl.so
- DESTINATION ${PERL_VENDORARCH_DIR}/auto/cproton_perl
- COMPONENT Perl
- )
-endif ((${CMAKE_MAJOR_VERSION} EQUAL 2) AND (${CMAKE_MINOR_VERSION} LESS 8))
+ COMPONENT Perl)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cproton_perl.pm
DESTINATION ${PERL_VENDORARCH_DIR}
--
1.8.3.1