parent
6b3a8d59f6
commit
67ce5a3dfe
@ -1,48 +0,0 @@
|
|||||||
diff -up python-fido2-0.9.3/test/test_client.py.mock python-fido2-0.9.3/test/test_client.py
|
|
||||||
--- python-fido2-0.9.3/test/test_client.py.mock 2021-11-09 04:15:13.000000000 -0700
|
|
||||||
+++ python-fido2-0.9.3/test/test_client.py 2022-05-19 20:47:06.165307669 -0600
|
|
||||||
@@ -29,7 +29,7 @@
|
|
||||||
|
|
||||||
from __future__ import absolute_import, unicode_literals
|
|
||||||
|
|
||||||
-import mock
|
|
||||||
+from unittest import mock
|
|
||||||
import unittest
|
|
||||||
from threading import Event, Timer
|
|
||||||
from binascii import a2b_hex
|
|
||||||
diff -up python-fido2-0.9.3/test/test_ctap2.py.mock python-fido2-0.9.3/test/test_ctap2.py
|
|
||||||
--- python-fido2-0.9.3/test/test_ctap2.py.mock 2021-11-09 04:15:13.000000000 -0700
|
|
||||||
+++ python-fido2-0.9.3/test/test_ctap2.py 2022-05-19 20:44:27.276937443 -0600
|
|
||||||
@@ -45,7 +45,7 @@ from cryptography.hazmat.backends import
|
|
||||||
from cryptography.hazmat.primitives.asymmetric import ec
|
|
||||||
|
|
||||||
import unittest
|
|
||||||
-import mock
|
|
||||||
+from unittest import mock
|
|
||||||
|
|
||||||
_AAGUID = a2b_hex("F8A011F38C0A4D15800617111F9EDC7D")
|
|
||||||
_INFO = a2b_hex(
|
|
||||||
diff -up python-fido2-0.9.3/test/test_pcsc.py.mock python-fido2-0.9.3/test/test_pcsc.py
|
|
||||||
--- python-fido2-0.9.3/test/test_pcsc.py.mock 2021-11-09 04:15:13.000000000 -0700
|
|
||||||
+++ python-fido2-0.9.3/test/test_pcsc.py 2022-05-19 20:45:11.291317012 -0600
|
|
||||||
@@ -28,7 +28,7 @@
|
|
||||||
from __future__ import absolute_import, unicode_literals
|
|
||||||
|
|
||||||
import unittest
|
|
||||||
-import mock
|
|
||||||
+from unittest import mock
|
|
||||||
import sys
|
|
||||||
from fido2.hid import CTAPHID
|
|
||||||
|
|
||||||
diff -up python-fido2-0.9.3/test/test_ctap1.py.mock python-fido2-0.9.3/test/test_ctap1.py
|
|
||||||
--- python-fido2-0.9.3/test/test_ctap1.py.mock 2021-11-09 04:15:13.000000000 -0700
|
|
||||||
+++ python-fido2-0.9.3/test/test_ctap1.py 2022-05-19 20:49:43.312664818 -0600
|
|
||||||
@@ -30,7 +30,7 @@ from __future__ import absolute_import,
|
|
||||||
from fido2.ctap1 import Ctap1, ApduError
|
|
||||||
from binascii import a2b_hex
|
|
||||||
import unittest
|
|
||||||
-import mock
|
|
||||||
+from unittest import mock
|
|
||||||
|
|
||||||
|
|
||||||
class TestCtap1(unittest.TestCase):
|
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/setup.py b/setup.py
|
|
||||||
index 445aa54..7747cde 100755
|
|
||||||
--- a/setup.py
|
|
||||||
+++ b/setup.py
|
|
||||||
@@ -54,7 +54,7 @@ setup(
|
|
||||||
url="https://github.com/Yubico/python-fido2",
|
|
||||||
python_requires=">=2.7.6,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
|
|
||||||
install_requires=["six", "cryptography>=1.5"],
|
|
||||||
- extras_require={':python_version < "3.4"': ["enum34"], "pcsc": ["pyscard"]},
|
|
||||||
+ extras_require={"pcsc": ["pyscard"]},
|
|
||||||
classifiers=[
|
|
||||||
"License :: OSI Approved :: BSD License",
|
|
||||||
"License :: OSI Approved :: Apache Software License",
|
|
@ -1 +1 @@
|
|||||||
SHA512 (python-python-fido2-0.9.3.tar.gz) = 76d121eaa64f62e96e80f151b9f526e04276feab035494c5cde4bb7ae35fbed9c7bbd73c1d22f309b26ece3b71b0532a7a01c5a2f10c09a843def4e9a7c0b04b
|
SHA512 (python-fido2-1.0.0.tar.gz) = 7c7d555f20b3c5cf917847f41dfdad949d8a07f3075202c37eb483ab6e3f90c45ec36d16d82e1f3cde1f3cf75498189dff2653288b0537b47cb1c0e3190f9bb5
|
||||||
|
Loading…
Reference in new issue