Garrett Holmstrom 10 years ago
parent b2223ba972
commit a67ecb6001

@ -0,0 +1,50 @@
Index: boto/boto/compat.py
===================================================================
--- boto.orig/boto/compat.py
+++ boto/boto/compat.py
@@ -46,15 +46,23 @@ except (AttributeError, ImportError):
# This is probably running on App Engine.
expanduser = (lambda x: x)
-from boto.vendored import six
-
-from boto.vendored.six import BytesIO, StringIO
-from boto.vendored.six.moves import filter, http_client, map, _thread, \
- urllib, zip
-from boto.vendored.six.moves.queue import Queue
-from boto.vendored.six.moves.urllib.parse import parse_qs, quote, unquote, \
- urlparse, urlsplit
-from boto.vendored.six.moves.urllib.request import urlopen
+try:
+ import six
+ from six import BytesIO, StringIO
+ from six.moves import filter, http_client, map, _thread, urllib, zip
+ from six.moves.queue import Queue
+ from six.moves.urllib.parse import parse_qs, quote, unquote, urlparse, \
+ urlsplit
+ from six.moves.urllib.request import urlopen
+except ImportError:
+ from boto.vendored import six
+ from boto.vendored.six import BytesIO, StringIO
+ from boto.vendored.six.moves import filter, http_client, map, _thread, \
+ urllib, zip
+ from boto.vendored.six.moves.queue import Queue
+ from boto.vendored.six.moves.urllib.parse import parse_qs, quote, unquote, \
+ urlparse, urlsplit
+ from boto.vendored.six.moves.urllib.request import urlopen
if six.PY3:
# StandardError was removed, so use the base exception type instead
Index: boto/setup.py
===================================================================
--- boto.orig/setup.py
+++ boto/setup.py
@@ -76,7 +76,7 @@ setup(name = "boto",
"boto.elastictranscoder", "boto.opsworks", "boto.redshift",
"boto.dynamodb2", "boto.support", "boto.cloudtrail",
"boto.directconnect", "boto.kinesis", "boto.rds2",
- "boto.cloudsearch2", "boto.logs", "boto.vendored",
+ "boto.cloudsearch2", "boto.logs",
"boto.route53.domains", "boto.cognito",
"boto.cognito.identity", "boto.cognito.sync",
"boto.cloudsearchdomain", "boto.kms",

@ -30,6 +30,10 @@ Source0: http://pypi.python.org/packages/source/b/boto/boto-%{version}.ta
# Taken from sourcecode 2014-07-31
Source1: boto-mit-license.txt
# Unbundle python-six
# https://github.com/boto/boto/pull/3086
Patch1: boto-2.37.0-devendor.patch
BuildRequires: python2-devel
BuildRequires: python-setuptools
%if %{with python3}
@ -38,6 +42,7 @@ BuildRequires: python3-setuptools
%endif # with python3
%if %{with unittests}
BuildRequires: python-argparse
BuildRequires: python-httpretty
BuildRequires: python-mock
BuildRequires: python-nose
@ -94,9 +99,12 @@ cloud systems like Eucalyptus, OpenStack and Open Nebula.
%prep
%setup -q -n boto-%{version}
%patch1 -p1
cp -p %{SOURCE1} .
rm -r boto.egg-info
rm -r boto/vendored
%build
@ -171,6 +179,7 @@ rm -f $RPM_BUILD_ROOT/%{_bindir}/*
* Wed Apr 8 2015 Garrett Holmstrom <gholms@fedoraproject.org> - 3.37.0-1
- Updated to 2.37.0 (RH #1180861)
- Dropped executables in F23
- Unbundled python-six (boto #3086)
* Sun Nov 9 2014 Garrett Holmstrom <gholms@fedoraproject.org> - 2.34.0-4
- Fixed python3 requires

Loading…
Cancel
Save