parent
b2223ba972
commit
a67ecb6001
@ -0,0 +1,50 @@
|
|||||||
|
Index: boto/boto/compat.py
|
||||||
|
===================================================================
|
||||||
|
--- boto.orig/boto/compat.py
|
||||||
|
+++ boto/boto/compat.py
|
||||||
|
@@ -46,15 +46,23 @@ except (AttributeError, ImportError):
|
||||||
|
# This is probably running on App Engine.
|
||||||
|
expanduser = (lambda x: x)
|
||||||
|
|
||||||
|
-from boto.vendored import six
|
||||||
|
-
|
||||||
|
-from boto.vendored.six import BytesIO, StringIO
|
||||||
|
-from boto.vendored.six.moves import filter, http_client, map, _thread, \
|
||||||
|
- urllib, zip
|
||||||
|
-from boto.vendored.six.moves.queue import Queue
|
||||||
|
-from boto.vendored.six.moves.urllib.parse import parse_qs, quote, unquote, \
|
||||||
|
- urlparse, urlsplit
|
||||||
|
-from boto.vendored.six.moves.urllib.request import urlopen
|
||||||
|
+try:
|
||||||
|
+ import six
|
||||||
|
+ from six import BytesIO, StringIO
|
||||||
|
+ from six.moves import filter, http_client, map, _thread, urllib, zip
|
||||||
|
+ from six.moves.queue import Queue
|
||||||
|
+ from six.moves.urllib.parse import parse_qs, quote, unquote, urlparse, \
|
||||||
|
+ urlsplit
|
||||||
|
+ from six.moves.urllib.request import urlopen
|
||||||
|
+except ImportError:
|
||||||
|
+ from boto.vendored import six
|
||||||
|
+ from boto.vendored.six import BytesIO, StringIO
|
||||||
|
+ from boto.vendored.six.moves import filter, http_client, map, _thread, \
|
||||||
|
+ urllib, zip
|
||||||
|
+ from boto.vendored.six.moves.queue import Queue
|
||||||
|
+ from boto.vendored.six.moves.urllib.parse import parse_qs, quote, unquote, \
|
||||||
|
+ urlparse, urlsplit
|
||||||
|
+ from boto.vendored.six.moves.urllib.request import urlopen
|
||||||
|
|
||||||
|
if six.PY3:
|
||||||
|
# StandardError was removed, so use the base exception type instead
|
||||||
|
Index: boto/setup.py
|
||||||
|
===================================================================
|
||||||
|
--- boto.orig/setup.py
|
||||||
|
+++ boto/setup.py
|
||||||
|
@@ -76,7 +76,7 @@ setup(name = "boto",
|
||||||
|
"boto.elastictranscoder", "boto.opsworks", "boto.redshift",
|
||||||
|
"boto.dynamodb2", "boto.support", "boto.cloudtrail",
|
||||||
|
"boto.directconnect", "boto.kinesis", "boto.rds2",
|
||||||
|
- "boto.cloudsearch2", "boto.logs", "boto.vendored",
|
||||||
|
+ "boto.cloudsearch2", "boto.logs",
|
||||||
|
"boto.route53.domains", "boto.cognito",
|
||||||
|
"boto.cognito.identity", "boto.cognito.sync",
|
||||||
|
"boto.cloudsearchdomain", "boto.kms",
|
Loading…
Reference in new issue