f38
Jitka Plesnikova 4 years ago
parent 75dbe7f297
commit 2e3d4141e6

1
.gitignore vendored

@ -1 +1,2 @@
/SVN-Look-0.41.tar.gz /SVN-Look-0.41.tar.gz
/SVN-Look-0.42.tar.gz

@ -1,60 +0,0 @@
From f0c2f407a1ff7faf4c5467a0f0aa49ec4ebd0384 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Thu, 8 Oct 2020 12:38:33 +0200
Subject: [PATCH] Fix MIN_PERL_VERSION
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
ExtUtils-MakeMaker-7.48 rejects invalid MIN_PERL_VERSION values.
CPAN RT#133489
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
META.yml | 2 +-
Makefile.PL | 2 +-
lib/SVN/Look.pm | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/META.yml b/META.yml
index 139ad25..e38b5db 100644
--- a/META.yml
+++ b/META.yml
@@ -25,7 +25,7 @@ requires:
List::MoreUtils: '0'
MIME::Base64: '0'
XML::Simple: '0'
- perl: 5.008_000
+ perl: 5.008000
strict: '0'
warnings: '0'
resources:
diff --git a/Makefile.PL b/Makefile.PL
index 80cdc0c..68219bd 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -38,7 +38,7 @@ my %WriteMakefileArgs = (
},
'DISTNAME' => 'SVN-Look',
'LICENSE' => 'perl',
- 'MIN_PERL_VERSION' => '5.008_000',
+ 'MIN_PERL_VERSION' => '5.008000',
'NAME' => 'SVN::Look',
'PREREQ_PM' => {
'Carp' => '0',
diff --git a/lib/SVN/Look.pm b/lib/SVN/Look.pm
index 39faf07..16ae0f1 100644
--- a/lib/SVN/Look.pm
+++ b/lib/SVN/Look.pm
@@ -1,6 +1,6 @@
## no critic (Modules::RequireExplicitPackage, InputOutput::RequireBriefOpen)
-use 5.008_000;
+use 5.008000;
use strict;
use warnings;
--
2.25.4

@ -1,17 +1,15 @@
Name: perl-SVN-Look Name: perl-SVN-Look
Version: 0.41 Version: 0.42
Release: 16%{?dist} Release: 1%{?dist}
Summary: Caching wrapper around the svnlook command Summary: Caching wrapper around the svnlook command
License: GPL+ or Artistic License: GPL+ or Artistic
URL: https://metacpan.org/release/SVN-Look URL: https://metacpan.org/release/SVN-Look
Source0: https://cpan.metacpan.org/authors/id/G/GN/GNUSTAVO/SVN-Look-%{version}.tar.gz Source0: https://cpan.metacpan.org/authors/id/G/GN/GNUSTAVO/SVN-Look-%{version}.tar.gz
# Adapt to ExtUtils-MakeMaker-7.48,
# <https://github.com/gnustavo/SVN-Look/issues/5>
Patch0: SVN-Look-0.41-Fix-MIN_PERL_VERSION.patch
BuildArch: noarch BuildArch: noarch
BuildRequires: coreutils
BuildRequires: make BuildRequires: make
BuildRequires: perl-interpreter
BuildRequires: perl-generators BuildRequires: perl-generators
BuildRequires: perl-interpreter
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76 BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires: perl(strict) BuildRequires: perl(strict)
BuildRequires: perl(warnings) BuildRequires: perl(warnings)
@ -20,6 +18,7 @@ BuildRequires: perl(Carp)
BuildRequires: perl(File::Spec::Functions) BuildRequires: perl(File::Spec::Functions)
BuildRequires: perl(File::Temp) BuildRequires: perl(File::Temp)
BuildRequires: perl(List::MoreUtils) BuildRequires: perl(List::MoreUtils)
BuildRequires: perl(MIME::Base64)
BuildRequires: perl(XML::Simple) BuildRequires: perl(XML::Simple)
BuildRequires: subversion BuildRequires: subversion
# Tests # Tests
@ -47,17 +46,17 @@ repetitious calls.
%prep %prep
%setup -q -n SVN-Look-%{version} %setup -q -n SVN-Look-%{version}
%patch0 -p1
%build %build
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
make %{?_smp_mflags} %{make_build}
%install %install
make pure_install DESTDIR=$RPM_BUILD_ROOT %{make_install}
%{_fixperms} $RPM_BUILD_ROOT/* %{_fixperms} $RPM_BUILD_ROOT/*
%check %check
unset AUTHOR_TESTING RELEASE_TESTING
make test make test
%files %files
@ -67,6 +66,9 @@ make test
%{_mandir}/man3/* %{_mandir}/man3/*
%changelog %changelog
* Fri Oct 09 2020 Jitka Plesnikova <jplesnik@redhat.com> - 0.42-1
- 0.42 bump
* Thu Oct 08 2020 Petr Pisar <ppisar@redhat.com> - 0.41-16 * Thu Oct 08 2020 Petr Pisar <ppisar@redhat.com> - 0.41-16
- Adapt to ExtUtils-MakeMaker-7.48 - Adapt to ExtUtils-MakeMaker-7.48

@ -1 +1 @@
2b51270445a774c30ba5a94086201809 SVN-Look-0.41.tar.gz SHA512 (SVN-Look-0.42.tar.gz) = 77146853d1a7c1ecb1d7a7e3465381f1a7b20c724f0cb7153466a6d99c4ce537ba7b1f224139cbbf31d56b71991769d4dee77d3f703866db308e48ad957c8d09

Loading…
Cancel
Save