c8-stream-1.7044
imports/c8-stream-1.7044/perl-Parse-PMFile-0.41-7.module+el8.1.0+2942+110089f5
commit
d4e9f8fc95
@ -0,0 +1 @@
|
||||
SOURCES/Parse-PMFile-0.41.tar.gz
|
@ -0,0 +1 @@
|
||||
6650643f65b669435cddd3c5d74804a31cef98af SOURCES/Parse-PMFile-0.41.tar.gz
|
@ -0,0 +1,44 @@
|
||||
From 76f72eb15b44af89a089d30b14d5f5d4d6829f7a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
|
||||
Date: Fri, 1 Jun 2018 09:28:17 +0200
|
||||
Subject: [PATCH] Do not use ExtUtils::MakeMaker::CPANfile
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The Makefile.PL works as well as with plain ExtUtils::MakeMaker.
|
||||
rpmbuild does not read dependencies from META, thus cpanfile content
|
||||
is irrelevant when building an RPM package.
|
||||
|
||||
Signed-off-by: Petr Písař <ppisar@redhat.com>
|
||||
---
|
||||
Makefile.PL | 2 +-
|
||||
cpanfile | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile.PL b/Makefile.PL
|
||||
index a4faee1..b4bb0d8 100644
|
||||
--- a/Makefile.PL
|
||||
+++ b/Makefile.PL
|
||||
@@ -1,6 +1,6 @@
|
||||
use strict;
|
||||
use warnings;
|
||||
-use ExtUtils::MakeMaker::CPANfile;
|
||||
+use ExtUtils::MakeMaker;
|
||||
|
||||
my %params = (
|
||||
NAME => 'Parse::PMFile',
|
||||
diff --git a/cpanfile b/cpanfile
|
||||
index a5eef0c..6295f99 100644
|
||||
--- a/cpanfile
|
||||
+++ b/cpanfile
|
||||
@@ -12,4 +12,4 @@ on test => sub {
|
||||
on develop => sub {
|
||||
requires 'PAUSE::Permissions' => '0.08' if $] > 5.010000;
|
||||
requires 'WorePAN' => '0.13';
|
||||
-};
|
||||
\ No newline at end of file
|
||||
+};
|
||||
--
|
||||
2.14.4
|
||||
|
@ -0,0 +1,136 @@
|
||||
# Run optional test
|
||||
%bcond_without perl_Parse_PMFile_enables_optional_test
|
||||
|
||||
Name: perl-Parse-PMFile
|
||||
Version: 0.41
|
||||
Release: 7%{?dist}
|
||||
Summary: Parses .pm file as PAUSE does
|
||||
License: GPL+ or Artistic
|
||||
URL: https://metacpan.org/release/Parse-PMFile
|
||||
Source0: https://cpan.metacpan.org/authors/id/I/IS/ISHIGAKI/Parse-PMFile-%{version}.tar.gz
|
||||
# Remove useless dependency on ExtUtils::MakeMaker::CPANfile
|
||||
Patch0: Parse-PMFile-0.41-Do-not-use-ExtUtils-MakeMaker-CPANfile.patch
|
||||
BuildArch: noarch
|
||||
BuildRequires: make
|
||||
BuildRequires: perl-generators
|
||||
BuildRequires: perl-interpreter
|
||||
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
|
||||
BuildRequires: perl(strict)
|
||||
BuildRequires: perl(warnings)
|
||||
# Run-time
|
||||
BuildRequires: perl(Dumpvalue)
|
||||
BuildRequires: perl(File::Spec)
|
||||
BuildRequires: perl(JSON::PP) >= 2.00
|
||||
BuildRequires: perl(Safe)
|
||||
BuildRequires: perl(version) >= 0.83
|
||||
# Tests
|
||||
BuildRequires: perl(File::Temp) >= 0.19
|
||||
BuildRequires: perl(FindBin)
|
||||
BuildRequires: perl(Opcode)
|
||||
BuildRequires: perl(Test::More) >= 0.88
|
||||
%if %{with perl_Parse_PMFile_enables_optional_test}
|
||||
# Optional tests
|
||||
# PAUSE::Permissions 0.08 not yet packaged
|
||||
BuildRequires: perl(version::vpp)
|
||||
# Test::Pod not used
|
||||
# Test::Pod::Coverage not used
|
||||
%endif
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
||||
Requires: perl(JSON::PP) >= 2.00
|
||||
Requires: perl(version) >= 0.83
|
||||
|
||||
# Remove under-specified dependencies
|
||||
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\((JSON::PP|version)\\)$
|
||||
|
||||
%description
|
||||
The most of the code of this module is taken from the PAUSE code as of
|
||||
April 2013 almost verbatim. Thus, the heart of this module should be quite
|
||||
stable. However, I made it not to use pipe ("-|") as well as I stripped
|
||||
database-related code. If you encounter any issue, that's most probably
|
||||
because of my modification.
|
||||
|
||||
%prep
|
||||
%setup -q -n Parse-PMFile-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make pure_install DESTDIR=$RPM_BUILD_ROOT
|
||||
%{_fixperms} $RPM_BUILD_ROOT/*
|
||||
|
||||
%check
|
||||
unset TEST_POD
|
||||
make test
|
||||
|
||||
%files
|
||||
%doc Changes README
|
||||
%{perl_vendorlib}/*
|
||||
%{_mandir}/man3/*
|
||||
|
||||
%changelog
|
||||
* Fri Mar 29 2019 Jitka Plesnikova <jplesnik@redhat.com> - 0.41-7
|
||||
- Rebuild with enable hardening (bug #1636329)
|
||||
|
||||
* Fri Jun 01 2018 Petr Pisar <ppisar@redhat.com> - 0.41-6
|
||||
- Remove useless dependency on ExtUtils::MakeMaker::CPANfile
|
||||
- Modernize the spec file
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.41-3
|
||||
- Perl 5.26 rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Nov 04 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.41-1
|
||||
- 0.41 bump
|
||||
|
||||
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.40-2
|
||||
- Perl 5.24 rebuild
|
||||
|
||||
* Mon Feb 22 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.40-1
|
||||
- 0.40 bump
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.39-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Jan 11 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.39-1
|
||||
- 0.39 bump
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.36-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Thu Jun 04 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.36-2
|
||||
- Perl 5.22 rebuild
|
||||
|
||||
* Mon Apr 20 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.36-1
|
||||
- 0.36 bump
|
||||
|
||||
* Tue Feb 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.35-1
|
||||
- 0.35 bump
|
||||
|
||||
* Mon Dec 15 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.33-1
|
||||
- 0.33 bump
|
||||
|
||||
* Thu Dec 11 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.31-1
|
||||
- 0.31 bump
|
||||
|
||||
* Mon Dec 08 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.30-1
|
||||
- 0.30 bump
|
||||
|
||||
* Mon Oct 13 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.29-1
|
||||
- 0.29 bump
|
||||
|
||||
* Wed Oct 08 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-1
|
||||
- 0.28 bump
|
||||
|
||||
* Tue Sep 23 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.26-1
|
||||
- Specfile autogenerated by cpanspec 1.78.
|
Loading…
Reference in new issue