You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
perl-Parse-PMFile/SOURCES/Parse-PMFile-0.41-Do-not-us...

45 lines
1.2 KiB

From 76f72eb15b44af89a089d30b14d5f5d4d6829f7a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Fri, 1 Jun 2018 09:28:17 +0200
Subject: [PATCH] Do not use ExtUtils::MakeMaker::CPANfile
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The Makefile.PL works as well as with plain ExtUtils::MakeMaker.
rpmbuild does not read dependencies from META, thus cpanfile content
is irrelevant when building an RPM package.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 2 +-
cpanfile | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.PL b/Makefile.PL
index a4faee1..b4bb0d8 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,6 +1,6 @@
use strict;
use warnings;
-use ExtUtils::MakeMaker::CPANfile;
+use ExtUtils::MakeMaker;
my %params = (
NAME => 'Parse::PMFile',
diff --git a/cpanfile b/cpanfile
index a5eef0c..6295f99 100644
--- a/cpanfile
+++ b/cpanfile
@@ -12,4 +12,4 @@ on test => sub {
on develop => sub {
requires 'PAUSE::Permissions' => '0.08' if $] > 5.010000;
requires 'WorePAN' => '0.13';
-};
\ No newline at end of file
+};
--
2.14.4