parent
fd0028ba0e
commit
0e082110d7
@ -0,0 +1,12 @@
|
||||
diff -up DBD-SQLite-1.27/Makefile.PL.old DBD-SQLite-1.27/Makefile.PL
|
||||
--- DBD-SQLite-1.27/Makefile.PL.old 2009-11-23 12:08:05.000000000 +0100
|
||||
+++ DBD-SQLite-1.27/Makefile.PL 2010-01-11 15:40:56.456399143 +0100
|
||||
@@ -123,7 +123,7 @@ if ( $@ or DBI->VERSION < $DBI_required
|
||||
# a system sqlite is also sophisticated enough to have a patching system
|
||||
# that can change the if ( 0 ) to if ( 1 )
|
||||
my ($sqlite_local, $sqlite_base, $sqlite_lib, $sqlite_inc);
|
||||
-if ( 0 ) {
|
||||
+if ( 1 ) {
|
||||
require File::Spec;
|
||||
if ( $sqlite_base = (grep(/SQLITE_LOCATION=.*/, @ARGV))[0] ) {
|
||||
$sqlite_base =~ /=(.*)/;
|
@ -1,20 +0,0 @@
|
||||
--- dbdimp.c.orig 2008-03-18 17:37:18.580463431 -0700
|
||||
+++ dbdimp.c 2008-03-18 17:39:04.320466041 -0700
|
||||
@@ -399,7 +399,7 @@
|
||||
continue;
|
||||
}
|
||||
/* There are bug reports that say this should be sqlite3_reset() */
|
||||
- sqlite3_finalize(imp_sth->stmt);
|
||||
+ sqlite3_reset(imp_sth->stmt);
|
||||
sqlite_error(sth, (imp_xxh_t*)imp_sth, imp_sth->retval, (char*)sqlite3_errmsg(imp_dbh->db));
|
||||
return -5;
|
||||
}
|
||||
@@ -419,7 +419,7 @@
|
||||
sqlite_trace(5, "exec ok - %d rows, %d cols\n", imp_sth->nrow, DBIc_NUM_FIELDS(imp_sth));
|
||||
return 0;
|
||||
/* There are bug reports that say this should be sqlite3_reset() */
|
||||
- default: sqlite3_finalize(imp_sth->stmt);
|
||||
+ default: sqlite3_reset(imp_sth->stmt);
|
||||
sqlite_error(sth, (imp_xxh_t*)imp_sth, imp_sth->retval, (char*)sqlite3_errmsg(imp_dbh->db));
|
||||
return -6;
|
||||
}
|
Loading…
Reference in new issue