- 543982 change Makefile.PL to compile with system sqlite

f38
Marcela Mašláňová 15 years ago
parent fd0028ba0e
commit 0e082110d7

@ -0,0 +1,12 @@
diff -up DBD-SQLite-1.27/Makefile.PL.old DBD-SQLite-1.27/Makefile.PL
--- DBD-SQLite-1.27/Makefile.PL.old 2009-11-23 12:08:05.000000000 +0100
+++ DBD-SQLite-1.27/Makefile.PL 2010-01-11 15:40:56.456399143 +0100
@@ -123,7 +123,7 @@ if ( $@ or DBI->VERSION < $DBI_required
# a system sqlite is also sophisticated enough to have a patching system
# that can change the if ( 0 ) to if ( 1 )
my ($sqlite_local, $sqlite_base, $sqlite_lib, $sqlite_inc);
-if ( 0 ) {
+if ( 1 ) {
require File::Spec;
if ( $sqlite_base = (grep(/SQLITE_LOCATION=.*/, @ARGV))[0] ) {
$sqlite_base =~ /=(.*)/;

@ -1,12 +1,13 @@
Name: perl-DBD-SQLite Name: perl-DBD-SQLite
Version: 1.27 Version: 1.27
Release: 2%{?dist} Release: 3%{?dist}
Summary: Self Contained RDBMS in a DBI Driver Summary: Self Contained RDBMS in a DBI Driver
Group: Development/Libraries Group: Development/Libraries
License: GPL+ or Artistic License: GPL+ or Artistic
URL: http://search.cpan.org/dist/DBD-SQLite/ URL: http://search.cpan.org/dist/DBD-SQLite/
Source0: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/DBD-SQLite-%{version}.tar.gz Source0: http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/DBD-SQLite-%{version}.tar.gz
patch0: perl-DBD-SQLite-bz543982.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# if sqlite >= 3.1.3 then # if sqlite >= 3.1.3 then
@ -36,6 +37,7 @@ to install this module, and nothing else.
%prep %prep
%setup -q -n DBD-SQLite-%{version} %setup -q -n DBD-SQLite-%{version}
%patch0 -p1
%build %build
CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS=vendor CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS=vendor
@ -68,6 +70,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Mon Jan 11 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.27-3
- 543982 change Makefile.PL to compile with system sqlite
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.27-2 * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.27-2
- rebuild against perl 5.10.1 - rebuild against perl 5.10.1

@ -1,20 +0,0 @@
--- dbdimp.c.orig 2008-03-18 17:37:18.580463431 -0700
+++ dbdimp.c 2008-03-18 17:39:04.320466041 -0700
@@ -399,7 +399,7 @@
continue;
}
/* There are bug reports that say this should be sqlite3_reset() */
- sqlite3_finalize(imp_sth->stmt);
+ sqlite3_reset(imp_sth->stmt);
sqlite_error(sth, (imp_xxh_t*)imp_sth, imp_sth->retval, (char*)sqlite3_errmsg(imp_dbh->db));
return -5;
}
@@ -419,7 +419,7 @@
sqlite_trace(5, "exec ok - %d rows, %d cols\n", imp_sth->nrow, DBIc_NUM_FIELDS(imp_sth));
return 0;
/* There are bug reports that say this should be sqlite3_reset() */
- default: sqlite3_finalize(imp_sth->stmt);
+ default: sqlite3_reset(imp_sth->stmt);
sqlite_error(sth, (imp_xxh_t*)imp_sth, imp_sth->retval, (char*)sqlite3_errmsg(imp_dbh->db));
return -6;
}
Loading…
Cancel
Save