|
|
|
@ -12,23 +12,11 @@ diff --git a/Makefile.PL b/Makefile.PL
|
|
|
|
|
index 1175783..f523987 100644
|
|
|
|
|
--- a/Makefile.PL
|
|
|
|
|
+++ b/Makefile.PL
|
|
|
|
|
@@ -330,8 +330,7 @@ WriteMakefile(
|
|
|
|
|
'Tie::Hash' => 0,
|
|
|
|
|
'File::Spec' => (WINLIKE ? '3.27' : '0.82'),
|
|
|
|
|
'DBI' => $DBI_required,
|
|
|
|
|
- 'Test::More' => '0.47', # Test::NoWarnings
|
|
|
|
|
- 'Test::Builder' => '0.86', # Test::NoWarnings
|
|
|
|
|
+ 'Test::More' => 0,
|
|
|
|
|
( WINLIKE ? (
|
|
|
|
|
'Win32' => '0.30',
|
|
|
|
|
) : () ),
|
|
|
|
|
@@ -363,8 +362,7 @@ WriteMakefile(
|
|
|
|
|
@@ -367,6 +367,7 @@ WriteMakefile(
|
|
|
|
|
build_requires => {
|
|
|
|
|
'File::Spec' => (WINLIKE ? '3.27' : '0.82'),
|
|
|
|
|
'Test::More' => '0.42',
|
|
|
|
|
- # Bundled in /inc
|
|
|
|
|
- # 'Test::NoWarnings' => '0.081',
|
|
|
|
|
+ 'Test::NoWarnings' => '0.081',
|
|
|
|
|
'Test::More' => '0.88',
|
|
|
|
|
+ 'Test::FailWarnings' => '0.008',
|
|
|
|
|
},
|
|
|
|
|
requires => {
|
|
|
|
|
'Tie::Hash' => 0,
|
|
|
|
@ -36,22 +24,21 @@ diff --git a/t/virtual_table/11_filecontent_fulltext.t b/t/virtual_table/11_file
|
|
|
|
|
index 0a0304f..a49fd35 100644
|
|
|
|
|
--- a/t/virtual_table/11_filecontent_fulltext.t
|
|
|
|
|
+++ b/t/virtual_table/11_filecontent_fulltext.t
|
|
|
|
|
@@ -27,9 +27,7 @@ my @tests = (
|
|
|
|
|
@@ -21,8 +21,7 @@ my @tests = (
|
|
|
|
|
lib/DBD/SQLite/VirtualTable/FileContent.pm
|
|
|
|
|
lib/DBD/SQLite/VirtualTable/PerlData.pm]],
|
|
|
|
|
["install_method" => qw[lib/DBD/SQLite.pm]],
|
|
|
|
|
- ['"use strict"' => qw[inc/Test/NoWarnings.pm
|
|
|
|
|
- inc/Test/NoWarnings/Warning.pm
|
|
|
|
|
- ['"use strict"' => qw[inc/Test/FailWarnings.pm
|
|
|
|
|
- lib/DBD/SQLite.pm
|
|
|
|
|
+ ['"use strict"' => qw[lib/DBD/SQLite.pm
|
|
|
|
|
lib/DBD/SQLite/Constants.pm
|
|
|
|
|
lib/DBD/SQLite/GetInfo.pm
|
|
|
|
|
lib/DBD/SQLite/VirtualTable.pm
|
|
|
|
|
@@ -43,8 +41,7 @@ my @tests = (
|
|
|
|
|
@@ -36,8 +35,7 @@ my @tests = (
|
|
|
|
|
# literally.
|
|
|
|
|
if (grep /ENABLE_FTS3_PARENTHESIS/, DBD::SQLite::compile_options()) {
|
|
|
|
|
if (has_compile_option('ENABLE_FTS3_PARENTHESIS')) {
|
|
|
|
|
push @tests, (
|
|
|
|
|
- ['"use strict" AND "use warnings"' => qw[inc/Test/NoWarnings.pm
|
|
|
|
|
- ['"use strict" AND "use warnings"' => qw[inc/Test/FailWarnings.pm
|
|
|
|
|
- lib/DBD/SQLite/Constants.pm
|
|
|
|
|
+ ['"use strict" AND "use warnings"' => qw[lib/DBD/SQLite/Constants.pm
|
|
|
|
|
lib/DBD/SQLite/GetInfo.pm
|
|
|
|
|