f38
Jitka Plesnikova 6 years ago
parent fcff80f4fe
commit 078134d0a0

1
.gitignore vendored

@ -16,3 +16,4 @@ DBD-SQLite-1.29.tar.gz
/DBD-SQLite-1.58.tar.gz
/DBD-SQLite-1.60.tar.gz
/DBD-SQLite-1.62.tar.gz
/DBD-SQLite-1.64.tar.gz

@ -12,23 +12,11 @@ diff --git a/Makefile.PL b/Makefile.PL
index 1175783..f523987 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -330,8 +330,7 @@ WriteMakefile(
'Tie::Hash' => 0,
'File::Spec' => (WINLIKE ? '3.27' : '0.82'),
'DBI' => $DBI_required,
- 'Test::More' => '0.47', # Test::NoWarnings
- 'Test::Builder' => '0.86', # Test::NoWarnings
+ 'Test::More' => 0,
( WINLIKE ? (
'Win32' => '0.30',
) : () ),
@@ -363,8 +362,7 @@ WriteMakefile(
@@ -367,6 +367,7 @@ WriteMakefile(
build_requires => {
'File::Spec' => (WINLIKE ? '3.27' : '0.82'),
'Test::More' => '0.42',
- # Bundled in /inc
- # 'Test::NoWarnings' => '0.081',
+ 'Test::NoWarnings' => '0.081',
'Test::More' => '0.88',
+ 'Test::FailWarnings' => '0.008',
},
requires => {
'Tie::Hash' => 0,
@ -36,22 +24,21 @@ diff --git a/t/virtual_table/11_filecontent_fulltext.t b/t/virtual_table/11_file
index 0a0304f..a49fd35 100644
--- a/t/virtual_table/11_filecontent_fulltext.t
+++ b/t/virtual_table/11_filecontent_fulltext.t
@@ -27,9 +27,7 @@ my @tests = (
@@ -21,8 +21,7 @@ my @tests = (
lib/DBD/SQLite/VirtualTable/FileContent.pm
lib/DBD/SQLite/VirtualTable/PerlData.pm]],
["install_method" => qw[lib/DBD/SQLite.pm]],
- ['"use strict"' => qw[inc/Test/NoWarnings.pm
- inc/Test/NoWarnings/Warning.pm
- ['"use strict"' => qw[inc/Test/FailWarnings.pm
- lib/DBD/SQLite.pm
+ ['"use strict"' => qw[lib/DBD/SQLite.pm
lib/DBD/SQLite/Constants.pm
lib/DBD/SQLite/GetInfo.pm
lib/DBD/SQLite/VirtualTable.pm
@@ -43,8 +41,7 @@ my @tests = (
@@ -36,8 +35,7 @@ my @tests = (
# literally.
if (grep /ENABLE_FTS3_PARENTHESIS/, DBD::SQLite::compile_options()) {
if (has_compile_option('ENABLE_FTS3_PARENTHESIS')) {
push @tests, (
- ['"use strict" AND "use warnings"' => qw[inc/Test/NoWarnings.pm
- ['"use strict" AND "use warnings"' => qw[inc/Test/FailWarnings.pm
- lib/DBD/SQLite/Constants.pm
+ ['"use strict" AND "use warnings"' => qw[lib/DBD/SQLite/Constants.pm
lib/DBD/SQLite/GetInfo.pm

@ -2,8 +2,8 @@
%bcond_without perl_DBD_SQLite_enables_optional_test
Name: perl-DBD-SQLite
Version: 1.62
Release: 4%{?dist}
Version: 1.64
Release: 1%{?dist}
Summary: SQLite DBI Driver
# lib/DBD/SQLite.pm: GPL+ or Artistic
# LICENSE: GPL+ or Artistic
@ -60,10 +60,11 @@ BuildRequires: perl(Exporter)
BuildRequires: perl(File::Spec::Functions)
BuildRequires: perl(File::Temp)
BuildRequires: perl(FindBin)
BuildRequires: perl(if)
BuildRequires: perl(lib)
# POSIX not used
BuildRequires: perl(Test::More)
BuildRequires: perl(Test::NoWarnings) >= 0.081
BuildRequires: perl(Test::FailWarnings) >= 0.008
# Win32 not used
%if %{with perl_DBD_SQLite_enables_optional_test}
# Optional tests
@ -113,6 +114,9 @@ make test
%{_mandir}/man3/*.3pm*
%changelog
* Tue Aug 13 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1.64-1
- 1.64 bump
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.62-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (DBD-SQLite-1.62.tar.gz) = b452a6245deb0dcc5906167f6ff14d55d70b4f05a1e8113c41810a34f9b75263c2d43f88bb909d872004795ec7d9f4ed93b68ffb5639be7dad9e44e0c8e8439f
SHA512 (DBD-SQLite-1.64.tar.gz) = 36a227193b4544c7cec24eec50ee51f46c00a2dad99ab7b8899b0417ea928a1e223f4052fb75f2d641cbfa4408192492ba8943fdb92520dc9888014467f503a4

Loading…
Cancel
Save