Update to 0.9.12 phase 1

epel9
Sérgio M. Basto 5 years ago
parent 8f273ec18c
commit 69c1237250

@ -150,7 +150,7 @@ diff --git a/rfb/rfb.h b/rfb/rfb.h
index f982b40..ba9e898 100644 index f982b40..ba9e898 100644
--- a/rfb/rfb.h --- a/rfb/rfb.h
+++ b/rfb/rfb.h +++ b/rfb/rfb.h
@@ -415,6 +415,14 @@ typedef struct sraRegion* sraRegionPtr; @@ -413,6 +413,14 @@ typedef struct sraRegion* sraRegionPtr;
typedef void (*ClientGoneHookPtr)(struct _rfbClientRec* cl); typedef void (*ClientGoneHookPtr)(struct _rfbClientRec* cl);
@ -165,9 +165,9 @@ index f982b40..ba9e898 100644
typedef struct _rfbFileTransferData { typedef struct _rfbFileTransferData {
int fd; int fd;
int compressionEnabled; int compressionEnabled;
@@ -696,6 +704,11 @@ typedef struct _rfbClientRec { @@ -694,6 +702,11 @@ typedef struct _rfbClientRec {
wsCtx *wsctx; #ifdef LIBVNCSERVER_HAVE_LIBPTHREAD
char *wspath; /* Requests path component */ int pipe_notify_client_thread[2];
#endif #endif
+ +
+ ClientReadFromSocket readFromSocket; /* Read data from socket */ + ClientReadFromSocket readFromSocket; /* Read data from socket */
@ -177,7 +177,7 @@ index f982b40..ba9e898 100644
} rfbClientRec, *rfbClientPtr; } rfbClientRec, *rfbClientPtr;
/** /**
@@ -748,8 +761,12 @@ extern void rfbDisconnectUDPSock(rfbScreenInfoPtr rfbScreen); @@ -746,8 +759,12 @@ extern void rfbDisconnectUDPSock(rfbScre
extern void rfbCloseClient(rfbClientPtr cl); extern void rfbCloseClient(rfbClientPtr cl);
extern int rfbReadExact(rfbClientPtr cl, char *buf, int len); extern int rfbReadExact(rfbClientPtr cl, char *buf, int len);
extern int rfbReadExactTimeout(rfbClientPtr cl, char *buf, int len,int timeout); extern int rfbReadExactTimeout(rfbClientPtr cl, char *buf, int len,int timeout);
@ -190,6 +190,3 @@ index f982b40..ba9e898 100644
extern int rfbCheckFds(rfbScreenInfoPtr rfbScreen,long usec); extern int rfbCheckFds(rfbScreenInfoPtr rfbScreen,long usec);
extern int rfbConnect(rfbScreenInfoPtr rfbScreen, char* host, int port); extern int rfbConnect(rfbScreenInfoPtr rfbScreen, char* host, int port);
extern int rfbConnectToTcpAddr(char* host, int port); extern int rfbConnectToTcpAddr(char* host, int port);
--
2.17.1

@ -1,28 +0,0 @@
From 75f04c14e49e084e41bdd5491edad8823773a08c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20K=C4=99pie=C5=84?= <github@kempniu.pl>
Date: Tue, 14 Feb 2017 12:42:04 +0100
Subject: [PATCH 40/98] Ensure compatibility with gtk-vnc 0.7.0+
---
libvncserver/websockets.c | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/libvncserver/websockets.c b/libvncserver/websockets.c
index 72396c2..0b2d46f 100644
--- a/libvncserver/websockets.c
+++ b/libvncserver/websockets.c
@@ -245,7 +245,10 @@ webSocketsCheck (rfbClientPtr cl)
return FALSE;
}
- if (strncmp(bbuf, "<", 1) == 0) {
+ if (strncmp(bbuf, "RFB ", 4) == 0) {
+ rfbLog("Normal socket connection\n");
+ return TRUE;
+ } else if (strncmp(bbuf, "<", 1) == 0) {
rfbLog("Got Flash policy request, sending response\n");
if (rfbWriteExact(cl, FLASH_POLICY_RESPONSE,
SZ_FLASH_POLICY_RESPONSE) < 0) {
--
2.9.4

@ -0,0 +1,22 @@
--- ./CMakeLists.txt.orig 2020-02-10 05:29:48.921993426 +0000
+++ ./CMakeLists.txt 2020-02-10 19:27:27.762744228 +0000
@@ -666,8 +666,8 @@ get_link_libraries(PRIVATE_LIBS vncclien
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libvncclient.pc.cmakein ${CMAKE_CURRENT_BINARY_DIR}/libvncclient.pc @ONLY)
-install_targets(/lib vncserver)
-install_targets(/lib vncclient)
+install_targets(/lib64 vncserver)
+install_targets(/lib64 vncclient)
install_files(/include/rfb FILES
rfb/keysym.h
rfb/rfb.h
@@ -677,7 +677,7 @@ install_files(/include/rfb FILES
rfb/rfbregion.h
)
-install_files(/lib/pkgconfig FILES
+install_files(/lib64/pkgconfig FILES
libvncserver.pc
libvncclient.pc
)

@ -1,15 +1,14 @@
Summary: Library to make writing a VNC server easy Summary: Library to make writing a VNC server easy
Name: libvncserver Name: libvncserver
Version: 0.9.11 Version: 0.9.12
Release: 11%{?dist} Release: 1%{?dist}
# NOTE: --with-filetransfer => GPLv2 # NOTE: --with-filetransfer => GPLv2
License: GPLv2+ License: GPLv2+
URL: http://libvnc.github.io/ URL: http://libvnc.github.io/
Source0: https://github.com/LibVNC/libvncserver/archive/LibVNCServer-%{version}.tar.gz Source0: https://github.com/LibVNC/libvncserver/archive/LibVNCServer-%{version}.tar.gz
## upstream patches Patch1: CMakeLists.txt.patch
Patch4: 0040-Ensure-compatibility-with-gtk-vnc-0.7.0.patch
## TLS security type enablement patches ## TLS security type enablement patches
# https://github.com/LibVNC/libvncserver/pull/234 # https://github.com/LibVNC/libvncserver/pull/234
@ -27,16 +26,30 @@ Patch104: libvncserver-0.9.11-Validate-client-cut-text-length.patch
# 2/2 Fix CVE-2018-7225, bug #1546860 # 2/2 Fix CVE-2018-7225, bug #1546860
Patch105: libvncserver-0.9.11-Limit-client-cut-text-length-to-1-MB.patch Patch105: libvncserver-0.9.11-Limit-client-cut-text-length-to-1-MB.patch
BuildRequires: autoconf BuildRequires: cmake
BuildRequires: automake BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(sdl2)
BuildRequires: pkgconfig(libsystemd)
BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(xdamage)
BuildRequires: pkgconfig(xext)
BuildRequires: pkgconfig(xrandr)
BuildRequires: pkgconfig(xtst)
BuildRequires: pkgconfig(xinerama)
BuildRequires: pkgconfig(xfixes)
BuildRequires: pkgconfig(openssl)
BuildRequires: pkgconfig(zlib)
BuildRequires: pkgconfig(libjpeg)
BuildRequires: pkgconfig(libpng)
#BuildRequires: pkgconfig(lzo2)
#BuildRequires: ffmpeg-devel
BuildRequires: gettext-devel
BuildRequires: libgcrypt-devel BuildRequires: libgcrypt-devel
BuildRequires: libjpeg-devel
BuildRequires: libtool
BuildRequires: lzo-devel BuildRequires: lzo-devel
BuildRequires: lzo-minilzo BuildRequires: lzo-minilzo
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(libcrypto) BuildRequires: pkgconfig(libcrypto)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(libssl) BuildRequires: pkgconfig(libssl)
# Additional deps for --with-x11vnc, see https://bugzilla.redhat.com/show_bug.cgi?id=864947 # Additional deps for --with-x11vnc, see https://bugzilla.redhat.com/show_bug.cgi?id=864947
BuildRequires: pkgconfig(avahi-client) BuildRequires: pkgconfig(avahi-client)
@ -75,25 +88,20 @@ developing applications that use %{name}.
%prep %prep
%setup -q -n %{name}-LibVNCServer-%{version} %setup -q -n %{name}-LibVNCServer-%{version}
%patch4 -p1 -b .0004 %patch1 -p1
#patch4 -p1 -b .0004
%patch10 -p1 %patch10 -p1
%patch11 -p1 %patch11 -p1
%patch100 -p1 -b .system_minilzo #patch100 -p1 -b .system_minilzo
# Nuke bundled minilzo # Nuke bundled minilzo
#rm -fv common/lzodefs.h common/lzoconf.h commmon/minilzo.h common/minilzo.c rm -fv common/lzodefs.h common/lzoconf.h commmon/minilzo.h common/minilzo.c
%patch101 -p1 -b .multilib #patch101 -p1 -b .multilib
%patch102 -p1 %patch102 -p1
%if 0%{?fedora} < 26 #patch104 -p1
%patch103 -p1 -b .soname #patch105 -p1
%global soname 0
%else
%global soname 1
%endif
%patch104 -p1
%patch105 -p1
# Fix encoding # Fix encoding
for file in ChangeLog ; do for file in ChangeLog ; do
@ -102,48 +110,27 @@ for file in ChangeLog ; do
touch --reference ${file}.OLD $file touch --reference ${file}.OLD $file
done done
# Needed by patch 1 (and to nuke rpath's)
autoreconf -vif
%build %build
%configure \ mkdir -p %{_target_platform}
--disable-silent-rules \ pushd %{_target_platform}
--disable-static \ %cmake ..
--without-filetransfer \ popd
--with-gcrypt \ %make_build -C %{_target_platform}
--with-png \
--with-x11vnc
# Hack to omit unused-direct-shlib-dependencies
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool
make %{?_smp_mflags}
%install %install
%make_install %make_install -C %{_target_platform}
# Unpackaged files
rm -fv %{buildroot}%{_bindir}/linuxvnc
rm -fv %{buildroot}%{_libdir}/lib*.a
rm -fv %{buildroot}%{_libdir}/lib*.la
%check
make -C test test ||:
%ldconfig_scriptlets %ldconfig_scriptlets
%files %files
%license COPYING %license COPYING
%doc AUTHORS ChangeLog NEWS README TODO %doc AUTHORS ChangeLog NEWS README.md TODO
%{_libdir}/libvncclient.so.%{soname}* %{_libdir}/libvncclient.so.*
%{_libdir}/libvncserver.so.%{soname}* %{_libdir}/libvncserver.so.*
%files devel %files devel
%{_bindir}/libvncserver-config #{_bindir}/libvncserver-config
%{_includedir}/rfb/ %{_includedir}/rfb/
%{_libdir}/libvncclient.so %{_libdir}/libvncclient.so
%{_libdir}/libvncserver.so %{_libdir}/libvncserver.so
@ -152,6 +139,9 @@ make -C test test ||:
%changelog %changelog
* Tue Feb 11 2020 Sérgio Basto <sergio@serjux.com> - 0.9.12-1
- Update to 0.9.12
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.11-11 * Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.11-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

Loading…
Cancel
Save