|
|
@ -1,12 +1,11 @@
|
|
|
|
diff -up ./java/Makefile.orig ./java/Makefile
|
|
|
|
diff -up ./java/Makefile.orig ./java/Makefile
|
|
|
|
--- ./java/Makefile.orig 2009-02-18 10:41:04.000000000 +1000
|
|
|
|
--- ./java/Makefile.orig 2009-02-18 10:41:04.000000000 +1000
|
|
|
|
+++ ./java/Makefile 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./java/Makefile 2009-09-18 10:13:04.000000000 +1000
|
|
|
|
@@ -4,13 +4,22 @@ FILES = libsvm/svm.class libsvm/svm_mode
|
|
|
|
@@ -4,13 +4,21 @@ FILES = libsvm/svm.class libsvm/svm_mode
|
|
|
|
libsvm/svm_print_interface.class \
|
|
|
|
libsvm/svm_print_interface.class \
|
|
|
|
svm_train.class svm_predict.class svm_toy.class svm_scale.class
|
|
|
|
svm_train.class svm_predict.class svm_toy.class svm_scale.class
|
|
|
|
|
|
|
|
|
|
|
|
+JAVA_TARGETDIR=${INSTDIR}/share/libsvm/java
|
|
|
|
+JAVA_DOC_DIR=${INSTDIR}/share/javadoc/libsvm-${LIBSVM_VER}
|
|
|
|
+JAVA_DOCDIR=${INSTDIR}/share/javadoc/libsvm-${LIBSVM_VER}
|
|
|
|
|
|
|
|
+CLASSPATH = .
|
|
|
|
+CLASSPATH = .
|
|
|
|
#JAVAC = jikes
|
|
|
|
#JAVAC = jikes
|
|
|
|
-JAVAC_FLAGS = -target 1.5 -source 1.5
|
|
|
|
-JAVAC_FLAGS = -target 1.5 -source 1.5
|
|
|
@ -26,7 +25,7 @@ diff -up ./java/Makefile.orig ./java/Makefile
|
|
|
|
|
|
|
|
|
|
|
|
.java.class:
|
|
|
|
.java.class:
|
|
|
|
$(JAVAC) $(JAVAC_FLAGS) $<
|
|
|
|
$(JAVAC) $(JAVAC_FLAGS) $<
|
|
|
|
@@ -18,8 +27,24 @@ all: $(FILES)
|
|
|
|
@@ -18,8 +26,23 @@ all: $(FILES)
|
|
|
|
libsvm/svm.java: libsvm/svm.m4
|
|
|
|
libsvm/svm.java: libsvm/svm.m4
|
|
|
|
m4 libsvm/svm.m4 > libsvm/svm.java
|
|
|
|
m4 libsvm/svm.m4 > libsvm/svm.java
|
|
|
|
|
|
|
|
|
|
|
@ -36,14 +35,13 @@ diff -up ./java/Makefile.orig ./java/Makefile
|
|
|
|
+ javadoc -d docs *.java libsvm/*.java
|
|
|
|
+ javadoc -d docs *.java libsvm/*.java
|
|
|
|
+
|
|
|
|
+
|
|
|
|
+install:
|
|
|
|
+install:
|
|
|
|
+ mkdir -p ${JAVA_TARGETDIR}
|
|
|
|
+ mkdir -p ${JAVA_TARGET_DIR}
|
|
|
|
+ install -m 644 libsvm.jar ${JAVA_TARGETDIR}
|
|
|
|
+ install -m 644 libsvm.jar ${JAVA_TARGET_DIR}
|
|
|
|
+ install -m 644 test_applet.html ${JAVA_TARGETDIR}
|
|
|
|
+# mkdir -p ${JAVA_DOC_DIR}
|
|
|
|
+# mkdir -p ${JAVA_DOCDIR}
|
|
|
|
+# cd docs; cp -R * ${JAVA_DOC_DIR}
|
|
|
|
+# cd docs; cp -R * ${JAVA_DOCDIR}
|
|
|
|
|
|
|
|
+uninstall:
|
|
|
|
+uninstall:
|
|
|
|
+ rm -fr ${JAVA_TARGETDIR}
|
|
|
|
+ rm -fr ${JAVA_TARGETDIR}
|
|
|
|
+ rm -fr ${JAVA_DOCDIR}
|
|
|
|
+# rm -fr ${JAVA_DOC_DIR}
|
|
|
|
+
|
|
|
|
+
|
|
|
|
clean:
|
|
|
|
clean:
|
|
|
|
rm -f libsvm/*.class *.class *.jar libsvm/*~ *~ libsvm/svm.java
|
|
|
|
rm -f libsvm/*.class *.class *.jar libsvm/*~ *~ libsvm/svm.java
|
|
|
@ -53,7 +51,7 @@ diff -up ./java/Makefile.orig ./java/Makefile
|
|
|
|
rm *.class libsvm/*.class
|
|
|
|
rm *.class libsvm/*.class
|
|
|
|
diff -up ./java/test_applet.html.orig ./java/test_applet.html
|
|
|
|
diff -up ./java/test_applet.html.orig ./java/test_applet.html
|
|
|
|
--- ./java/test_applet.html.orig 2003-07-12 14:07:32.000000000 +1000
|
|
|
|
--- ./java/test_applet.html.orig 2003-07-12 14:07:32.000000000 +1000
|
|
|
|
+++ ./java/test_applet.html 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./java/test_applet.html 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -1 +1,3 @@
|
|
|
|
@@ -1 +1,3 @@
|
|
|
|
-<APPLET code="svm_toy.class" archive="libsvm.jar" width=300 height=350></APPLET>
|
|
|
|
-<APPLET code="svm_toy.class" archive="libsvm.jar" width=300 height=350></APPLET>
|
|
|
|
+<html>
|
|
|
|
+<html>
|
|
|
@ -61,7 +59,7 @@ diff -up ./java/test_applet.html.orig ./java/test_applet.html
|
|
|
|
+</html>
|
|
|
|
+</html>
|
|
|
|
diff -up ./Makefile.orig ./Makefile
|
|
|
|
diff -up ./Makefile.orig ./Makefile
|
|
|
|
--- ./Makefile.orig 2008-09-15 14:36:48.000000000 +1000
|
|
|
|
--- ./Makefile.orig 2008-09-15 14:36:48.000000000 +1000
|
|
|
|
+++ ./Makefile 2009-09-16 14:40:39.000000000 +1000
|
|
|
|
+++ ./Makefile 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -1,11 +1,40 @@
|
|
|
|
@@ -1,11 +1,40 @@
|
|
|
|
CXX? = g++
|
|
|
|
CXX? = g++
|
|
|
|
-CFLAGS = -Wall -Wconversion -O3 -fPIC
|
|
|
|
-CFLAGS = -Wall -Wconversion -O3 -fPIC
|
|
|
@ -175,7 +173,7 @@ diff -up ./Makefile.orig ./Makefile
|
|
|
|
+
|
|
|
|
+
|
|
|
|
diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
--- ./python/Makefile.orig 2008-12-10 09:05:08.000000000 +1000
|
|
|
|
--- ./python/Makefile.orig 2008-12-10 09:05:08.000000000 +1000
|
|
|
|
+++ ./python/Makefile 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./python/Makefile 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -2,9 +2,11 @@ CXX? = g++
|
|
|
|
@@ -2,9 +2,11 @@ CXX? = g++
|
|
|
|
SWIG ?= swig
|
|
|
|
SWIG ?= swig
|
|
|
|
|
|
|
|
|
|
|
@ -225,7 +223,7 @@ diff -up ./python/Makefile.orig ./python/Makefile
|
|
|
|
+
|
|
|
|
+
|
|
|
|
diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
|
|
|
|
diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
|
|
|
|
--- ./svm-toy/gtk/callbacks.cpp.orig 2006-03-04 17:40:12.000000000 +1000
|
|
|
|
--- ./svm-toy/gtk/callbacks.cpp.orig 2006-03-04 17:40:12.000000000 +1000
|
|
|
|
+++ ./svm-toy/gtk/callbacks.cpp 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./svm-toy/gtk/callbacks.cpp 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -2,6 +2,7 @@
|
|
|
|
@@ -2,6 +2,7 @@
|
|
|
|
#include <stdio.h>
|
|
|
|
#include <stdio.h>
|
|
|
|
#include <ctype.h>
|
|
|
|
#include <ctype.h>
|
|
|
@ -236,7 +234,7 @@ diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
|
|
|
|
#include "../../svm.h"
|
|
|
|
#include "../../svm.h"
|
|
|
|
diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
|
|
|
|
diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
|
|
|
|
--- ./svm-toy/gtk/Makefile.orig 2007-10-14 16:29:12.000000000 +1000
|
|
|
|
--- ./svm-toy/gtk/Makefile.orig 2007-10-14 16:29:12.000000000 +1000
|
|
|
|
+++ ./svm-toy/gtk/Makefile 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./svm-toy/gtk/Makefile 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -2,21 +2,27 @@ CC? = gcc
|
|
|
|
@@ -2,21 +2,27 @@ CC? = gcc
|
|
|
|
CXX? = g++
|
|
|
|
CXX? = g++
|
|
|
|
CFLAGS = -Wall -O3 -g `gtk-config --cflags`
|
|
|
|
CFLAGS = -Wall -O3 -g `gtk-config --cflags`
|
|
|
@ -275,7 +273,7 @@ diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
|
|
|
|
+ rm -f *~ callbacks.o svm-toy-gtk main.o interface.o callbacks.o
|
|
|
|
+ rm -f *~ callbacks.o svm-toy-gtk main.o interface.o callbacks.o
|
|
|
|
diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
|
|
|
|
diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
|
|
|
|
--- ./svm-toy/qt/Makefile.orig 2008-12-19 16:42:05.000000000 +1000
|
|
|
|
--- ./svm-toy/qt/Makefile.orig 2008-12-19 16:42:05.000000000 +1000
|
|
|
|
+++ ./svm-toy/qt/Makefile 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./svm-toy/qt/Makefile 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -1,17 +1,21 @@
|
|
|
|
@@ -1,17 +1,21 @@
|
|
|
|
CXX? = g++
|
|
|
|
CXX? = g++
|
|
|
|
-CFLAGS = -Wall -O3 -I$(INCLUDE) -I$(INCLUDE)/QtGui -lQtGui
|
|
|
|
-CFLAGS = -Wall -O3 -I$(INCLUDE) -I$(INCLUDE)/QtGui -lQtGui
|
|
|
@ -308,7 +306,7 @@ diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
|
|
|
|
|
|
|
|
|
|
|
|
diff -up ./tools/easy.py.orig ./tools/easy.py
|
|
|
|
diff -up ./tools/easy.py.orig ./tools/easy.py
|
|
|
|
--- ./tools/easy.py.orig 2009-01-14 07:13:26.000000000 +1000
|
|
|
|
--- ./tools/easy.py.orig 2009-01-14 07:13:26.000000000 +1000
|
|
|
|
+++ ./tools/easy.py 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./tools/easy.py 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -2,6 +2,7 @@
|
|
|
|
@@ -2,6 +2,7 @@
|
|
|
|
|
|
|
|
|
|
|
|
import sys
|
|
|
|
import sys
|
|
|
@ -334,7 +332,7 @@ diff -up ./tools/easy.py.orig ./tools/easy.py
|
|
|
|
# example for windows
|
|
|
|
# example for windows
|
|
|
|
diff -up ./tools/grid.py.orig ./tools/grid.py
|
|
|
|
diff -up ./tools/grid.py.orig ./tools/grid.py
|
|
|
|
--- ./tools/grid.py.orig 2008-08-08 20:41:11.000000000 +1000
|
|
|
|
--- ./tools/grid.py.orig 2008-08-08 20:41:11.000000000 +1000
|
|
|
|
+++ ./tools/grid.py 2009-09-16 13:44:31.000000000 +1000
|
|
|
|
+++ ./tools/grid.py 2009-09-18 10:10:34.000000000 +1000
|
|
|
|
@@ -11,7 +11,7 @@ from subprocess import *
|
|
|
|
@@ -11,7 +11,7 @@ from subprocess import *
|
|
|
|
|
|
|
|
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|
is_win32 = (sys.platform == 'win32')
|
|
|
|