diff --git a/import.log b/import.log
index 5d497c5..cdc99e7 100644
--- a/import.log
+++ b/import.log
@@ -3,3 +3,4 @@ libsvm-2_88-1_fc9:HEAD:libsvm-2.88-1.fc9.src.rpm:1226296273
libsvm-2_88-2_fc9:HEAD:libsvm-2.88-2.fc9.src.rpm:1226365469
libsvm-2_89-1_fc10:HEAD:libsvm-2.89-1.fc10.src.rpm:1238738697
libsvm-2_89-3_fc11:HEAD:libsvm-2.89-3.fc11.src.rpm:1253083141
+libsvm-2_89-4_fc11:HEAD:libsvm-2.89-4.fc11.src.rpm:1253235532
diff --git a/libsvm-2.89.patch b/libsvm-2.89.patch
index 2c0d28f..5673758 100644
--- a/libsvm-2.89.patch
+++ b/libsvm-2.89.patch
@@ -1,12 +1,11 @@
diff -up ./java/Makefile.orig ./java/Makefile
--- ./java/Makefile.orig 2009-02-18 10:41:04.000000000 +1000
-+++ ./java/Makefile 2009-09-16 13:44:31.000000000 +1000
-@@ -4,13 +4,22 @@ FILES = libsvm/svm.class libsvm/svm_mode
++++ ./java/Makefile 2009-09-18 10:13:04.000000000 +1000
+@@ -4,13 +4,21 @@ FILES = libsvm/svm.class libsvm/svm_mode
libsvm/svm_print_interface.class \
svm_train.class svm_predict.class svm_toy.class svm_scale.class
-+JAVA_TARGETDIR=${INSTDIR}/share/libsvm/java
-+JAVA_DOCDIR=${INSTDIR}/share/javadoc/libsvm-${LIBSVM_VER}
++JAVA_DOC_DIR=${INSTDIR}/share/javadoc/libsvm-${LIBSVM_VER}
+CLASSPATH = .
#JAVAC = jikes
-JAVAC_FLAGS = -target 1.5 -source 1.5
@@ -26,7 +25,7 @@ diff -up ./java/Makefile.orig ./java/Makefile
.java.class:
$(JAVAC) $(JAVAC_FLAGS) $<
-@@ -18,8 +27,24 @@ all: $(FILES)
+@@ -18,8 +26,23 @@ all: $(FILES)
libsvm/svm.java: libsvm/svm.m4
m4 libsvm/svm.m4 > libsvm/svm.java
@@ -36,14 +35,13 @@ diff -up ./java/Makefile.orig ./java/Makefile
+ javadoc -d docs *.java libsvm/*.java
+
+install:
-+ mkdir -p ${JAVA_TARGETDIR}
-+ install -m 644 libsvm.jar ${JAVA_TARGETDIR}
-+ install -m 644 test_applet.html ${JAVA_TARGETDIR}
-+# mkdir -p ${JAVA_DOCDIR}
-+# cd docs; cp -R * ${JAVA_DOCDIR}
++ mkdir -p ${JAVA_TARGET_DIR}
++ install -m 644 libsvm.jar ${JAVA_TARGET_DIR}
++# mkdir -p ${JAVA_DOC_DIR}
++# cd docs; cp -R * ${JAVA_DOC_DIR}
+uninstall:
+ rm -fr ${JAVA_TARGETDIR}
-+ rm -fr ${JAVA_DOCDIR}
++# rm -fr ${JAVA_DOC_DIR}
+
clean:
rm -f libsvm/*.class *.class *.jar libsvm/*~ *~ libsvm/svm.java
@@ -53,7 +51,7 @@ diff -up ./java/Makefile.orig ./java/Makefile
rm *.class libsvm/*.class
diff -up ./java/test_applet.html.orig ./java/test_applet.html
--- ./java/test_applet.html.orig 2003-07-12 14:07:32.000000000 +1000
-+++ ./java/test_applet.html 2009-09-16 13:44:31.000000000 +1000
++++ ./java/test_applet.html 2009-09-18 10:10:34.000000000 +1000
@@ -1 +1,3 @@
-
+
@@ -61,7 +59,7 @@ diff -up ./java/test_applet.html.orig ./java/test_applet.html
+
diff -up ./Makefile.orig ./Makefile
--- ./Makefile.orig 2008-09-15 14:36:48.000000000 +1000
-+++ ./Makefile 2009-09-16 14:40:39.000000000 +1000
++++ ./Makefile 2009-09-18 10:10:34.000000000 +1000
@@ -1,11 +1,40 @@
CXX? = g++
-CFLAGS = -Wall -Wconversion -O3 -fPIC
@@ -175,7 +173,7 @@ diff -up ./Makefile.orig ./Makefile
+
diff -up ./python/Makefile.orig ./python/Makefile
--- ./python/Makefile.orig 2008-12-10 09:05:08.000000000 +1000
-+++ ./python/Makefile 2009-09-16 13:44:31.000000000 +1000
++++ ./python/Makefile 2009-09-18 10:10:34.000000000 +1000
@@ -2,9 +2,11 @@ CXX? = g++
SWIG ?= swig
@@ -225,7 +223,7 @@ diff -up ./python/Makefile.orig ./python/Makefile
+
diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
--- ./svm-toy/gtk/callbacks.cpp.orig 2006-03-04 17:40:12.000000000 +1000
-+++ ./svm-toy/gtk/callbacks.cpp 2009-09-16 13:44:31.000000000 +1000
++++ ./svm-toy/gtk/callbacks.cpp 2009-09-18 10:10:34.000000000 +1000
@@ -2,6 +2,7 @@
#include
#include
@@ -236,7 +234,7 @@ diff -up ./svm-toy/gtk/callbacks.cpp.orig ./svm-toy/gtk/callbacks.cpp
#include "../../svm.h"
diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
--- ./svm-toy/gtk/Makefile.orig 2007-10-14 16:29:12.000000000 +1000
-+++ ./svm-toy/gtk/Makefile 2009-09-16 13:44:31.000000000 +1000
++++ ./svm-toy/gtk/Makefile 2009-09-18 10:10:34.000000000 +1000
@@ -2,21 +2,27 @@ CC? = gcc
CXX? = g++
CFLAGS = -Wall -O3 -g `gtk-config --cflags`
@@ -275,7 +273,7 @@ diff -up ./svm-toy/gtk/Makefile.orig ./svm-toy/gtk/Makefile
+ rm -f *~ callbacks.o svm-toy-gtk main.o interface.o callbacks.o
diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
--- ./svm-toy/qt/Makefile.orig 2008-12-19 16:42:05.000000000 +1000
-+++ ./svm-toy/qt/Makefile 2009-09-16 13:44:31.000000000 +1000
++++ ./svm-toy/qt/Makefile 2009-09-18 10:10:34.000000000 +1000
@@ -1,17 +1,21 @@
CXX? = g++
-CFLAGS = -Wall -O3 -I$(INCLUDE) -I$(INCLUDE)/QtGui -lQtGui
@@ -308,7 +306,7 @@ diff -up ./svm-toy/qt/Makefile.orig ./svm-toy/qt/Makefile
diff -up ./tools/easy.py.orig ./tools/easy.py
--- ./tools/easy.py.orig 2009-01-14 07:13:26.000000000 +1000
-+++ ./tools/easy.py 2009-09-16 13:44:31.000000000 +1000
++++ ./tools/easy.py 2009-09-18 10:10:34.000000000 +1000
@@ -2,6 +2,7 @@
import sys
@@ -334,7 +332,7 @@ diff -up ./tools/easy.py.orig ./tools/easy.py
# example for windows
diff -up ./tools/grid.py.orig ./tools/grid.py
--- ./tools/grid.py.orig 2008-08-08 20:41:11.000000000 +1000
-+++ ./tools/grid.py 2009-09-16 13:44:31.000000000 +1000
++++ ./tools/grid.py 2009-09-18 10:10:34.000000000 +1000
@@ -11,7 +11,7 @@ from subprocess import *
is_win32 = (sys.platform == 'win32')
diff --git a/libsvm.spec b/libsvm.spec
index 89a8616..6d6705f 100644
--- a/libsvm.spec
+++ b/libsvm.spec
@@ -1,6 +1,6 @@
Name: libsvm
Version: 2.89
-Release: 3%{?dist}
+Release: 4%{?dist}
Summary: A Library for Support Vector Machines
Group: Development/Libraries
@@ -28,13 +28,13 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
%else
%define moc_path %{_libdir}/qt4/bin/moc
%endif
+
%ifnarch ppc ppc64
%define no_java FALSE
%else
%define no_java NO_JAVA
%endif
-
%description
LIBSVM is an integrated software for support vector classification,
(C-SVC, nu-SVC ), regression (epsilon-SVR, nu-SVR) and distribution
@@ -68,8 +68,11 @@ programs with libsvm in Python.
%package java
Summary: Java tools and interfaces for libsvm
Group: Development/Libraries
-BuildRequires: java-1.6.0-openjdk-devel
-Requires: jre >= 1.6.0
+BuildRequires: java-devel >= 1.5.0
+BuildRequires: jpackage-utils
+
+Requires: java >= 1.5.0
+Requires: jpackage-utils
Requires: %{name} = %{version}-%{release}
%description java
@@ -129,7 +132,7 @@ cp README svm-toy/qt
%install
rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} PYTHON_VERSION="%{pyver}" LIBSVM_VER="%{version}" NO_JAVA="%{no_java}"
+make install DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} PYTHON_VERSION="%{pyver}" LIBSVM_VER="%{version}" NO_JAVA="%{no_java}" JAVA_TARGET_DIR="${RPM_BUILD_ROOT}/%{_javadir}"
ln -sf %{name}.so.1 ${RPM_BUILD_ROOT}%{_libdir}/%{name}.so
rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/src
mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/48x48/apps/
@@ -198,8 +201,8 @@ rm -rf $RPM_BUILD_ROOT
%ifnarch ppc ppc64
%files java
%defattr(-,root,root,-)
-%doc java/README-Java
-%{_datadir}/%{name}/java
+%doc java/README-Java java/test_applet.html
+%{_javadir}/%{name}.jar
#%{_datadir}/javadoc/%{name}-%{version}
%endif
@@ -219,7 +222,14 @@ rm -rf $RPM_BUILD_ROOT
%changelog
-* Mon Sep 16 2009 Ding-Yi Chen - 2.89-3
+* Fri Sep 18 2009 Ding-Yi Chen - 2.89-4
+- Fixed [Bug 524108] put libsvm.jar into _javadir
+ + Move livsvm.jar to _javadir
+ + Move test_applet.html to _datadir/doc/libsvm-
+- Buildrequire changed to java-devel>=1.5.0, jpackage-utils
+- Require changed to java>=1.5.0, jpackage-utils
+
+* Wed Sep 16 2009 Ding-Yi Chen - 2.89-3
- Fix the building for EL-5
Note that libsvm-java on ppc and ppc64 for EL-5 is excluded,
as java-1.6.0-openjdk-devel for them do not exist yet.