there are no string literal operators used in LibO :)

f41
David Tardon 13 years ago
parent ea9791b36e
commit eb2adfd69d

@ -0,0 +1,25 @@
From 0669fdb4874f8169ce1e49f3ae946c87ce1478ce Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 11 Jan 2012 07:47:38 +0100
Subject: [PATCH] fix for gcc 4.7/C++11: this is not string literal operator
---
xmlsecurity/source/xmlsec/nss/nssinitializer.cxx | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx b/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx
index a1e5977..0e2553d 100644
--- a/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx
+++ b/xmlsecurity/source/xmlsec/nss/nssinitializer.cxx
@@ -297,7 +297,7 @@ bool nsscrypto_initialize( const css::uno::Reference< css::lang::XMultiServiceFa
deleteRootsModule();
#if defined SYSTEM_MOZILLA
- OUString rootModule(RTL_CONSTASCII_USTRINGPARAM("libnssckbi"SAL_DLLEXTENSION));
+ OUString rootModule(RTL_CONSTASCII_USTRINGPARAM("libnssckbi" SAL_DLLEXTENSION));
#else
OUString rootModule(RTL_CONSTASCII_USTRINGPARAM("${LO_LIB_DIR}/libnssckbi" SAL_DLLEXTENSION));
#endif
--
1.7.7.5

@ -117,6 +117,7 @@ Patch16: 0001-workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
Patch17: 0001-smath-does-not-handle-accents-in-MathML.patch Patch17: 0001-smath-does-not-handle-accents-in-MathML.patch
Patch18: 0001-workaround-internal-compiler-error-with-gcc-4.7.patch Patch18: 0001-workaround-internal-compiler-error-with-gcc-4.7.patch
Patch19: 0001-fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch Patch19: 0001-fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
Patch20: 0001-fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
# TODO: this in S390 only, so it can wait .-) # TODO: this in S390 only, so it can wait .-)
#Patch13: solenv.fix.mk.inheritance.patch #Patch13: solenv.fix.mk.inheritance.patch
@ -770,6 +771,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch17 -p1 -b .smath-does-not-handle-accents-in-MathML.patch %patch17 -p1 -b .smath-does-not-handle-accents-in-MathML.patch
%patch18 -p1 -b .workaround-internal-compiler-error-with-gcc-4.7.patch %patch18 -p1 -b .workaround-internal-compiler-error-with-gcc-4.7.patch
%patch19 -p1 -b .fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch %patch19 -p1 -b .fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
%patch20 -p1 -b .fix-for-gcc-4.7-C-11-this-is-not-string-literal-oper.patch
#%patch13 -p1 -b .solenv.fix.mk.inheritance.patch #%patch13 -p1 -b .solenv.fix.mk.inheritance.patch
# TODO: check this # TODO: check this

Loading…
Cancel
Save