there are no string literal operators used in LibO :)

f41
David Tardon 13 years ago
parent 8888a4047d
commit ea9791b36e

@ -0,0 +1,58 @@
From b2dd236acdef807b51e27692ace5afd82f96585a Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Tue, 10 Jan 2012 19:32:51 +0100
Subject: [PATCH] fix for gcc 4.7/C++11: these are not string literal
operators
---
binfilter/bf_sch/source/core/sch_globfunc.cxx | 4 ++--
binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/binfilter/bf_sch/source/core/sch_globfunc.cxx b/binfilter/bf_sch/source/core/sch_globfunc.cxx
index 6a81bf1..ac87608 100644
--- a/binfilter/bf_sch/source/core/sch_globfunc.cxx
+++ b/binfilter/bf_sch/source/core/sch_globfunc.cxx
@@ -1193,7 +1193,7 @@ namespace binfilter {
/*N*/ const USHORT* pRanges = rSet.GetRanges();
/*N*/ for( long n = 0; pRanges[ n ] && n<32; n+=2 )
/*N*/ {
-/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "[%"SAL_PRIdINT32"; %"SAL_PRIdINT32"] ", (sal_uInt32)pRanges[ n ], (sal_uInt32)pRanges[ n+1 ] );
+/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "[%" SAL_PRIdINT32 "; %" SAL_PRIdINT32 "] ", (sal_uInt32)pRanges[ n ], (sal_uInt32)pRanges[ n+1 ] );
/*N*/ strncat( pBuf, pSmallBuf, sizeof(pBuf) - strlen(pBuf) - 1 );
/*N*/ }
/*N*/
@@ -1219,7 +1219,7 @@ namespace binfilter {
/*N*/ nCns++;
/*N*/ if( nCnt < 100 )
/*N*/ {
-/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "%"SAL_PRIdINT32", ", (sal_uInt32) nWhich );
+/*N*/ snprintf( pSmallBuf, sizeof(pSmallBuf), "%" SAL_PRIdINT32 ", ", (sal_uInt32) nWhich );
/*N*/ strncat( pBuf, pSmallBuf, sizeof(pBuf) - strlen(pBuf) - 1 );
/*N*/ }
/*N*/
diff --git a/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx b/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx
index f2e9607..ce3ce33 100644
--- a/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx
+++ b/binfilter/bf_sw/source/core/sw3io/sw_sw3imp.cxx
@@ -1644,7 +1644,7 @@ void Sw3StringPool::LoadOld( SvStream& r )
/*N*/ if( pCrypter )
/*N*/ {
/*?*/ sal_Char buf[ 17 ];
-/*?*/ snprintf( buf, sizeof(buf), "%08"SAL_PRIxUINT32"%08"SAL_PRIxUINT32, nDate, nTime );
+/*?*/ snprintf( buf, sizeof(buf), "%08" SAL_PRIxUINT32 "%08" SAL_PRIxUINT32, nDate, nTime );
/*?*/ rtl::OStringBuffer aTest( buf );
/*?*/ pCrypter->Encrypt( aTest );
/*?*/ return sal_Bool( !memcmp( cPasswd, aTest.getStr(), PASSWDLEN ) );
@@ -1662,7 +1662,7 @@ void Sw3StringPool::LoadOld( SvStream& r )
/*N*/ {
/*?*/ pCrypter = new Crypter( pRoot->GetKey() );
/*?*/ sal_Char buf[ 17 ];
-/*?*/ snprintf( buf, sizeof(buf), "%08"SAL_PRIxUINT32"%08"SAL_PRIxUINT32, nDate, nTime );
+/*?*/ snprintf( buf, sizeof(buf), "%08" SAL_PRIxUINT32 "%08" SAL_PRIxUINT32, nDate, nTime );
/*?*/ rtl::OStringBuffer aTest( buf );
/*?*/ pCrypter->Encrypt( aTest );
/*?*/ memcpy( cPasswd, aTest.getStr(), aTest.getLength() );
--
1.7.7.5

@ -116,6 +116,7 @@ Patch15: 0001-gcc-trunk-avoid-confusion.patch
Patch16: 0001-workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
Patch17: 0001-smath-does-not-handle-accents-in-MathML.patch
Patch18: 0001-workaround-internal-compiler-error-with-gcc-4.7.patch
Patch19: 0001-fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
# TODO: this in S390 only, so it can wait .-)
#Patch13: solenv.fix.mk.inheritance.patch
@ -768,6 +769,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch16 -p1 -b .workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
%patch17 -p1 -b .smath-does-not-handle-accents-in-MathML.patch
%patch18 -p1 -b .workaround-internal-compiler-error-with-gcc-4.7.patch
%patch19 -p1 -b .fix-for-gcc-4.7-C-11-these-are-not-string-literal-op.patch
#%patch13 -p1 -b .solenv.fix.mk.inheritance.patch
# TODO: check this

Loading…
Cancel
Save