fix kde build

f41
David Tardon 13 years ago
parent c34d15ef11
commit e6583de5e3

@ -0,0 +1,40 @@
From 0d7e2108425da1f81c20a605145679168486df59 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Lubo=C5=A1=20Lu=C5=88=C3=A1k?= <l.lunak@suse.cz>
Date: Fri, 6 Jan 2012 10:55:03 +0100
Subject: [PATCH] workaround for LO namespace pollution breaking KDE4 fpicker
build
---
fpicker/source/unx/kde4/KDE4FilePicker.cxx | 8 ++++++++
1 files changed, 8 insertions(+), 0 deletions(-)
diff --git a/fpicker/source/unx/kde4/KDE4FilePicker.cxx b/fpicker/source/unx/kde4/KDE4FilePicker.cxx
index f282645..69be3b1 100644
--- a/fpicker/source/unx/kde4/KDE4FilePicker.cxx
+++ b/fpicker/source/unx/kde4/KDE4FilePicker.cxx
@@ -56,7 +56,10 @@
#define Region QtXRegion
//kde has an enum that uses this...OO does too
+#define LO_SETTINGS_MOUSE SETTINGS_MOUSE
#undef SETTINGS_MOUSE
+#define LO_SETTINGS_LOCALE SETTINGS_LOCALE
+#undef SETTINGS_LOCALE
#include <kfiledialog.h>
#include <kwindowsystem.h>
@@ -70,6 +73,11 @@
#undef Region
+#define SETTINGS_MOUSE LO_SETTINGS_MOUSE
+#undef LO_SETTINGS_MOUSE
+#define SETTINGS_LOCALE LO_SETTINGS_LOCALE
+#undef LO_SETTINGS_LOCALE
+
using namespace ::com::sun::star;
using namespace ::com::sun::star::ui::dialogs;
--
1.7.7.5

@ -113,6 +113,7 @@ Patch12: libreoffice-rhel6poppler.patch
Patch13: 0001-fix-syntactic-error.patch Patch13: 0001-fix-syntactic-error.patch
Patch14: 0001-gcc-trunk-fix-error-unable-to-find-string-literal-op.patch Patch14: 0001-gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
Patch15: 0001-gcc-trunk-avoid-confusion.patch Patch15: 0001-gcc-trunk-avoid-confusion.patch
Patch16: 0001-workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
# TODO: this in S390 only, so it can wait .-) # TODO: this in S390 only, so it can wait .-)
#Patch13: solenv.fix.mk.inheritance.patch #Patch13: solenv.fix.mk.inheritance.patch
@ -762,6 +763,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch13 -p1 -b .fix-syntactic-error.patch %patch13 -p1 -b .fix-syntactic-error.patch
%patch14 -p1 -b .gcc-trunk-fix-error-unable-to-find-string-literal-op.patch %patch14 -p1 -b .gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
%patch15 -p1 -b .gcc-trunk-avoid-confusion.patch %patch15 -p1 -b .gcc-trunk-avoid-confusion.patch
%patch16 -p1 -b .workaround-for-LO-namespace-pollution-breaking-KDE4-.patch
#%patch13 -p1 -b .solenv.fix.mk.inheritance.patch #%patch13 -p1 -b .solenv.fix.mk.inheritance.patch
# TODO: check this # TODO: check this

Loading…
Cancel
Save