f41
David Tardon 13 years ago
parent dbbe28d2aa
commit c34d15ef11

@ -0,0 +1,26 @@
From eca998dc1dc874415794a27336d5db1679ef69b8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Mat=C3=BA=C5=A1=20Kukan?= <matus.kukan@gmail.com>
Date: Sat, 17 Dec 2011 13:29:50 +0100
Subject: [PATCH] gcc-trunk: avoid confusion
Signed-off-by: David Tardon <dtardon@redhat.com>
---
svtools/source/graphic/graphic.hxx | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/svtools/source/graphic/graphic.hxx b/svtools/source/graphic/graphic.hxx
index 7b4f5e0..a1efca0 100644
--- a/svtools/source/graphic/graphic.hxx
+++ b/svtools/source/graphic/graphic.hxx
@@ -58,7 +58,7 @@ public:
Graphic();
~Graphic() throw();
- using unographic::GraphicDescriptor::init;
+ using ::unographic::GraphicDescriptor::init;
void init( const ::Graphic& rGraphic ) throw();
static const ::Graphic* getImplementation( const ::com::sun::star::uno::Reference< ::com::sun::star::uno::XInterface >& rxIFace ) throw();
--
1.7.7.5

@ -112,6 +112,7 @@ Patch12: libreoffice-rhel6poppler.patch
%endif
Patch13: 0001-fix-syntactic-error.patch
Patch14: 0001-gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
Patch15: 0001-gcc-trunk-avoid-confusion.patch
# TODO: this in S390 only, so it can wait .-)
#Patch13: solenv.fix.mk.inheritance.patch
@ -760,6 +761,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%endif
%patch13 -p1 -b .fix-syntactic-error.patch
%patch14 -p1 -b .gcc-trunk-fix-error-unable-to-find-string-literal-op.patch
%patch15 -p1 -b .gcc-trunk-avoid-confusion.patch
#%patch13 -p1 -b .solenv.fix.mk.inheritance.patch
# TODO: check this

Loading…
Cancel
Save