parent
f5341d339b
commit
9d8f3bb9c5
@ -1,43 +0,0 @@
|
|||||||
From 47a471601ed67fee19ecec90e57682db02ca3744 Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Tardon <dtardon@redhat.com>
|
|
||||||
Date: Sat, 21 May 2011 21:19:01 +0200
|
|
||||||
Subject: [PATCH] fix build with system bsh
|
|
||||||
|
|
||||||
---
|
|
||||||
scripting/util/provider/beanshell/makefile.mk | 6 ++++++
|
|
||||||
1 files changed, 6 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/scripting/util/provider/beanshell/makefile.mk b/scripting/util/provider/beanshell/makefile.mk
|
|
||||||
index 1f70fcb..a7c74f5 100755
|
|
||||||
--- a/scripting/util/provider/beanshell/makefile.mk
|
|
||||||
+++ b/scripting/util/provider/beanshell/makefile.mk
|
|
||||||
@@ -36,7 +36,9 @@ EXTENSIONNAME:=ScriptProviderForBeanShell
|
|
||||||
EXTENSION_ZIPNAME:=script-provider-for-beanshell
|
|
||||||
|
|
||||||
COMPONENT_JARFILES=$(EXTENSIONDIR)$/$(EXTENSIONNAME).jar
|
|
||||||
+.IF "$(SYSTEM_BSH)" != "YES"
|
|
||||||
EXTENSION_PACKDEPS=$(SOLARBINDIR)$/bsh.jar
|
|
||||||
+.ENDIF
|
|
||||||
|
|
||||||
.IF "$(ENABLE_SCRIPTING_BEANSHELL)" != "YES"
|
|
||||||
@all:
|
|
||||||
@@ -47,12 +49,16 @@ EXTENSION_PACKDEPS=$(SOLARBINDIR)$/bsh.jar
|
|
||||||
.INCLUDE : target.mk
|
|
||||||
.INCLUDE : extension_post.mk
|
|
||||||
|
|
||||||
+.IF "$(SYSTEM_BSH)" != "YES"
|
|
||||||
+
|
|
||||||
ALLTAR : $(EXTENSIONDIR)$/bsh.jar
|
|
||||||
|
|
||||||
$(EXTENSIONDIR)$/bsh.jar : $(SOLARBINDIR)$/bsh.jar
|
|
||||||
@@-$(MKDIRHIER) $(@:d)
|
|
||||||
$(COMMAND_ECHO)$(COPY) $< $@
|
|
||||||
|
|
||||||
+.ENDIF
|
|
||||||
+
|
|
||||||
.ELSE
|
|
||||||
|
|
||||||
.INCLUDE : target.mk
|
|
||||||
--
|
|
||||||
1.7.5.1
|
|
||||||
|
|
@ -1,15 +0,0 @@
|
|||||||
# HG changeset patch
|
|
||||||
# Parent d5fb760990e45ae0db4f4b7609d8affb85101a39
|
|
||||||
add missing link
|
|
||||||
|
|
||||||
diff -r d5fb760990e4 -r c08b02a02f23 include/mdds/flat_segment_tree_def.inl
|
|
||||||
--- misc/mdds_0.3.0/inc/mdds/flat_segment_tree.hpp Thu Mar 24 14:52:10 2011 +0100
|
|
||||||
+++ misc/build/mdds_0.3.0/inc/mdds/flat_segment_tree.hpp Thu Mar 24 14:53:14 2011 +0100
|
|
||||||
@@ -438,6 +438,7 @@
|
|
||||||
m_left_leaf->value_leaf.value = m_init_val;
|
|
||||||
new_node->left = m_left_leaf;
|
|
||||||
new_node->right = m_left_leaf->right;
|
|
||||||
+ m_left_leaf->right->left = new_node;
|
|
||||||
m_left_leaf->right = new_node;
|
|
||||||
}
|
|
||||||
|
|
@ -1,43 +0,0 @@
|
|||||||
# HG changeset patch
|
|
||||||
# Parent ff6ad274f8ecb1715d366ddb53ecafd422252660
|
|
||||||
do not insert new node if the whole range was shifted
|
|
||||||
|
|
||||||
diff -r ff6ad274f8ec include/mdds/flat_segment_tree_def.inl
|
|
||||||
--- misc/mdds_0.3.0/inc/mdds/flat_segment_tree.hpp Thu Mar 24 14:54:16 2011 +0100
|
|
||||||
+++ misc/build/mdds_0.3.0/inc/mdds/flat_segment_tree.hpp Thu Mar 24 14:55:26 2011 +0100
|
|
||||||
@@ -430,16 +430,25 @@
|
|
||||||
|
|
||||||
if (m_left_leaf->value_leaf.value != m_init_val)
|
|
||||||
{
|
|
||||||
- // The leftmost leaf node has a non-initial value. We need to
|
|
||||||
- // insert a new node to carry that value after the shift.
|
|
||||||
- node_ptr new_node(new node(true));
|
|
||||||
- new_node->value_leaf.key = pos + size;
|
|
||||||
- new_node->value_leaf.value = m_left_leaf->value_leaf.value;
|
|
||||||
- m_left_leaf->value_leaf.value = m_init_val;
|
|
||||||
- new_node->left = m_left_leaf;
|
|
||||||
- new_node->right = m_left_leaf->right;
|
|
||||||
- m_left_leaf->right->left = new_node;
|
|
||||||
- m_left_leaf->right = new_node;
|
|
||||||
+ if (size < m_right_leaf->value_leaf.key - m_left_leaf->value_leaf.key)
|
|
||||||
+ {
|
|
||||||
+ // The leftmost leaf node has a non-initial value. We need to
|
|
||||||
+ // insert a new node to carry that value after the shift.
|
|
||||||
+ node_ptr new_node(new node(true));
|
|
||||||
+ new_node->value_leaf.key = pos + size;
|
|
||||||
+ new_node->value_leaf.value = m_left_leaf->value_leaf.value;
|
|
||||||
+ m_left_leaf->value_leaf.value = m_init_val;
|
|
||||||
+ new_node->left = m_left_leaf;
|
|
||||||
+ new_node->right = m_left_leaf->right;
|
|
||||||
+ m_left_leaf->right->left = new_node;
|
|
||||||
+ m_left_leaf->right = new_node;
|
|
||||||
+ }
|
|
||||||
+ else
|
|
||||||
+ {
|
|
||||||
+ // We shifted out the whole range, so there would be no new
|
|
||||||
+ // node inserted. Just set default value.
|
|
||||||
+ m_left_leaf->value_leaf.value = m_init_val;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
m_valid_tree = false;
|
|
Loading…
Reference in new issue