f41
David Tardon 14 years ago
parent 60cff80657
commit f5341d339b

21
.gitignore vendored

@ -49,3 +49,24 @@
/libreoffice-translations-3.4.1.3.tar.bz2
/libreoffice-ure-3.4.1.3.tar.bz2
/libreoffice-writer-3.4.1.3.tar.bz2
/libreoffice-artwork-3.4.2.1.tar.bz2
/libreoffice-base-3.4.2.1.tar.bz2
/libreoffice-libs-core-3.4.2.1.tar.bz2
/libreoffice-libs-extern-3.4.2.1.tar.bz2
/libreoffice-libs-extern-sys-3.4.2.1.tar.bz2
/libreoffice-libs-gui-3.4.2.1.tar.bz2
/libreoffice-postprocess-3.4.2.1.tar.bz2
/libreoffice-sdk-3.4.2.1.tar.bz2
/libreoffice-testing-3.4.2.1.tar.bz2
/libreoffice-ure-3.4.2.1.tar.bz2
/libreoffice-writer-3.4.2.1.tar.bz2
/libreoffice-translations-3.4.2.1.tar.bz2
/libreoffice-bootstrap-3.4.2.1.tar.bz2
/libreoffice-multiliblauncher.sh
/libreoffice-calc-3.4.2.1.tar.bz2
/libreoffice-components-3.4.2.1.tar.bz2
/libreoffice-extensions-3.4.2.1.tar.bz2
/libreoffice-extras-3.4.2.1.tar.bz2
/libreoffice-filters-3.4.2.1.tar.bz2
/libreoffice-help-3.4.2.1.tar.bz2
/libreoffice-impress-3.4.2.1.tar.bz2

@ -1,39 +0,0 @@
From 194da0076d3b4a6968496261fd2eaca9e8e955f9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Fri, 24 Jun 2011 10:29:09 +0100
Subject: [PATCH] bad merge, fix to enable extensions to build again
---
odk/settings/settings.mk | 6 ------
1 files changed, 0 insertions(+), 6 deletions(-)
diff --git a/odk/settings/settings.mk b/odk/settings/settings.mk
index bbd18ee..e4fc05a 100644
--- a/odk/settings/settings.mk
+++ b/odk/settings/settings.mk
@@ -502,11 +502,9 @@ PLATFORM=kfreebsd
ifeq "$(PROCTYPE)" "x86_64"
PACKAGE_LIB_DIR=kfreebsd_x86_64.plt
UNOPKG_PLATFORM=kFreeBSD_x86_64
-STLPORT=no
else
PACKAGE_LIB_DIR=kfreebsd_x86.plt
UNOPKG_PLATFORM=kFreeBSD_x86
-STLPORT=no
endif
else
PLATFORM=freebsd
@@ -570,10 +568,6 @@ CPPUHELPERLIB=-luno_cppuhelper$(COMID)
SALHELPERLIB=-luno_salhelper$(COMID)
REGLIB=-lreg
STORELIB=-lstore
-ifeq "$(STLPORT)" "yes"
-endif
-else
-STLPORTLIB=
EMPTYSTRING=
PATH_SEPARATOR=:
--
1.7.5.4

@ -1,39 +0,0 @@
From a935029385159ee137418730363257599f67e5d6 Mon Sep 17 00:00:00 2001
From: Radek Doulik <rodo@novell.com>
Date: Mon, 11 Jul 2011 20:36:47 +0200
Subject: [PATCH] fix regression in SvGlobalName::operator <
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
- it was comparing wrong parts and ommiting part of ID's, resulting
in wrong results and thus ::std::map didn't work well with default
less compare function of it's keys
- fixes fdo#32709
(cherry picked from commit 345dc7961bc142f167a1b8e5f43f4439e8234f06)
Signed-off-by: Caolán McNamara <caolanm@redhat.com>
---
tools/source/ref/globname.cxx | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/source/ref/globname.cxx b/tools/source/ref/globname.cxx
index 7a7f5c5..c78aeb5 100644
--- a/tools/source/ref/globname.cxx
+++ b/tools/source/ref/globname.cxx
@@ -208,10 +208,10 @@ BOOL SvGlobalName::operator < ( const SvGlobalName & rObj ) const
else if( Data2_a == Data2_b )
{
sal_uInt32 Data1_a;
- memcpy(&Data1_a, pImp->szData+4, sizeof(sal_uInt32));
+ memcpy(&Data1_a, pImp->szData, sizeof(sal_uInt32));
sal_uInt32 Data1_b;
- memcpy(&Data1_b, rObj.pImp->szData+4, sizeof(sal_uInt32));
+ memcpy(&Data1_b, rObj.pImp->szData, sizeof(sal_uInt32));
return Data1_a < Data1_b;
}
--
1.7.6

@ -26,8 +26,8 @@
Summary: Free Software Productivity Suite
Name: libreoffice
Epoch: 1
Version: 3.4.1.3
Release: 3%{?dist}
Version: 3.4.2.1
Release: 1%{?dist}
License: LGPLv3 and LGPLv2+ and BSD and (MPLv1.1 or GPLv2 or LGPLv2 or Netscape) and (CDDL or GPLv2) and Public Domain
Group: Applications/Productivity
URL: http://www.documentfoundation.org/develop
@ -113,9 +113,7 @@ Patch18: 0001-Resolves-rhbz-713154-pdf-export-dialog-too-tall-to-f.patch
Patch19: 0001-Related-rhbz-702833-addEventListener-without-removeE.patch
Patch20: 0001-Related-rhbz-711087-band-aid.patch
Patch21: 0001-rhbz-667082-do-not-crash-importing-section-containin.patch
Patch22: 0001-bad-merge-fix-to-enable-extensions-to-build-again.patch
Patch23: 0001-Related-rhbz-718976-crash-in-SwTxtSizeInfo-GetMultiC.patch
Patch24: 0001-fix-regression-in-SvGlobalName-operator.patch
Patch22: 0001-Related-rhbz-718976-crash-in-SwTxtSizeInfo-GetMultiC.patch
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
%define instdir %{_libdir}
@ -739,9 +737,7 @@ mv -f redhat.soc extras/source/palettes/standard.soc
%patch19 -p1 -b .rhbz702833-addEventListener-without-removeE.patch
%patch20 -p1 -b .rhbz711087-band-aid.patch
%patch21 -p1 -b .rhbz667082-do-not-crash-importing-section-containin.patch
%patch22 -p1 -b .bad-merge-fix-to-enable-extensions-to-build-again.patch
%patch23 -p1 -b .rhbz718976-crash-in-SwTxtSizeInfo-GetMultiC.patch
%patch24 -p1 -b .fix-regression-in-SvGlobalName-operator.patch
%patch22 -p1 -b .rhbz718976-crash-in-SwTxtSizeInfo-GetMultiC.patch
# these are horribly incomplete--empty translations and copied english
# strings with spattering of translated strings
@ -2026,6 +2022,11 @@ update-desktop-database %{_datadir}/applications &> /dev/null || :
%{basisinstdir}/program/kde-open-url
%changelog
* Wed Jul 13 2011 David Tardon <dtardon@redhat.com> - 3.4.2.1-1
- 3.4.2 rc1
- drop 0001-bad-merge-fix-to-enable-extensions-to-build-again.patch
- drop 0001-fix-regression-in-SvGlobalName-operator.patch
* Tue Jul 12 2011 Caolán McNamara <caolanm@redhat.com> - 3.4.1.3-3
- fix regression in SvGlobalName operator

@ -1,31 +1,32 @@
17410483b5b5f267aa18b7e00b65e6e0 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
5829f1003eb730948327142137057815 libreoffice-artwork-3.4.2.1.tar.bz2
ec893aac2b46eadd0d651fbefb0e8c75 libreoffice-base-3.4.2.1.tar.bz2
1c342f6f1227b60a3eabb7c958a62076 libreoffice-libs-core-3.4.2.1.tar.bz2
ca88faadcb450a4f7569f5e211b7ab34 libreoffice-libs-extern-3.4.2.1.tar.bz2
74f4c9c7576b819e080223d961fb367b libreoffice-libs-extern-sys-3.4.2.1.tar.bz2
f988b40bf3328bfc0d2102bf90decc35 libreoffice-libs-gui-3.4.2.1.tar.bz2
9910fb6d20e49461ec75a0c0443ec91e libreoffice-postprocess-3.4.2.1.tar.bz2
7a848a8ede3d6e49a314c99bbd187444 libreoffice-sdk-3.4.2.1.tar.bz2
054127e979d7d24736bc644a12272e28 libreoffice-testing-3.4.2.1.tar.bz2
47f9342e31f667e9bd7e319704494306 libreoffice-ure-3.4.2.1.tar.bz2
62d28c0dfd1d59e5164b467d213797b9 libreoffice-writer-3.4.2.1.tar.bz2
bbf6fb09fe58a9375ec507b0d3c156f3 libreoffice-translations-3.4.2.1.tar.bz2
9e8c507689262f7e04f693fddcf48dfd libreoffice-bootstrap-3.4.2.1.tar.bz2
185d60944ea767075d27247c3162b3bc 185d60944ea767075d27247c3162b3bc-unowinreg.dll
18f577b374d60b3c760a3a3350407632 18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz
03c019658ec49050c8103ba0f10b5067 redhat-langpacks.tar.gz
74939c9ea525374776f09bf972ede99f libreoffice-multiliblauncher.sh
fdb27bfe2dbe2e7b57ae194d9bf36bab fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz
a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
1f24ab1d39f4a51faf22244c94a6203f 1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
35c94d2df8893241173de1d16b6034c0 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
798b2ffdc8bcfe7bca2cf92b62caf685 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip
a7983f859eafb2677d7ff386a023bc40 a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip
35c94d2df8893241173de1d16b6034c0 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
ada24d37d8d638b3d8a9985e80bc2978 ada24d37d8d638b3d8a9985e80bc2978-source-9.0.0.7-bj.zip
18f577b374d60b3c760a3a3350407632 18f577b374d60b3c760a3a3350407632-STLport-4.5.tar.gz
01d8637c1c988e5cebe1ce3cf1afbf18 libreoffice-calc-3.4.2.1.tar.bz2
17410483b5b5f267aa18b7e00b65e6e0 17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip
b4cae0700aa1c2aef7eb7f345365e6f1 b4cae0700aa1c2aef7eb7f345365e6f1-translate-toolkit-1.8.1.tar.bz2
fdb27bfe2dbe2e7b57ae194d9bf36bab fdb27bfe2dbe2e7b57ae194d9bf36bab-SampleICC-1.3.2.tar.gz
10b3212002688e7ce49a276c68352b50 libreoffice-artwork-3.4.1.3.tar.bz2
c6547ec8f971284ea1e58bb39375c500 libreoffice-base-3.4.1.3.tar.bz2
26328364a0804dedab94818c15e76871 libreoffice-bootstrap-3.4.1.3.tar.bz2
d26c6ab53c9404e82e04ea366d4db261 libreoffice-calc-3.4.1.3.tar.bz2
132aa87f2f3e7fff62d7211a86b769f3 libreoffice-components-3.4.1.3.tar.bz2
801c254c28402df0c5fb5e2615817a6d libreoffice-extensions-3.4.1.3.tar.bz2
b94208fdae537f0b026ee26cede9a946 libreoffice-extras-3.4.1.3.tar.bz2
096e3071949d1eedf73faa13a2cf7b7e libreoffice-filters-3.4.1.3.tar.bz2
e27e715b08cc6a35988aaa6efab6cc7f libreoffice-help-3.4.1.3.tar.bz2
e94d7adb79f38d3fd8119b712b04cc6e libreoffice-impress-3.4.1.3.tar.bz2
1d2e7ca24b9fffafeaf236817fc8cbe9 libreoffice-libs-core-3.4.1.3.tar.bz2
69a9af6536607340a57b54b5562077f7 libreoffice-libs-extern-3.4.1.3.tar.bz2
3b4e819497ba695f5c64a0107c2aac8d libreoffice-libs-extern-sys-3.4.1.3.tar.bz2
5a7370a79e563f649f6bf506bc71928c libreoffice-libs-gui-3.4.1.3.tar.bz2
c480ed571703e68d851fbbcd4aa520be libreoffice-postprocess-3.4.1.3.tar.bz2
222cec135152c108068baa4e370a3f68 libreoffice-sdk-3.4.1.3.tar.bz2
93524298efb472503b12ae47c95de399 libreoffice-testing-3.4.1.3.tar.bz2
5eb8e1950f91198ae1e7ddc6c1dd19fd libreoffice-translations-3.4.1.3.tar.bz2
5420c40473f8bf8e5b400dd8a1e54f02 libreoffice-ure-3.4.1.3.tar.bz2
1516196f023bb1ae55fd1773a8db9d16 libreoffice-writer-3.4.1.3.tar.bz2
03c019658ec49050c8103ba0f10b5067 redhat-langpacks.tar.gz
9c8eb8b34476bcdbbb1d37fb84bb0d6a libreoffice-components-3.4.2.1.tar.bz2
ceb863b121cbe56298bc77de64627254 libreoffice-extensions-3.4.2.1.tar.bz2
9f71f3a23e690acc9d0f4685ef52b829 libreoffice-extras-3.4.2.1.tar.bz2
797205de3db3ab1e3ff84bb875152823 libreoffice-filters-3.4.2.1.tar.bz2
e8e72b2d22e8f504d8d8d163e90422f8 libreoffice-help-3.4.2.1.tar.bz2
1ee6032abbc2de86c0d0822dc2c210a4 libreoffice-impress-3.4.2.1.tar.bz2

Loading…
Cancel
Save