i10ce
Arkady L. Shane 3 weeks ago
commit 0b35ace06d
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1 @@
2b3c04f8be5ab715cda2bb6aef847e7d2d4709ee SOURCES/libfame-0.9.1.tar.gz

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/libfame-0.9.1.tar.gz

@ -0,0 +1,31 @@
--- libfame-0.9.1.orig/configure.in 2008-08-15 23:50:51.000000000 -0400
+++ libfame-0.9.1/configure.in 2008-08-15 23:55:14.000000000 -0400
@@ -90,26 +90,9 @@ dnl See if we need to pass -lm for the m
AC_CHECK_LIB(m, sqrt, LIBS="$LIBS -lm")
dnl Optimize
+dnl enable -fstrict-aliasing unconditionally
if test x$ac_cv_prog_gcc = xyes; then
- CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math"
-
-dnl -fstrict-aliasing doesn't seem to be supported by gcc < 2.95
- gcc_major_version=`$CC -dumpversion | \
- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
- gcc_minor_version=`$CC -dumpversion | \
- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
- gcc_micro_version=`$CC -dumpversion | \
- sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
-
- dnl ok, I must admit I don't know how to do or/and ;)
- if test $gcc_major_version -eq 2; then
- if test $gcc_minor_version -gt 94; then
- CFLAGS="$CFLAGS -fstrict-aliasing"
- fi
- fi
- if test $gcc_major_version -gt 2; then
- CFLAGS="$CFLAGS -fstrict-aliasing"
- fi
+ CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math -fstrict-aliasing"
fi
dnl Check for debugging support

@ -0,0 +1,35 @@
Submitted By: Randy McMurchy <randy_at_linuxfromscratch_dot_org>
Date: 2004-09-04
Initial Package Version: 0.9.1
Upstream Status: Not submitted
Origin: Randy McMurchy
Description: Fixes libfame library when compiled with GCC-3.4.x
$LastChangedBy: randy $
$Date: 2004-09-05 00:11:51 -0600 (Sun, 05 Sep 2004) $
diff -Naur libfame-0.9.1-orig/src/half_mmx.h libfame-0.9.1/src/half_mmx.h
--- libfame-0.9.1-orig/src/half_mmx.h 2002-04-30 18:04:02.000000000 +0000
+++ libfame-0.9.1/src/half_mmx.h 2004-09-05 03:49:09.666845896 +0000
@@ -18,7 +18,7 @@
*/
/**************************** half-pixel interpolation ***********************/
-static short const _mmx_one[] = { 1, 1, 1, 1 };
+const _mmx_one[] = { 1, 1, 1, 1 };
static void inline mmx_interpolate(unsigned char **ref,
int pitch,
diff -Naur libfame-0.9.1-orig/src/half_sse.h libfame-0.9.1/src/half_sse.h
--- libfame-0.9.1-orig/src/half_sse.h 2002-01-27 02:24:56.000000000 +0000
+++ libfame-0.9.1/src/half_sse.h 2004-09-05 03:49:39.894250632 +0000
@@ -19,7 +19,7 @@
*/
/**************************** half-pixel interpolation ***********************/
-static short const _mmx_one[] = { 1, 1, 1, 1 };
+const _mmx_one[] = { 1, 1, 1, 1 };
static unsigned char const _mmx_one_byte[] = {1,1,1,1,1,1,1,1};

@ -0,0 +1,15 @@
diff -Naupr libfame-0.9.1.orig/src/fame_malloc.c libfame-0.9.1/src/fame_malloc.c
--- libfame-0.9.1.orig/src/fame_malloc.c 2003-06-20 14:40:30.000000000 +0200
+++ libfame-0.9.1/src/fame_malloc.c 2005-09-30 11:08:48.000000000 +0200
@@ -36,9 +36,9 @@ void* fame_malloc(size_t size)
*/
ptr = (unsigned char*) malloc(size+ALIGN);
- aligned = (unsigned char*) (((unsigned int)ptr & (~(ALIGN-1))) + ALIGN );
+ aligned = (unsigned char*) (((unsigned long)ptr &(~(ALIGN-1))) + ALIGN );
padding = aligned - 1;
- *padding = (ALIGN-1) - ((unsigned int)ptr & (ALIGN-1));
+ *padding = (ALIGN-1) - ((unsigned long)ptr & (ALIGN-1));
return ((void*)aligned);
}

@ -0,0 +1,11 @@
--- libfame.m4.in~ 2001-11-20 13:56:37.000000000 +0200
+++ libfame.m4.in 2004-07-17 22:44:13.241838905 +0300
@@ -3,7 +3,7 @@
dnl Vivien Chappelier 12/11/00
dnl stolen from ORBit autoconf
dnl
-AC_DEFUN(AM_PATH_LIBFAME,
+AC_DEFUN([AM_PATH_LIBFAME],
[dnl
dnl Get the cflags and libraries from the libfame-config script
dnl

@ -0,0 +1,11 @@
--- libfame-config.in~ 2001-06-22 14:10:59.000000000 +0300
+++ libfame-config.in 2004-07-17 22:47:55.867418653 +0300
@@ -48,7 +48,7 @@
if [ "`uname`" = "SunOS" ]; then
libdirs="-L@libdir@ -R@libdir@"
else
- libdirs="-L@libdir@ @FAME_RLD_FLAGS@"
+ libdirs="-L@libdir@"
fi
echo $libdirs -lfame
;;

@ -0,0 +1,36 @@
diff -Naru libfame-0.9.1.orig/configure.in libfame-0.9.1/configure.in
--- libfame-0.9.1.orig/configure.in 2004-02-11 15:12:24.000000000 +0200
+++ libfame-0.9.1/configure.in 2004-07-17 23:26:07.421758515 +0300
@@ -101,11 +101,11 @@
CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math"
dnl -fstrict-aliasing doesn't seem to be supported by gcc < 2.95
- gcc_major_version=`$CC --version | \
+ gcc_major_version=`$CC -dumpversion | \
sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
- gcc_minor_version=`$CC --version | \
+ gcc_minor_version=`$CC -dumpversion | \
sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
- gcc_micro_version=`$CC --version | \
+ gcc_micro_version=`$CC -dumpversion | \
sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
dnl ok, I must admit I don't know how to do or/and ;)
diff -Naru libfame-0.9.1.orig/configure libfame-0.9.1/configure
--- libfame-0.9.1.orig/configure 2004-02-11 15:12:28.000000000 +0200
+++ libfame-0.9.1/configure 2004-07-17 23:26:07.422758205 +0300
@@ -4607,11 +4607,11 @@
if test x$ac_cv_c_compiler_gnu = xyes; then
CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math"
- gcc_major_version=`$CC --version | \
+ gcc_major_version=`$CC -dumpversion | \
sed -e 's,[^0-9.],,g' -e 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
- gcc_minor_version=`$CC --version | \
+ gcc_minor_version=`$CC -dumpversion | \
sed -e 's,[^0-9.],,g' -e 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
- gcc_micro_version=`$CC --version | \
+ gcc_micro_version=`$CC -dumpversion | \
sed -e 's,[^0-9.],,g' -e 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
if test $gcc_major_version -eq 2; then

@ -0,0 +1,48 @@
diff -Naru libfame-0.9.1.orig/configure libfame-0.9.1/configure
--- libfame-0.9.1.orig/configure 2004-02-11 15:12:28.000000000 +0200
+++ libfame-0.9.1/configure 2004-07-18 00:01:13.266432497 +0300
@@ -4505,18 +4505,11 @@
fi
;;
i386-*-*)
- if test x$ac_cv_c_compiler_gnu = xyes; then
- CFLAGS="$CFLAGS -march=i386"
- fi
- ;;
- i486-*-*)
- if test x$ac_cv_c_compiler_gnu = xyes; then
- CFLAGS="$CFLAGS -march=i486 -DHAS_BSWAP"
- fi
+ true
;;
i?86-*-*)
if test x$ac_cv_c_compiler_gnu = xyes; then
- CFLAGS="$CFLAGS -march=i586 -DHAS_BSWAP"
+ CFLAGS="$CFLAGS -DHAS_BSWAP"
fi
;;
esac
diff -Naru libfame-0.9.1.orig/configure.in libfame-0.9.1/configure.in
--- libfame-0.9.1.orig/configure.in 2004-02-11 15:12:24.000000000 +0200
+++ libfame-0.9.1/configure.in 2004-07-18 00:01:01.288132690 +0300
@@ -61,18 +61,11 @@
fi
;;
i386-*-*)
- if test x$ac_cv_prog_gcc = xyes; then
- CFLAGS="$CFLAGS -march=i386"
- fi
- ;;
- i486-*-*)
- if test x$ac_cv_prog_gcc = xyes; then
- CFLAGS="$CFLAGS -march=i486 -DHAS_BSWAP"
- fi
+ true
;;
i?86-*-*)
if test x$ac_cv_prog_gcc = xyes; then
- CFLAGS="$CFLAGS -march=i586 -DHAS_BSWAP"
+ CFLAGS="$CFLAGS -DHAS_BSWAP"
fi
;;
esac

@ -0,0 +1,180 @@
Name: libfame
Summary: Fast Assembly MPEG Encoding library
Version: 0.9.1
Release: 31%{?dist}
License: LGPLv2+
URL: http://fame.sourceforge.net/
Source0: http://download.sourceforge.net/fame/%{name}-%{version}.tar.gz
Patch0: %{name}-aclocal18.patch
Patch1: %{name}-config-rpath.patch
Patch2: %{name}-gccver.patch
Patch3: %{name}-nomarch.patch
# Patch from http://www.linuxfromscratch.org/blfs/downloads/svn/
Patch4: %{name}-0.9.1-gcc34-1.patch
Patch5: %{name}-0.9.1-fstrict-aliasing.patch
Patch6: %{name}-0.9.1-x86_64.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
%description
FAME is a library for fast MPEG encoding.
%package devel
Summary: Libraries and include to develop using FAME
Requires: %{name}%{?isa} = %{version}-%{release}
%description devel
FAME is a library for fast MPEG encoding.
This package contains the libraries, include files and other resources
you can use to develop FAME applications.
%prep
%setup -q
%patch0 -p0 -b .aclocal18
%patch1 -p0 -b .config-rpath
%patch2 -p1 -b .gccver
%patch3 -p1 -b .nomarch
%patch4 -p1 -b .mmxone
%patch5 -p1 -b .fstrict-aliasing
%patch6 -p1 -b .x86_64
# This is required since the included libtool stuff is too old and breaks
# linking (-lm and -lc functions not found!) on FC5 x86_64.
%{__rm} -f acinclude.m4 aclocal.m4
%{__cp} -f %{_datadir}/aclocal/libtool.m4 libtool.m4
touch NEWS ChangeLog
autoreconf -fiv
# Fix lib stuff for lib64
%{__perl} -pi.orig -e 's|/lib"|/%{_lib}"|g' configure.in
%build
# Note: SSE support does nothing (as of 0.9.1). grep for HAS_SSE.
%configure --disable-dependency-tracking \
%ifarch %{ix86} ia64
--enable-mmx
%else
--disable-mmx
%endif
%{make_build}
%install
%{make_install}
#Remove libtool archives.
find %buildroot -name '*.la' -or -name '*.a' | xargs rm -f
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%doc AUTHORS BUGS CHANGES README TODO
%license COPYING
%{_libdir}/libfame*.so.*
%files devel
%{_bindir}/libfame-config
%{_includedir}/fame*.h
%{_libdir}/libfame.so
%{_datadir}/aclocal/libfame.m4
%{_mandir}/man3/fame*.3*
%changelog
* Wed Dec 25 2024 Arkady L. Shane <tigro@msvsphere-os.ru> -
- Rebuilt for MSVSphere 10
* Wed Aug 02 2023 RPM Fusion Release Engineering <sergiomb@rpmfusion.org> - 0.9.1-31
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sun Aug 07 2022 RPM Fusion Release Engineering <sergiomb@rpmfusion.org> - 0.9.1-30
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild and ffmpeg
5.1
* Wed Feb 09 2022 RPM Fusion Release Engineering <sergiomb@rpmfusion.org> - 0.9.1-29
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Tue Aug 03 2021 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 0.9.1-28
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Feb 03 2021 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 0.9.1-27
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Aug 18 2020 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 0.9.1-26
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue Feb 04 2020 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 0.9.1-25
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Tue Aug 13 2019 Leigh Scott <leigh123linux@gmail.com> - 0.9.1-24
- Remove BuildRoot tag
- Remove Group tag
- Add isa to devel requires
- Remove clean section
- Remove defattr from files
- Delete .a and .la files
- Spec file clean up
- Install license file correctly
- Fix license type
- Fix mixed use of tabs and whitespace
* Fri Aug 09 2019 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 0.9.1-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Mon Mar 04 2019 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 0.9.1-22
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Jul 26 2018 RPM Fusion Release Engineering <leigh123linux@gmail.com> - 0.9.1-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Thu Mar 01 2018 RPM Fusion Release Engineering <leigh123linux@googlemail.com> - 0.9.1-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 31 2017 RPM Fusion Release Engineering <kwizart@rpmfusion.org> - 0.9.1-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sun Mar 19 2017 RPM Fusion Release Engineering <kwizart@rpmfusion.org> - 0.9.1-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Sun Aug 31 2014 Sérgio Basto <sergio@serjux.com> - 0.9.1-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sun Mar 03 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.9.1-16
- Mass rebuilt for Fedora 19 Features
* Wed Feb 08 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.9.1-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 0.9.1-14
- rebuild for new F11 features
* Fri Aug 15 2008 Jarod Wilson <jarod@wilsonet.com> 0.9.1-13
- Merge livna and freshrpms packages for rpmfusion
* Mon Sep 18 2006 Matthias Saou <http://freshrpms.net/> 0.9.1-12
- Update underquoted patch, which stopped applying cleanly for some reason.
* Mon Mar 20 2006 Matthias Saou <http://freshrpms.net/> 0.9.1-11
- Remove old libtool/m4 files to fix x86_64 FC5 linking.
* Fri Mar 17 2006 Matthias Saou <http://freshrpms.net/> 0.9.1-9
- Release bump to drop the disttag number in FC5 build.
* Fri Sep 30 2005 Matthias Saou <http://freshrpms.net/> 0.9.1-8
- Include x86_64 patch from Andy Loening, fixes some segfaults.
- Update underquoted patch to also remove warnings at libfame build time.
* Sun Jun 5 2005 Matthias Saou <http://freshrpms.net/> 0.9.1-7
- Make the underquoted patch apply to the .in file too, so it actually works.
- Put ldconfig calls back as programs to have rpm's deps pick them up.
* Thu May 5 2005 Matthias Saou <http://freshrpms.net/> 0.9.1-6
- Run plain "./autogen.sh" instead of autoreconf to avoid libm problem on
x86_64 (weird one!).
- Actually really apply the last patch too...
* Sun May 1 2005 Matthias Saou <http://freshrpms.net/> 0.9.1-5
- Patch the m4 file to fix underquoted warning.
Loading…
Cancel
Save