You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

37 lines
1.7 KiB

diff -Naru libfame-0.9.1.orig/configure.in libfame-0.9.1/configure.in
--- libfame-0.9.1.orig/configure.in 2004-02-11 15:12:24.000000000 +0200
+++ libfame-0.9.1/configure.in 2004-07-17 23:26:07.421758515 +0300
@@ -101,11 +101,11 @@
CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math"
dnl -fstrict-aliasing doesn't seem to be supported by gcc < 2.95
- gcc_major_version=`$CC --version | \
+ gcc_major_version=`$CC -dumpversion | \
sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
- gcc_minor_version=`$CC --version | \
+ gcc_minor_version=`$CC -dumpversion | \
sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
- gcc_micro_version=`$CC --version | \
+ gcc_micro_version=`$CC -dumpversion | \
sed -e 's,[[^0-9.]],,g' -e 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
dnl ok, I must admit I don't know how to do or/and ;)
diff -Naru libfame-0.9.1.orig/configure libfame-0.9.1/configure
--- libfame-0.9.1.orig/configure 2004-02-11 15:12:28.000000000 +0200
+++ libfame-0.9.1/configure 2004-07-17 23:26:07.422758205 +0300
@@ -4607,11 +4607,11 @@
if test x$ac_cv_c_compiler_gnu = xyes; then
CFLAGS="$CFLAGS -Wall -fexpensive-optimizations -funroll-loops -ffast-math"
- gcc_major_version=`$CC --version | \
+ gcc_major_version=`$CC -dumpversion | \
sed -e 's,[^0-9.],,g' -e 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\1/'`
- gcc_minor_version=`$CC --version | \
+ gcc_minor_version=`$CC -dumpversion | \
sed -e 's,[^0-9.],,g' -e 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\2/'`
- gcc_micro_version=`$CC --version | \
+ gcc_micro_version=`$CC -dumpversion | \
sed -e 's,[^0-9.],,g' -e 's/\([0-9]*\).\([0-9]*\).\([0-9]*\)/\3/'`
if test $gcc_major_version -eq 2; then