parent
231b5fdcab
commit
f16ee8710c
@ -1,14 +1,2 @@
|
|||||||
/kio-extras-18.08.3.tar.xz
|
|
||||||
/kio-extras-18.12.0.tar.xz
|
|
||||||
/kio-extras-18.12.1.tar.xz
|
|
||||||
/kio-extras-18.12.2.tar.xz
|
|
||||||
/kio-extras-18.12.3.tar.xz
|
|
||||||
/kio-extras-19.04.1.tar.xz
|
|
||||||
/kio-extras-19.04.2.tar.xz
|
|
||||||
/kio-extras-19.04.3.tar.xz
|
|
||||||
/kio-extras-19.08.1.tar.xz
|
|
||||||
/kio-extras-19.08.2.tar.xz
|
|
||||||
/kio-extras-19.08.3.tar.xz
|
|
||||||
/kio-extras-19.12.1.tar.xz
|
|
||||||
/kio-extras-19.12.2.tar.xz
|
|
||||||
/kio-extras-19.12.3.tar.xz
|
/kio-extras-19.12.3.tar.xz
|
||||||
|
/kio-extras-20.04.0.tar.xz
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
diff -up kio-extras-19.12.1/CMakeLists.txt.nfs-libtirpc kio-extras-19.12.1/CMakeLists.txt
|
|
||||||
--- kio-extras-19.12.1/CMakeLists.txt.nfs-libtirpc 2020-01-13 11:25:38.142277371 -0600
|
|
||||||
+++ kio-extras-19.12.1/CMakeLists.txt 2020-01-13 11:26:22.794980576 -0600
|
|
||||||
@@ -178,9 +178,11 @@ if(NOT WIN32)
|
|
||||||
if(Gperf_FOUND)
|
|
||||||
add_subdirectory( man )
|
|
||||||
endif()
|
|
||||||
- check_include_files(rpc/rpc.h HAVE_RPC_RPC_H)
|
|
||||||
- add_feature_info("NFS kioslave" HAVE_RPC_RPC_H "The RPC library is needed to build the NFS kioslave")
|
|
||||||
- if(HAVE_RPC_RPC_H)
|
|
||||||
+ pkg_check_modules(TIRPC libtirpc)
|
|
||||||
+ include_directories(${TIRPC_INCLUDE_DIRS})
|
|
||||||
+ set(CMAKE_REQUIRED_LIBRARIES ${TIRPC_LIBRARIES})
|
|
||||||
+ add_feature_info("NFS kioslave" TIRPC_FOUND "The RPC library is needed to build the NFS kioslave")
|
|
||||||
+ if(TIRPC_FOUND)
|
|
||||||
add_subdirectory( nfs )
|
|
||||||
endif()
|
|
||||||
endif()
|
|
||||||
diff -up kio-extras-19.12.1/nfs/CMakeLists.txt.nfs-libtirpc kio-extras-19.12.1/nfs/CMakeLists.txt
|
|
||||||
--- kio-extras-19.12.1/nfs/CMakeLists.txt.nfs-libtirpc 2020-01-04 22:40:32.000000000 -0600
|
|
||||||
+++ kio-extras-19.12.1/nfs/CMakeLists.txt 2020-01-13 11:25:38.142277371 -0600
|
|
||||||
@@ -10,6 +10,7 @@ if (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_
|
|
||||||
message(FATAL_ERROR "Could not find 64-bit XDR datatype functions!")
|
|
||||||
endif (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_XDR_UINT64_T AND NOT HAVE_XDR_U_HYPER AND NOT HAVE_XDR_U_LONGLONG_T)
|
|
||||||
|
|
||||||
+add_definitions(-D_DEFAULT_SOURCE)
|
|
||||||
if (HAVE_XDR_U_INT64_T)
|
|
||||||
add_definitions(-DHAVE_XDR_U_INT64_T)
|
|
||||||
endif (HAVE_XDR_U_INT64_T)
|
|
||||||
@@ -26,7 +27,8 @@ endif (HAVE_XDR_U_LONGLONG_T)
|
|
||||||
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_nfs\")
|
|
||||||
|
|
||||||
add_library(kio_nfs MODULE kio_nfs.cpp nfsv2.cpp nfsv3.cpp rpc_nfs3_prot_xdr.c rpc_nfs2_prot_xdr.c)
|
|
||||||
-target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network)
|
|
||||||
+target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network ${TIRPC_LIBRARIES})
|
|
||||||
+
|
|
||||||
set_target_properties(kio_nfs PROPERTIES OUTPUT_NAME "nfs")
|
|
||||||
|
|
||||||
install(TARGETS kio_nfs DESTINATION ${KDE_INSTALL_PLUGINDIR}/kf5/kio)
|
|
@ -1 +1 @@
|
|||||||
SHA512 (kio-extras-19.12.3.tar.xz) = 289d4336e563ee38be20f40c146172111ebeb3893edd15c76ad42435b8b1b0967864d8764519cd5c0aaa2580c56b76283076a3598917876b5e22acdf75ba9da7
|
SHA512 (kio-extras-20.04.0.tar.xz) = 2af83e7fa380ab28b68d0a59e3a25ac170424cfefaa319e5b43bc907752055b081d3f2c21337be2a3f9752a20c9ad79e995f070461fb68fc578e98a5d9124847
|
||||||
|
Loading…
Reference in new issue