fix Recommends: qtimageformts dep
epel9
Rex Dieter 5 years ago
parent 231b5fdcab
commit f16ee8710c

14
.gitignore vendored

@ -1,14 +1,2 @@
/kio-extras-18.08.3.tar.xz
/kio-extras-18.12.0.tar.xz
/kio-extras-18.12.1.tar.xz
/kio-extras-18.12.2.tar.xz
/kio-extras-18.12.3.tar.xz
/kio-extras-19.04.1.tar.xz
/kio-extras-19.04.2.tar.xz
/kio-extras-19.04.3.tar.xz
/kio-extras-19.08.1.tar.xz
/kio-extras-19.08.2.tar.xz
/kio-extras-19.08.3.tar.xz
/kio-extras-19.12.1.tar.xz
/kio-extras-19.12.2.tar.xz
/kio-extras-19.12.3.tar.xz /kio-extras-19.12.3.tar.xz
/kio-extras-20.04.0.tar.xz

@ -1,39 +0,0 @@
diff -up kio-extras-19.12.1/CMakeLists.txt.nfs-libtirpc kio-extras-19.12.1/CMakeLists.txt
--- kio-extras-19.12.1/CMakeLists.txt.nfs-libtirpc 2020-01-13 11:25:38.142277371 -0600
+++ kio-extras-19.12.1/CMakeLists.txt 2020-01-13 11:26:22.794980576 -0600
@@ -178,9 +178,11 @@ if(NOT WIN32)
if(Gperf_FOUND)
add_subdirectory( man )
endif()
- check_include_files(rpc/rpc.h HAVE_RPC_RPC_H)
- add_feature_info("NFS kioslave" HAVE_RPC_RPC_H "The RPC library is needed to build the NFS kioslave")
- if(HAVE_RPC_RPC_H)
+ pkg_check_modules(TIRPC libtirpc)
+ include_directories(${TIRPC_INCLUDE_DIRS})
+ set(CMAKE_REQUIRED_LIBRARIES ${TIRPC_LIBRARIES})
+ add_feature_info("NFS kioslave" TIRPC_FOUND "The RPC library is needed to build the NFS kioslave")
+ if(TIRPC_FOUND)
add_subdirectory( nfs )
endif()
endif()
diff -up kio-extras-19.12.1/nfs/CMakeLists.txt.nfs-libtirpc kio-extras-19.12.1/nfs/CMakeLists.txt
--- kio-extras-19.12.1/nfs/CMakeLists.txt.nfs-libtirpc 2020-01-04 22:40:32.000000000 -0600
+++ kio-extras-19.12.1/nfs/CMakeLists.txt 2020-01-13 11:25:38.142277371 -0600
@@ -10,6 +10,7 @@ if (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_
message(FATAL_ERROR "Could not find 64-bit XDR datatype functions!")
endif (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_XDR_UINT64_T AND NOT HAVE_XDR_U_HYPER AND NOT HAVE_XDR_U_LONGLONG_T)
+add_definitions(-D_DEFAULT_SOURCE)
if (HAVE_XDR_U_INT64_T)
add_definitions(-DHAVE_XDR_U_INT64_T)
endif (HAVE_XDR_U_INT64_T)
@@ -26,7 +27,8 @@ endif (HAVE_XDR_U_LONGLONG_T)
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_nfs\")
add_library(kio_nfs MODULE kio_nfs.cpp nfsv2.cpp nfsv3.cpp rpc_nfs3_prot_xdr.c rpc_nfs2_prot_xdr.c)
-target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network)
+target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network ${TIRPC_LIBRARIES})
+
set_target_properties(kio_nfs PROPERTIES OUTPUT_NAME "nfs")
install(TARGETS kio_nfs DESTINATION ${KDE_INSTALL_PLUGINDIR}/kf5/kio)

@ -7,8 +7,8 @@
%endif %endif
Name: kio-extras Name: kio-extras
Version: 19.12.3 Version: 20.04.0
Release: 2%{?dist} Release: 1%{?dist}
Summary: Additional components to increase the functionality of KIO Framework Summary: Additional components to increase the functionality of KIO Framework
License: GPLv2+ License: GPLv2+
@ -20,13 +20,9 @@ URL: https://cgit.kde.org/%{name}.git
%else %else
%global stable stable %global stable stable
%endif %endif
Source0: http://download.kde.org/%{stable}/applications/%{version}/src/%{name}-%{version}.tar.xz Source0: http://download.kde.org/%{stable}/release-service/%{version}/src/%{name}-%{version}.tar.xz
## upstramable patches ## upstramable patches
# patch to use libtirpc for RPC, from Cygwin Ports
# should be upstreamable, considering that glibc's builtin RPC is obsolete
# https://github.com/cygwinports/kf5-kio-extras/blob/master/16.08.3-nfs-libtirpc.patch
Patch1000: kio-extras-19.12.1-nfs-libtirpc.patch
# Don't eat up memory attempting to create thumbnail of huge images # Don't eat up memory attempting to create thumbnail of huge images
# https://bugs.kde.org/show_bug.cgi?id=420173 # https://bugs.kde.org/show_bug.cgi?id=420173
@ -61,6 +57,7 @@ BuildRequires: kf5-solid-devel
BuildRequires: cmake(KF5SyntaxHighlighting) BuildRequires: cmake(KF5SyntaxHighlighting)
BuildRequires: cmake(KF5ActivitiesStats) BuildRequires: cmake(KF5ActivitiesStats)
BuildRequires: cmake(KDSoap)
BuildRequires: libjpeg-devel BuildRequires: libjpeg-devel
BuildRequires: libmtp-devel BuildRequires: libmtp-devel
BuildRequires: libsmbclient-devel BuildRequires: libsmbclient-devel
@ -98,7 +95,7 @@ Provides: kio-extras-docs = %{version}-%{release}
Obsoletes: kio-extras-htmlthumbnail < 18.08.3 Obsoletes: kio-extras-htmlthumbnail < 18.08.3
# helpful for imagethumbnail plugin # helpful for imagethumbnail plugin
Recommends: qt5-qtimageformats %{?_isa} Recommends: qt5-qtimageformats%{?_isa}
# when -info was split out # when -info was split out
Obsoletes: kio-extras < 19.04.1-1 Obsoletes: kio-extras < 19.04.1-1
@ -122,8 +119,6 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
%prep %prep
%autosetup -p1 %autosetup -p1
#setup -q
#patch1000 -p1 -b .nfs-libtirpc
%build %build
@ -233,6 +228,10 @@ time make test -C %{_target_platform} ARGS="--output-on-failure --timeout 10" ||
%changelog %changelog
* Sat May 02 2020 Rex Dieter <rdieter@fedoraproject.org> - 20.04.0-1
- 20.04.0
- fix Recommends: qtimageformts dep
* Fri Apr 17 2020 Sandro Mani <manisandro@gmail.com> - 19.12.3-2 * Fri Apr 17 2020 Sandro Mani <manisandro@gmail.com> - 19.12.3-2
- Add patch to skip huge images in thumbnailer - Add patch to skip huge images in thumbnailer

@ -1 +1 @@
SHA512 (kio-extras-19.12.3.tar.xz) = 289d4336e563ee38be20f40c146172111ebeb3893edd15c76ad42435b8b1b0967864d8764519cd5c0aaa2580c56b76283076a3598917876b5e22acdf75ba9da7 SHA512 (kio-extras-20.04.0.tar.xz) = 2af83e7fa380ab28b68d0a59e3a25ac170424cfefaa319e5b43bc907752055b081d3f2c21337be2a3f9752a20c9ad79e995f070461fb68fc578e98a5d9124847

Loading…
Cancel
Save