Build against libtirpc (#1532944), patch from Cygwin Ports
* Wed Jan 10 2018 Kevin Kofler <Kevin@tigcc.ticalc.org> - 17.12.0-2 - Build against libtirpc (#1532944), patch from Cygwin Portsepel9
parent
ce954af74c
commit
ba9e70239d
@ -0,0 +1,36 @@
|
|||||||
|
--- kio-extras-16.08.3/CMakeLists.txt 2016-11-07 06:21:48.000000000 -0600
|
||||||
|
+++ kio-extras-16.08.3/CMakeLists.txt 2017-02-02 09:45:43.808487100 -0600
|
||||||
|
@@ -152,9 +152,11 @@ endif()
|
||||||
|
if(Gperf_FOUND AND KF5KHtml_FOUND)
|
||||||
|
add_subdirectory( man )
|
||||||
|
endif()
|
||||||
|
- check_include_files(rpc/rpc.h HAVE_RPC_RPC_H)
|
||||||
|
- add_feature_info("NFS kioslave" HAVE_RPC_RPC_H "The RPC library is needed to build the NFS kioslave")
|
||||||
|
- if(HAVE_RPC_RPC_H)
|
||||||
|
+ pkg_check_modules(TIRPC libtirpc)
|
||||||
|
+ include_directories(${TIRPC_INCLUDE_DIRS})
|
||||||
|
+ set(CMAKE_REQUIRED_LIBRARIES ${TIRPC_LIBRARIES})
|
||||||
|
+ add_feature_info("NFS kioslave" TIRPC_FOUND "The RPC library is needed to build the NFS kioslave")
|
||||||
|
+ if(TIRPC_FOUND)
|
||||||
|
add_subdirectory( nfs )
|
||||||
|
endif()
|
||||||
|
endif()
|
||||||
|
--- kio-extras-16.08.3/nfs/CMakeLists.txt 2016-11-07 06:21:48.000000000 -0600
|
||||||
|
+++ kio-extras-16.08.3/nfs/CMakeLists.txt 2017-02-02 10:01:19.502229500 -0600
|
||||||
|
@@ -10,6 +10,7 @@ if (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_
|
||||||
|
message(FATAL_ERROR "Could not find 64-bit XDR datatype functions!")
|
||||||
|
endif (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_XDR_UINT64_T AND NOT HAVE_XDR_U_HYPER AND NOT HAVE_XDR_U_LONGLONG_T)
|
||||||
|
|
||||||
|
+add_definitions(-D_DEFAULT_SOURCE)
|
||||||
|
if (HAVE_XDR_U_INT64_T)
|
||||||
|
add_definitions(-DHAVE_XDR_U_INT64_T)
|
||||||
|
endif (HAVE_XDR_U_INT64_T)
|
||||||
|
@@ -26,7 +27,7 @@ endif (HAVE_XDR_U_LONGLONG_T)
|
||||||
|
add_definitions(-DTRANSLATION_DOMAIN=\"kio_nfs\")
|
||||||
|
|
||||||
|
add_library(kio_nfs MODULE kio_nfs.cpp nfsv2.cpp nfsv3.cpp rpc_nfs3_prot_xdr.c rpc_nfs2_prot_xdr.c)
|
||||||
|
-target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network)
|
||||||
|
+target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network ${TIRPC_LIBRARIES})
|
||||||
|
set_target_properties(kio_nfs PROPERTIES OUTPUT_NAME "nfs")
|
||||||
|
|
||||||
|
install(TARGETS kio_nfs DESTINATION ${PLUGIN_INSTALL_DIR}/kf5/kio)
|
Loading…
Reference in new issue