Build against libtirpc (#1532944), patch from Cygwin Ports

* Wed Jan 10 2018 Kevin Kofler <Kevin@tigcc.ticalc.org> - 17.12.0-2
- Build against libtirpc (#1532944), patch from Cygwin Ports
epel9
Kevin Kofler 7 years ago
parent ce954af74c
commit ba9e70239d

@ -0,0 +1,36 @@
--- kio-extras-16.08.3/CMakeLists.txt 2016-11-07 06:21:48.000000000 -0600
+++ kio-extras-16.08.3/CMakeLists.txt 2017-02-02 09:45:43.808487100 -0600
@@ -152,9 +152,11 @@ endif()
if(Gperf_FOUND AND KF5KHtml_FOUND)
add_subdirectory( man )
endif()
- check_include_files(rpc/rpc.h HAVE_RPC_RPC_H)
- add_feature_info("NFS kioslave" HAVE_RPC_RPC_H "The RPC library is needed to build the NFS kioslave")
- if(HAVE_RPC_RPC_H)
+ pkg_check_modules(TIRPC libtirpc)
+ include_directories(${TIRPC_INCLUDE_DIRS})
+ set(CMAKE_REQUIRED_LIBRARIES ${TIRPC_LIBRARIES})
+ add_feature_info("NFS kioslave" TIRPC_FOUND "The RPC library is needed to build the NFS kioslave")
+ if(TIRPC_FOUND)
add_subdirectory( nfs )
endif()
endif()
--- kio-extras-16.08.3/nfs/CMakeLists.txt 2016-11-07 06:21:48.000000000 -0600
+++ kio-extras-16.08.3/nfs/CMakeLists.txt 2017-02-02 10:01:19.502229500 -0600
@@ -10,6 +10,7 @@ if (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_
message(FATAL_ERROR "Could not find 64-bit XDR datatype functions!")
endif (NOT HAVE_XDR_U_INT64_T AND NOT HAVE_XDR_UINT64_T AND NOT HAVE_XDR_U_HYPER AND NOT HAVE_XDR_U_LONGLONG_T)
+add_definitions(-D_DEFAULT_SOURCE)
if (HAVE_XDR_U_INT64_T)
add_definitions(-DHAVE_XDR_U_INT64_T)
endif (HAVE_XDR_U_INT64_T)
@@ -26,7 +27,7 @@ endif (HAVE_XDR_U_LONGLONG_T)
add_definitions(-DTRANSLATION_DOMAIN=\"kio_nfs\")
add_library(kio_nfs MODULE kio_nfs.cpp nfsv2.cpp nfsv3.cpp rpc_nfs3_prot_xdr.c rpc_nfs2_prot_xdr.c)
-target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network)
+target_link_libraries(kio_nfs KF5::KIOCore KF5::I18n Qt5::Network ${TIRPC_LIBRARIES})
set_target_properties(kio_nfs PROPERTIES OUTPUT_NAME "nfs")
install(TARGETS kio_nfs DESTINATION ${PLUGIN_INSTALL_DIR}/kf5/kio)

@ -8,7 +8,7 @@
Name: kio-extras Name: kio-extras
Version: 17.12.0 Version: 17.12.0
Release: 1%{?dist} Release: 2%{?dist}
Summary: Additional components to increase the functionality of KIO Framework Summary: Additional components to increase the functionality of KIO Framework
License: GPLv2+ License: GPLv2+
@ -22,6 +22,11 @@ URL: https://cgit.kde.org/%{name}.git
%endif %endif
Source0: http://download.kde.org/%{stable}/applications/%{version}/src/%{name}-%{version}.tar.xz Source0: http://download.kde.org/%{stable}/applications/%{version}/src/%{name}-%{version}.tar.xz
# patch to use libtirpc for RPC, from Cygwin Ports
# should be upstreamable, considering that glibc's builtin RPC is obsolete
# https://github.com/cygwinports/kf5-kio-extras/blob/master/16.08.3-nfs-libtirpc.patch
Patch0: kio-extras-16.08.3-nfs-libtirpc.patch
## upstream patches ## upstream patches
# filter plugin provides # filter plugin provides
@ -58,6 +63,7 @@ BuildRequires: OpenEXR-devel
BuildRequires: openslp-devel BuildRequires: openslp-devel
BuildRequires: perl-generators BuildRequires: perl-generators
BuildRequires: phonon-qt5-devel BuildRequires: phonon-qt5-devel
BuildRequires: pkgconfig(libtirpc)
BuildRequires: qt5-qtbase-devel BuildRequires: qt5-qtbase-devel
BuildRequires: qt5-qtsvg-devel BuildRequires: qt5-qtsvg-devel
BuildRequires: taglib-devel > 1.11 BuildRequires: taglib-devel > 1.11
@ -227,6 +233,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%changelog %changelog
* Wed Jan 10 2018 Kevin Kofler <Kevin@tigcc.ticalc.org> - 17.12.0-2
- Build against libtirpc (#1532944), patch from Cygwin Ports
* Thu Dec 28 2017 Rex Dieter <rdieter@fedoraproject.org> - 17.12.0-1 * Thu Dec 28 2017 Rex Dieter <rdieter@fedoraproject.org> - 17.12.0-1
- 17.12.0 - 17.12.0

Loading…
Cancel
Save