commit
1d7a58328d
@ -0,0 +1,2 @@
|
||||
SOURCES/hdf5_1.14.4.3+repack-1~exp3.debian.tar.xz
|
||||
SOURCES/hdf5-1.14.5.tar.gz
|
@ -0,0 +1,2 @@
|
||||
830552f9a2007f0aee945eecfc00a53161da5817 SOURCES/hdf5_1.14.4.3+repack-1~exp3.debian.tar.xz
|
||||
29ecb629b952fa27992df9ddf05231522793f655 SOURCES/hdf5-1.14.5.tar.gz
|
@ -0,0 +1,10 @@
|
||||
#!/bin/bash
|
||||
|
||||
ARCH=$(uname -m)
|
||||
|
||||
case $ARCH in
|
||||
x86_64 | ppc64 | ia64 | s390x ) BITS=64;;
|
||||
* ) BITS=32;;
|
||||
esac
|
||||
|
||||
exec $0-${BITS} "$@"
|
@ -0,0 +1,41 @@
|
||||
diff --git a/java/src/Makefile.am b/java/src/Makefile.am
|
||||
index aaa4052..0d66096 100644
|
||||
--- a/java/src/Makefile.am
|
||||
+++ b/java/src/Makefile.am
|
||||
@@ -32,8 +32,8 @@ JAVAROOT = .classes
|
||||
classes:
|
||||
test -d $(@D)/$(JAVAROOT) || $(MKDIR_P) $(@D)/$(JAVAROOT)
|
||||
|
||||
-jarfile = jar$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).jar
|
||||
-hdf5_javadir = $(libdir)
|
||||
+jarfile = $(PACKAGE_TARNAME).jar
|
||||
+hdf5_javadir = $(prefix)/lib/java
|
||||
|
||||
pkgpath = hdf/hdf5lib
|
||||
CLASSPATH_ENV=CLASSPATH=.:$(top_srcdir)/java/lib/slf4j-api-2.0.6.jar:$$CLASSPATH
|
||||
diff --git a/java/test/Makefile.am b/java/test/Makefile.am
|
||||
index 9f39be9..d58f3cd 100644
|
||||
--- a/java/test/Makefile.am
|
||||
+++ b/java/test/Makefile.am
|
||||
@@ -26,7 +26,7 @@ classes:
|
||||
test -d $(@D)/$(JAVAROOT) || $(MKDIR_P) $(@D)/$(JAVAROOT)
|
||||
|
||||
pkgpath = test
|
||||
-hdfjarfile = jar$(PACKAGE_TARNAME)-$(PACKAGE_VERSION).jar
|
||||
+hdfjarfile = $(PACKAGE_TARNAME).jar
|
||||
CLASSPATH_ENV=CLASSPATH=.:$(JAVAROOT):$(top_builddir)/java/src/$(hdfjarfile):$(top_srcdir)/java/lib/junit.jar:$(top_srcdir)/java/lib/hamcrest-core.jar:$(top_srcdir)/java/lib/slf4j-api-2.0.6.jar:$(top_srcdir)/java/lib/ext/slf4j-simple-2.0.6.jar:$$CLASSPATH
|
||||
|
||||
jarfile = jar$(PACKAGE_TARNAME)test.jar
|
||||
diff --git a/java/test/junit.sh.in b/java/test/junit.sh.in
|
||||
index 0690081..9a784a1 100644
|
||||
--- a/java/test/junit.sh.in
|
||||
+++ b/java/test/junit.sh.in
|
||||
@@ -48,7 +48,7 @@ BLDLIBDIR="$BLDDIR/testlibs"
|
||||
HDFTEST_HOME="$top_srcdir/java/test"
|
||||
DUMP_TESTFILES="$top_srcdir/tools/test/h5dump/testfiles"
|
||||
|
||||
-JARFILE=jar@PACKAGE_TARNAME@-@PACKAGE_VERSION@.jar
|
||||
+JARFILE=@PACKAGE_TARNAME@.jar
|
||||
TESTJARFILE=jar@PACKAGE_TARNAME@test.jar
|
||||
test -d $BLDLIBDIR || mkdir -p $BLDLIBDIR
|
||||
|
@ -0,0 +1,11 @@
|
||||
diff -up hdf5-hdf5_1.14.5/configure.ac.float128 hdf5-hdf5_1.14.5/configure.ac
|
||||
--- hdf5-hdf5_1.14.5/configure.ac.float128 2024-09-30 08:50:29.000000000 -0600
|
||||
+++ hdf5-hdf5_1.14.5/configure.ac 2024-10-03 19:17:46.998322936 -0600
|
||||
@@ -854,6 +854,7 @@ if test "X$HDF_FORTRAN" = "Xyes"; then
|
||||
if test "$MY_FLT128_DIG" -gt "$MY_LDBL_DIG" ; then
|
||||
AC_MSG_RESULT([yes])
|
||||
AC_DEFINE([HAVE_FLOAT128], [1], [Determine if __float128 will be used in the Fortran wrappers])
|
||||
+ AC_CHECK_SIZEOF([__float128])
|
||||
else
|
||||
## Can't use __float128, but write an undef line anyway
|
||||
AC_MSG_RESULT([no])
|
@ -0,0 +1,112 @@
|
||||
diff --git a/bin/h5cc.in b/bin/h5cc.in
|
||||
index 966bb40..c0f813f 100644
|
||||
--- a/bin/h5cc.in
|
||||
+++ b/bin/h5cc.in
|
||||
@@ -89,10 +89,10 @@ CLINKERBASE="@CC@"
|
||||
# paths and libraries from AM_LDFLAGS, LDFLAGS, AM_LIBS or LIBS carried in
|
||||
# from the hdf5 build. The order of the flags is intended to give precedence
|
||||
# to the user's flags.
|
||||
-H5BLD_CFLAGS="@AM_CFLAGS@ @CFLAGS@"
|
||||
+H5BLD_CFLAGS=
|
||||
H5BLD_CPPFLAGS="@AM_CPPFLAGS@ @CPPFLAGS@"
|
||||
-H5BLD_LDFLAGS="@AM_LDFLAGS@ @LDFLAGS@"
|
||||
-H5BLD_LIBS="@LIBS@"
|
||||
+H5BLD_LDFLAGS=
|
||||
+H5BLD_LIBS=
|
||||
|
||||
CC="${HDF5_CC:-$CCBASE}"
|
||||
CLINKER="${HDF5_CLINKER:-$CLINKERBASE}"
|
||||
@@ -105,7 +105,8 @@ LIBS="${HDF5_LIBS:-$LIBSBASE}"
|
||||
# available library is shared, it will be used by default. The user can
|
||||
# override either default, although choosing an unavailable library will result
|
||||
# in link errors.
|
||||
-STATIC_AVAILABLE="@enable_static@"
|
||||
+# Fedora prefers shared libraries
|
||||
+STATIC_AVAILABLE=no
|
||||
if test "${STATIC_AVAILABLE}" = "yes"; then
|
||||
USE_SHARED_LIB="${HDF5_USE_SHLIB:-no}"
|
||||
else
|
||||
@@ -385,7 +386,7 @@ if test "x$do_link" = "xyes"; then
|
||||
# paths and libraries from AM_LDFLAGS, LDFLAGS, AM_LIBS or LIBS carried in
|
||||
# from the hdf5 build. The order of the flags is intended to give precedence
|
||||
# to the user's flags.
|
||||
- $SHOW $CLINKER $H5BLD_CPPFLAGS $CPPFLAGS $H5BLD_CFLAGS $CFLAGS $LDFLAGS $clibpath $link_objs $LIBS $link_args $shared_link
|
||||
+ $SHOW $CLINKER $H5BLD_CPPFLAGS $CPPFLAGS $H5BLD_CFLAGS $CFLAGS $LDFLAGS $clibpath $link_objs $LIBS $link_args
|
||||
status=$?
|
||||
fi
|
||||
|
||||
diff --git a/c++/src/h5c++.in b/c++/src/h5c++.in
|
||||
index 573d20d..50065e0 100644
|
||||
--- a/c++/src/h5c++.in
|
||||
+++ b/c++/src/h5c++.in
|
||||
@@ -87,10 +87,10 @@ CXXLINKERBASE="@CXX@"
|
||||
# paths and libraries from AM_LDFLAGS, LDFLAGS, AM_LIBS or LIBS carried in
|
||||
# from the hdf5 build. The order of the flags is intended to give precedence
|
||||
# to the user's flags.
|
||||
-H5BLD_CXXFLAGS="@AM_CXXFLAGS@ @CXXFLAGS@"
|
||||
+H5BLD_CXXFLAGS=
|
||||
H5BLD_CPPFLAGS="@AM_CPPFLAGS@ @CPPFLAGS@"
|
||||
-H5BLD_LDFLAGS="@AM_LDFLAGS@ @LDFLAGS@"
|
||||
-H5BLD_LIBS="@LIBS@"
|
||||
+H5BLD_LDFLAGS=
|
||||
+H5BLD_LIBS=
|
||||
|
||||
CXX="${HDF5_CXX:-$CXXBASE}"
|
||||
CXXLINKER="${HDF5_CXXLINKER:-$CXXLINKERBASE}"
|
||||
@@ -103,7 +103,8 @@ LIBS="${HDF5_LIBS:-$LIBSBASE}"
|
||||
# available library is shared, it will be used by default. The user can
|
||||
# override either default, although choosing an unavailable library will result
|
||||
# in link errors.
|
||||
-STATIC_AVAILABLE="@enable_static@"
|
||||
+# Fedora prefers shared libraries
|
||||
+STATIC_AVAILABLE=no
|
||||
if test "${STATIC_AVAILABLE}" = "yes"; then
|
||||
USE_SHARED_LIB="${HDF5_USE_SHLIB:-no}"
|
||||
else
|
||||
@@ -385,7 +386,7 @@ if test "x$do_link" = "xyes"; then
|
||||
# from the hdf5 build. The order of the flags is intended to give precedence
|
||||
# to the user's flags.
|
||||
|
||||
- $SHOW $CXXLINKER $H5BLD_CPPFLAGS $CPPFLAGS $H5BLD_CXXFLAGS $CXXFLAGS $LDFLAGS $clibpath $link_objs $LIBS $link_args $shared_link
|
||||
+ $SHOW $CXXLINKER $H5BLD_CPPFLAGS $CPPFLAGS $H5BLD_CXXFLAGS $CXXFLAGS $LDFLAGS $clibpath $link_objs $LIBS $link_args
|
||||
|
||||
status=$?
|
||||
fi
|
||||
diff --git a/fortran/src/h5fc.in b/fortran/src/h5fc.in
|
||||
index 661fde5..00b5f4b 100644
|
||||
--- a/fortran/src/h5fc.in
|
||||
+++ b/fortran/src/h5fc.in
|
||||
@@ -83,11 +83,11 @@ FLINKERBASE="@FC@"
|
||||
# libraries in $link_args, followed by any external library paths and libraries
|
||||
# from AM_LDFLAGS, LDFLAGS, AM_LIBS or LIBS carried in from the hdf5 build.
|
||||
# The order of the flags is intended to give precedence to the user's flags.
|
||||
-H5BLD_FCFLAGS="@AM_FCFLAGS@ @FCFLAGS@"
|
||||
+H5BLD_FCFLAGS=
|
||||
F9XMODFLAG="@F9XMODFLAG@"
|
||||
F9XSUFFIXFLAG="@F9XSUFFIXFLAG@"
|
||||
-H5BLD_LDFLAGS="@AM_LDFLAGS@ @LDFLAGS@"
|
||||
-H5BLD_LIBS="@LIBS@"
|
||||
+H5BLD_LDFLAGS=
|
||||
+H5BLD_LIBS=
|
||||
|
||||
FC="${HDF5_FC:-$FCBASE}"
|
||||
FLINKER="${HDF5_FLINKER:-$FLINKERBASE}"
|
||||
@@ -99,7 +99,8 @@ LIBS="${HDF5_LIBS:-$LIBSBASE}"
|
||||
# available library is shared, it will be used by default. The user can
|
||||
# override either default, although choosing an unavailable library will result
|
||||
# in link errors.
|
||||
-STATIC_AVAILABLE="@enable_static@"
|
||||
+# Fedora prefers shared libraries
|
||||
+STATIC_AVAILABLE=no
|
||||
if test "${STATIC_AVAILABLE}" = "yes"; then
|
||||
USE_SHARED_LIB="${HDF5_USE_SHLIB:-no}"
|
||||
else
|
||||
@@ -363,7 +364,7 @@ if test "x$do_link" = "xyes"; then
|
||||
# libraries in $link_args, followed by any external library paths and libraries
|
||||
# from AM_LDFLAGS, LDFLAGS, AM_LIBS or LIBS carried in from the hdf5 build.
|
||||
# The order of the flags is intended to give precedence to the user's flags.
|
||||
- $SHOW $FLINKER $FCFLAGS $H5BLD_FCFLAGS $F9XSUFFIXFLAG $LDFLAGS $fmodules $link_objs $LIBS $link_args $shared_link
|
||||
+ $SHOW $FLINKER $FCFLAGS $H5BLD_FCFLAGS $F9XSUFFIXFLAG $LDFLAGS $fmodules $link_objs $LIBS $link_args
|
||||
status=$?
|
||||
fi
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue