import bzrtp-5.3.5-1

i9m changed/i9m/bzrtp-5.3.5-1.el9.inferit
Sergey Cherevko 8 months ago
commit c9f4a8f086
Signed by: scherevko
GPG Key ID: D87CBBC16D2E4A72

@ -0,0 +1 @@
591aba998e6375027bc6832ee00308f12151364b SOURCES/bzrtp-5.3.5.tar.gz

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/bzrtp-5.3.5.tar.gz

@ -0,0 +1,13 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2cbcc68..ad8abc4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -143,7 +143,7 @@ if(ENABLE_PACKAGE_SOURCE)
endif()
include(CMakePackageConfigHelpers)
-set(CMAKE_MODULES_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME}/cmake")
+set(CMAKE_MODULES_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}")
configure_package_config_file("cmake/${PROJECT_NAME}Config.cmake.in" "${PROJECT_BINARY_DIR}/${PROJECT_NAME}Config.cmake"
INSTALL_DESTINATION "${CMAKE_MODULES_INSTALL_DIR}"
NO_SET_AND_CHECK_MACRO

@ -0,0 +1,35 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da43ab8..2cbcc68 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,6 +94,17 @@ if(ENABLE_UNIT_TESTS AND NOT ANDROID AND NOT IOS)
add_subdirectory(test)
endif()
+set(prefix ${CMAKE_INSTALL_PREFIX})
+set(exec_prefix ${prefix}/libexec)
+set(libdir ${prefix}/lib${LIB_SUFFIX})
+set(includedir ${prefix}/include)
+set(PACKAGE_VERSION ${PROJECT_VERSION})
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libbzrtp.pc.in
+ "${CMAKE_CURRENT_BINARY_DIR}/libbzrtp.pc"
+ @ONLY
+)
+
if(ENABLE_DOC)
# Doxygen
find_package(Doxygen)
@@ -121,6 +132,12 @@ if(ENABLE_DOC)
endif()
endif()
+install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/libbzrtp.pc"
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig"
+)
+
+
if(ENABLE_PACKAGE_SOURCE)
add_subdirectory(build)
endif()

@ -0,0 +1,204 @@
%define major 0
%define libname %{name}-libs
%define develname %{name}-devel
Summary: ZRTP keys exchange protocol implementation
Name: bzrtp
Version: 5.3.5
Release: 1%{?dist}.inferit
License: GPLv2
Group: System/Libraries
URL: https://linphone.org/
Source0: https://gitlab.linphone.org/BC/public/bzrtp/-/archive/%{version}/bzrtp-%{version}.tar.gz
# (wally) install .pc file with cmake
Patch0: bzrtp-cmake-install-pkgconfig-pc-file.patch
# (wally) fix cmake config file location
Patch1: bzrtp-cmake-config-location.patch
BuildRequires: cmake
BuildRequires: ninja-build
BuildRequires: pkgconfig(bctoolbox) >= %{version}
BuildRequires: pkgconfig(libxml-2.0)
BuildRequires: pkgconfig(sqlite3)
%description
bzrtp is a FOSS implementation of ZRTP keys exchange protocol.
The library is written in C 89, is fully portable, and can be executed
on many platforms including x86 and ARM processors.
%package -n %{libname}
Summary: ZRTP keys exchange protocol implementation
Group: System/Libraries
%description -n %{libname}
bzrtp is a FOSS implementation of ZRTP keys exchange protocol.
The library is written in C 89, is fully portable, and can be executed
on many platforms including x86 and ARM processors.
%package -n %{develname}
Summary: Development files for %{name}
Group: Development/C
Requires: %{libname} = %{version}-%{release}
Provides: bzrtp-devel = %{version}-%{release}
%description -n %{develname}
This package contains development files for %{name}
%prep
%setup -q
%autopatch -p1
# Fix version
sed -i -e '/project/s/\(VERSION\)\s\+[0-9]\+\(\.[0-9]\+\)\+/\1 %{version}/' CMakeLists.txt
%build
%cmake -GNinja \
-DENABLE_STATIC:BOOL=NO \
-DENABLE_STRICT:BOOL=NO
%cmake_build
%install
%cmake_install
%files -n %{libname}
%license LICENSE.txt
%doc CHANGELOG.md README.md
%{_libdir}/lib%{name}.so.%{major}{,.*}
%files -n %{develname}
%{_includedir}/%{name}/
%{_libdir}/lib%{name}.so
%{_libdir}/pkgconfig/lib%{name}.pc
%{_libdir}/cmake/BZRTP/
%changelog
* Thu May 30 2024 Sergey Cherevko <s.cherevko@msvsphere-os.ru> - 5.3.5-1.inferit
- Rebuilt for MSVSphere 9.4
* Sat Dec 30 2023 wally <wally> 5.3.5-1.mga10
+ Revision: 2024672
- new version 5.3.5
* Fri Jun 09 2023 wally <wally> 5.2.70-1.mga9
+ Revision: 1961521
- new version 5.2.70
* Sat Dec 24 2022 wally <wally> 5.2.4-1.mga9
+ Revision: 1926260
- new version 5.2.4
* Sun Dec 04 2022 wally <wally> 5.1.72-1.mga9
+ Revision: 1917533
- new version 5.1.72
- build using ninja
* Tue Aug 23 2022 wally <wally> 5.1.55-1.mga9
+ Revision: 1879626
- new version 5.1.55
* Wed May 04 2022 wally <wally> 5.1.12-2.mga9
+ Revision: 1856170
- rebuild to core/release
* Tue May 03 2022 wally <wally> 5.1.12-1.mga9
+ Revision: 1855680
- new version 5.1.12
* Fri Mar 18 2022 umeabot <umeabot> 5.0.53-2.mga9
+ Revision: 1798806
- Mageia 9 Mass Rebuild
* Sun Nov 21 2021 wally <wally> 5.0.53-1.mga9
+ Revision: 1758355
- new version 5.0.53
* Sat Jul 31 2021 wally <wally> 5.0.0-1.mga9
+ Revision: 1738379
- new version 5.0.0
* Sun May 30 2021 wally <wally> 4.5.15-1.mga9
+ Revision: 1728849
- new version 4.5.15
* Sat Apr 10 2021 wally <wally> 4.5.1-1.mga9
+ Revision: 1714610
- new version 4.5.1
* Sun Mar 21 2021 wally <wally> 4.4.34-1.mga9
+ Revision: 1706479
- new version 4.4.34
* Sun Dec 27 2020 wally <wally> 4.4.21-1.mga8
+ Revision: 1664104
- new version 4.4.21
* Sat Dec 19 2020 wally <wally> 4.4.19-1.mga8
+ Revision: 1661357
- new version 4.4.19
* Thu Dec 10 2020 wally <wally> 4.4.13-1.mga8
+ Revision: 1655179
- new version 4.4.13
* Mon Nov 23 2020 wally <wally> 4.4.9-1.mga8
+ Revision: 1648760
- new version 4.4.9
* Sun Oct 25 2020 wally <wally> 4.4.6-1.mga8
+ Revision: 1639238
- new version 4.4.6
* Sat Sep 05 2020 shlomif <shlomif> 4.4.0-1.mga8
+ Revision: 1622361
- New version 4.4.0
* Sat Mar 28 2020 wally <wally> 4.3.1-1.mga8
+ Revision: 1561406
- new version 4.3.1
* Wed Feb 12 2020 umeabot <umeabot> 3.mga8-current
+ Revision: 1511154
- Mageia 8 Mass Rebuild
+ wally <wally>
- build with new cmake macros
* Sat Sep 22 2018 umeabot <umeabot> 1.0.6-2.mga7
+ Revision: 1295757
- Mageia 7 Mass Rebuild
+ wally <wally>
- fix devel pkg summary
- add more strict requires to devel pkg
* Sun Dec 31 2017 wally <wally> 1.0.6-1.mga7
+ Revision: 1188315
- new version 1.0.6
- switch to cmake build
* Wed Nov 22 2017 tv <tv> 1.0.4-3.mga7
+ Revision: 1178714
- rebuild for new libbctoolbox
* Sun Jan 22 2017 akien <akien> 1.0.4-2.mga6
+ Revision: 1083025
- Remove BR on mbedtls, used to build bctoolbox only
* Fri Dec 02 2016 zezinho <zezinho> 1.0.4-1.mga6
+ Revision: 1071680
- new version 1.0.4
* Fri Jan 15 2016 luigiwalser <luigiwalser> 1.0.3-2.mga6
+ Revision: 923165
- rebuild to regenerate devel deps
* Mon Nov 16 2015 oden <oden> 1.0.3-1.mga6
+ Revision: 903556
- 1.0.3
* Sun Aug 02 2015 oden <oden> 1.0.2-1.mga6
+ Revision: 860686
- fix group
- imported package bzrtp
* Sun Aug 02 2015 Oden Eriksson <oe@nux.se> 1.0.2-1
- initial Mageia package
Loading…
Cancel
Save