You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
bzrtp/SOURCES/bzrtp-cmake-install-pkgconf...

36 lines
828 B

diff --git a/CMakeLists.txt b/CMakeLists.txt
index da43ab8..2cbcc68 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,6 +94,17 @@ if(ENABLE_UNIT_TESTS AND NOT ANDROID AND NOT IOS)
add_subdirectory(test)
endif()
+set(prefix ${CMAKE_INSTALL_PREFIX})
+set(exec_prefix ${prefix}/libexec)
+set(libdir ${prefix}/lib${LIB_SUFFIX})
+set(includedir ${prefix}/include)
+set(PACKAGE_VERSION ${PROJECT_VERSION})
+
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libbzrtp.pc.in
+ "${CMAKE_CURRENT_BINARY_DIR}/libbzrtp.pc"
+ @ONLY
+)
+
if(ENABLE_DOC)
# Doxygen
find_package(Doxygen)
@@ -121,6 +132,12 @@ if(ENABLE_DOC)
endif()
endif()
+install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/libbzrtp.pc"
+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig"
+)
+
+
if(ENABLE_PACKAGE_SOURCE)
add_subdirectory(build)
endif()