Resolves: rhbz#2113772 FTBFS in Fedora rawhide/f37

epel10
Caolán McNamara 2 years ago
parent 24db98bd07
commit 6925253fcf

@ -0,0 +1,42 @@
From 3872abbb33ebb8d6c891baff33778aae04f0c546 Mon Sep 17 00:00:00 2001
From: axxel <awagger@gmail.com>
Date: Tue, 26 Jul 2022 22:42:00 +0200
Subject: [PATCH] test: update to libfmt v9.0.0
---
test/blackbox/BlackboxTestRunner.cpp | 8 ++++----
test/blackbox/CMakeLists.txt | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/test/blackbox/BlackboxTestRunner.cpp b/test/blackbox/BlackboxTestRunner.cpp
index 7e126a62..85c5b9d4 100644
--- a/test/blackbox/BlackboxTestRunner.cpp
+++ b/test/blackbox/BlackboxTestRunner.cpp
@@ -158,8 +158,7 @@
auto folderName = directory.stem();
if (Size(imgPaths) != totalTests)
- fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName, totalTests,
- imgPaths.size());
+ fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName.string(), totalTests, imgPaths.size());
for (auto& test : tests) {
fmt::print("{:20} @ {:3}, {:3}", folderName.string(), test.rotation, Size(imgPaths));
@@ -234,7 +233,7 @@
}
if (Size(imageGroups) != totalTests)
- fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName, totalTests,
+ fmt::print("TEST {} => Expected number of tests: {}, got: {} => FAILED\n", folderName.string(), totalTests,
imageGroups.size());
for (auto& test : tests) {
@@ -445,7 +444,7 @@
{ 17, 20, 0 },
{ 19, 20, 180 },
});
-
+
runTests("upca-extension-1", "UPC-A", 6, {
{ 3, 6, 0 },
{ 4, 6, 180 },

@ -1,6 +1,6 @@
Name: zxing-cpp
Version: 1.2.0
Release: 6%{?dist}
Release: 7%{?dist}
Summary: C++ port of the ZXing ("Zebra Crossing") barcode scanning library
# The entire source is ASL 2.0, except:
@ -40,6 +40,8 @@ Patch1: %{url}/pull/269.patch
# Use the system copy of pybind11 rather than trying to download a copy. This
# patch is unconditional, so it is not, as-is, suitable for sending upstream.
Patch2: zxing-cpp-1.2.0-system-pybind11.patch
# fix for recent libfmt
Patch3: 0001-test-update-to-libfmt-v9.0.0.patch
%description
ZXing-C++ ("zebra crossing") is an open-source, multi-format 1D/2D barcode
@ -147,6 +149,9 @@ popd
%files -n python3-%{name} -f %{pyproject_files}
%changelog
* Tue Aug 02 2022 Caolán McNamara <caolanm@redhat.com> 1.2.0-7
- Resolves: rhbz#2113772 FTBFS in Fedora rawhide/f37
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

Loading…
Cancel
Save