Signed-off-by: Petr Šabata <contyk@redhat.com>
f38
Petr Šabata 6 years ago
parent 2f215c8600
commit e8b3faaea6

@ -1,35 +0,0 @@
From 130a5f784b2e27ff1eb959a36707cb3aff1a96d4 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20=C5=A0abata?= <contyk@redhat.com>
Date: Tue, 10 Apr 2018 21:14:12 +0200
Subject: [PATCH] Link against jpeg
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
This resolves a broken runtime dependency.
Signed-off-by: Petr Šabata <contyk@redhat.com>
---
meson.build | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 6e077cf..3834bba 100644
--- a/meson.build
+++ b/meson.build
@@ -20,8 +20,11 @@ girara = dependency('girara-gtk3')
glib = dependency('glib-2.0')
cairo = dependency('cairo')
mupdf = cc.find_library('mupdf')
+jpeg = dependency('libjpeg')
+openjpeg = dependency('libopenjp2')
+jbig2dec = cc.find_library('jbig2dec')
-build_dependencies = [zathura, girara, glib, cairo, mupdf]
+build_dependencies = [zathura, girara, glib, cairo, mupdf, jpeg, openjpeg, jbig2dec]
# defines
defines = [
--
2.17.0

@ -1,33 +0,0 @@
From 86e3c01cf1a113681873d4f550262c1aefa48df7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20=C5=A0abata?= <contyk@redhat.com>
Date: Tue, 10 Apr 2018 20:41:55 +0200
Subject: [PATCH] Drop the mupdfthird dependency
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
It's not provided in Fedora.
Signed-off-by: Petr Šabata <contyk@redhat.com>
---
meson.build | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/meson.build b/meson.build
index 3b0d7b7..6e077cf 100644
--- a/meson.build
+++ b/meson.build
@@ -20,9 +20,8 @@ girara = dependency('girara-gtk3')
glib = dependency('glib-2.0')
cairo = dependency('cairo')
mupdf = cc.find_library('mupdf')
-mupdfthird = cc.find_library('mupdfthird')
-build_dependencies = [zathura, girara, glib, cairo, mupdf, mupdfthird]
+build_dependencies = [zathura, girara, glib, cairo, mupdf]
# defines
defines = [
--
2.17.0

@ -1,12 +1,10 @@
Name: zathura-pdf-mupdf
Version: 0.3.3
Release: 2%{?dist}
Version: 0.3.4
Release: 1%{?dist}
Summary: PDF support for zathura via mupdf
License: zlib
URL: http://pwmt.org/projects/zathura/plugins/%{name}
Source0: http://pwmt.org/projects/zathura/plugins/download/%{name}-%{version}.tar.xz
Patch0: %{name}-0.3.3-mupdfthird.patch
Patch1: %{name}-0.3.3-jpeg.patch
BuildRequires: binutils
BuildRequires: cairo-devel
# Needed to validate the desktop file
@ -19,7 +17,7 @@ BuildRequires: jbig2dec-devel
BuildRequires: libappstream-glib
BuildRequires: libjpeg-turbo-devel
BuildRequires: meson >= 0.43
BuildRequires: mupdf-static
BuildRequires: mupdf-static >= 1.14
BuildRequires: openjpeg2-devel
BuildRequires: zathura-devel >= 0.3.9
Requires: zathura >= 0.3.9
@ -31,11 +29,9 @@ This plugin adds PDF support to zathura using the mupdf rendering engine.
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%build
%meson
%meson -Dlink-external=true
%meson_build
%install
@ -55,6 +51,10 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*.metainf
%{_datadir}/metainfo/org.pwmt.zathura-pdf-mupdf.metainfo.xml
%changelog
* Thu Nov 15 2018 Petr Šabata <contyk@redhat.com> - 0.3.4-1
- 0.3.4 bump
- Fixes rhbz#1645552
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

Loading…
Cancel
Save