You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
36 lines
1004 B
36 lines
1004 B
From 130a5f784b2e27ff1eb959a36707cb3aff1a96d4 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Petr=20=C5=A0abata?= <contyk@redhat.com>
|
|
Date: Tue, 10 Apr 2018 21:14:12 +0200
|
|
Subject: [PATCH] Link against jpeg
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This resolves a broken runtime dependency.
|
|
|
|
Signed-off-by: Petr Šabata <contyk@redhat.com>
|
|
---
|
|
meson.build | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 6e077cf..3834bba 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -20,8 +20,11 @@ girara = dependency('girara-gtk3')
|
|
glib = dependency('glib-2.0')
|
|
cairo = dependency('cairo')
|
|
mupdf = cc.find_library('mupdf')
|
|
+jpeg = dependency('libjpeg')
|
|
+openjpeg = dependency('libopenjp2')
|
|
+jbig2dec = cc.find_library('jbig2dec')
|
|
|
|
-build_dependencies = [zathura, girara, glib, cairo, mupdf]
|
|
+build_dependencies = [zathura, girara, glib, cairo, mupdf, jpeg, openjpeg, jbig2dec]
|
|
|
|
# defines
|
|
defines = [
|
|
--
|
|
2.17.0
|
|
|