Merge branch 'pr12' into rawhide

f38
Ankur Sinha (Ankur Sinha Gmail) 3 years ago
commit 776ac31fb1
No known key found for this signature in database
GPG Key ID: F8D8C0BEBAC898BD

@ -0,0 +1,84 @@
From 10c8edffbf9b814bb95e74b04a6a1d7fb729b4b4 Mon Sep 17 00:00:00 2001
Message-Id: <10c8edffbf9b814bb95e74b04a6a1d7fb729b4b4.1644786121.git.mjg@fedoraproject.org>
From: Michael J Gruber <mjg@fedoraproject.org>
Date: Sun, 13 Feb 2022 22:00:59 +0100
Subject: [PATCH] Revert "Rework detection of mupdf"
This reverts commit 49a85efb915bfed933d251f6074b807d0e1ef385.
On Fedora, neither pkconfig nor cmake find mupdf the way meson looks for
it. Also, we don't mujs since mupdf builds against the in-tree copy.
Signed-off-by: Michael J Gruber <mjg@fedoraproject.org>
---
meson.build | 17 +++++------------
meson_options.txt | 6 ++++++
2 files changed, 11 insertions(+), 12 deletions(-)
diff --git a/meson.build b/meson.build
index c8c19dc..07abdf5 100644
--- a/meson.build
+++ b/meson.build
@@ -19,7 +19,7 @@ zathura = dependency('zathura', version: '>=0.3.9')
girara = dependency('girara-gtk3')
glib = dependency('glib-2.0')
cairo = dependency('cairo')
-mupdf = dependency('mupdf', required: false)
+mupdf = cc.find_library('mupdf')
mupdfthird = cc.find_library('mupdf-third')
build_dependencies = [
@@ -27,23 +27,17 @@ build_dependencies = [
girara,
glib,
cairo,
+ mupdf,
+ mupdfthird
]
-if not mupdf.found()
- # normal build of mupdf
- mupdf = cc.find_library('mupdf')
- build_dependencies += [mupdf, mupdfthird]
-else
- # build from Debian's libmupdf-dev
- build_dependencies += [mupdf, mupdfthird]
-
+if get_option('link-external')
libjpeg = dependency('libjpeg')
libjbig2dec = cc.find_library('jbig2dec')
libopenjp2 = dependency('libopenjp2')
gumbo = dependency('gumbo')
tesseract = dependency('tesseract')
leptonica = dependency('lept')
- mujs = dependency('mujs')
build_dependencies += [
libjpeg,
@@ -51,8 +45,7 @@ else
libopenjp2,
gumbo,
tesseract,
- leptonica,
- mujs
+ leptonica
]
endif
diff --git a/meson_options.txt b/meson_options.txt
index c8df610..db9d0c5 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -1,3 +1,9 @@
+option('link-external',
+ type: 'boolean',
+ value: false,
+ description: 'Link external libraries required by mupdf.'
+)
+
option('plugindir',
type: 'string',
value: '',
--
2.35.1.306.ga00bde9711

@ -6,11 +6,13 @@
Name: zathura-pdf-mupdf
Version: 0.3.8
Release: 1%{?dist}
Release: 2%{?dist}
Summary: PDF support for zathura via mupdf
License: zlib
URL: https://pwmt.org/projects/%{name}/
Source0: %{url}/download/%{name}-%{version}.tar.xz
Patch1: 0001-Revert-Rework-detection-of-mupdf.patch
BuildRequires: binutils
BuildRequires: cairo-devel
# Needed to validate the desktop file
@ -65,6 +67,11 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*.metainf
%{_datadir}/metainfo/org.pwmt.zathura-pdf-mupdf.metainfo.xml
%changelog
* Wed Apr 13 2022 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.8-2
- merge https://src.fedoraproject.org/rpms/zathura-pdf-mupdf/pull-request/12
- Remove upstreamed patch
- Restore build with external libraries
* Sat Apr 02 2022 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 0.3.8-1
- update to latest release

Loading…
Cancel
Save