Update to 0.3.8 (bz #2053985)

f38
Michael J Gruber 3 years ago
parent ddc4b5fc0d
commit 2d8a656033

1
.gitignore vendored

@ -6,3 +6,4 @@
/zathura-pdf-mupdf-0.3.5.tar.xz
/zathura-pdf-mupdf-0.3.6.tar.xz
/zathura-pdf-mupdf-0.3.7.tar.xz
/zathura-pdf-mupdf-0.3.8.tar.xz

@ -0,0 +1,84 @@
From 10c8edffbf9b814bb95e74b04a6a1d7fb729b4b4 Mon Sep 17 00:00:00 2001
Message-Id: <10c8edffbf9b814bb95e74b04a6a1d7fb729b4b4.1644786121.git.mjg@fedoraproject.org>
From: Michael J Gruber <mjg@fedoraproject.org>
Date: Sun, 13 Feb 2022 22:00:59 +0100
Subject: [PATCH] Revert "Rework detection of mupdf"
This reverts commit 49a85efb915bfed933d251f6074b807d0e1ef385.
On Fedora, neither pkconfig nor cmake find mupdf the way meson looks for
it. Also, we don't mujs since mupdf builds against the in-tree copy.
Signed-off-by: Michael J Gruber <mjg@fedoraproject.org>
---
meson.build | 17 +++++------------
meson_options.txt | 6 ++++++
2 files changed, 11 insertions(+), 12 deletions(-)
diff --git a/meson.build b/meson.build
index c8c19dc..07abdf5 100644
--- a/meson.build
+++ b/meson.build
@@ -19,7 +19,7 @@ zathura = dependency('zathura', version: '>=0.3.9')
girara = dependency('girara-gtk3')
glib = dependency('glib-2.0')
cairo = dependency('cairo')
-mupdf = dependency('mupdf', required: false)
+mupdf = cc.find_library('mupdf')
mupdfthird = cc.find_library('mupdf-third')
build_dependencies = [
@@ -27,23 +27,17 @@ build_dependencies = [
girara,
glib,
cairo,
+ mupdf,
+ mupdfthird
]
-if not mupdf.found()
- # normal build of mupdf
- mupdf = cc.find_library('mupdf')
- build_dependencies += [mupdf, mupdfthird]
-else
- # build from Debian's libmupdf-dev
- build_dependencies += [mupdf, mupdfthird]
-
+if get_option('link-external')
libjpeg = dependency('libjpeg')
libjbig2dec = cc.find_library('jbig2dec')
libopenjp2 = dependency('libopenjp2')
gumbo = dependency('gumbo')
tesseract = dependency('tesseract')
leptonica = dependency('lept')
- mujs = dependency('mujs')
build_dependencies += [
libjpeg,
@@ -51,8 +45,7 @@ else
libopenjp2,
gumbo,
tesseract,
- leptonica,
- mujs
+ leptonica
]
endif
diff --git a/meson_options.txt b/meson_options.txt
index c8df610..db9d0c5 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -1,3 +1,9 @@
+option('link-external',
+ type: 'boolean',
+ value: false,
+ description: 'Link external libraries required by mupdf.'
+)
+
option('plugindir',
type: 'string',
value: '',
--
2.35.1.306.ga00bde9711

@ -1,36 +0,0 @@
From 3547a91391e7c96145d752ffcd3c3dd7655fef21 Mon Sep 17 00:00:00 2001
Message-Id: <3547a91391e7c96145d752ffcd3c3dd7655fef21.1635089223.git.mjg@fedoraproject.org>
From: Michael J Gruber <mjg@fedoraproject.org>
Date: Sun, 24 Oct 2021 17:15:12 +0200
Subject: [PATCH] link against tesseract/leptonica for mupdf 1.19.0
Signed-off-by: Michael J Gruber <mjg@fedoraproject.org>
---
meson.build | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 28373c4..d60cb76 100644
--- a/meson.build
+++ b/meson.build
@@ -36,12 +36,16 @@ if get_option('link-external')
libjbig2dec = cc.find_library('jbig2dec')
libopenjp2 = dependency('libopenjp2')
gumbo = dependency('gumbo')
+ tesseract = dependency('tesseract')
+ leptonica = dependency('lept')
build_dependencies += [
libjpeg,
libjbig2dec,
libopenjp2,
- gumbo
+ gumbo,
+ tesseract,
+ leptonica
]
endif
--
2.33.1.1061.g4ab8308fcf

@ -1 +1 @@
SHA512 (zathura-pdf-mupdf-0.3.7.tar.xz) = 709c34b1478e22f7da6a10bc8c59aa5bd1cbffd221caa38154d2e3efbea58dd2930fef3932687acac5d5ebccbd884303d81008a138a6276057f335aed0d570c0
SHA512 (zathura-pdf-mupdf-0.3.8.tar.xz) = c2ec4a204446822eb3771673e99ddc42d6ffdfbbb9fc079e09442f0b5a6e2397190d2a8079a92f2d08d5824199760a90d192cb517c9f17676102f3ed69edd5a0

@ -5,13 +5,13 @@
Name: zathura-pdf-mupdf
Version: 0.3.7
Release: 5%{?dist}
Version: 0.3.8
Release: 1%{?dist}
Summary: PDF support for zathura via mupdf
License: zlib
URL: https://pwmt.org/projects/%{name}/
Source0: %{url}/download/%{name}-%{version}.tar.xz
Patch1: 0001-link-against-tesseract-leptonica-for-mupdf-1.19.0.patch
Patch1: 0001-Revert-Rework-detection-of-mupdf.patch
BuildRequires: binutils
BuildRequires: cairo-devel
# Needed to validate the desktop file
@ -66,6 +66,11 @@ appstream-util validate-relax --nonet %{buildroot}%{_datadir}/metainfo/*.metainf
%{_datadir}/metainfo/org.pwmt.zathura-pdf-mupdf.metainfo.xml
%changelog
* Sun Feb 13 2022 Michael J Gruber <mjg@fedoraproject.org> - 0.3.8-1
- Update to 0.3.8 (bz #2053985)
- Remove upstreamed patch
- Restore build with external libraries
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.7-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

Loading…
Cancel
Save