commit
722a9885c3
@ -0,0 +1 @@
|
||||
SOURCES/xmlunit-2.8.2.tar.gz
|
@ -0,0 +1 @@
|
||||
be39d0bab77de816ae04be6d2f58cef6138f0461 SOURCES/xmlunit-2.8.2.tar.gz
|
@ -0,0 +1,127 @@
|
||||
From 73abcb06636217e52a9d56b4dc3c69bd37141d44 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Mon, 4 Mar 2019 14:52:59 +0100
|
||||
Subject: [PATCH 1/4] Disable tests requiring network access
|
||||
|
||||
---
|
||||
.../java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java | 2 ++
|
||||
.../java/org/xmlunit/assertj3/XmlAssertValidationTest.java | 6 ++++++
|
||||
.../java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java | 2 ++
|
||||
.../java/org/xmlunit/matchers/ValidationMatcherTest.java | 2 ++
|
||||
4 files changed, 12 insertions(+)
|
||||
|
||||
diff --git a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java
|
||||
index 6499f67..c465a51 100644
|
||||
--- a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java
|
||||
+++ b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java
|
||||
@@ -13,6 +13,7 @@
|
||||
*/
|
||||
package org.xmlunit.assertj3;
|
||||
|
||||
+import org.junit.Ignore;
|
||||
import org.junit.Rule;
|
||||
import org.junit.Test;
|
||||
|
||||
@@ -43,6 +44,7 @@ public class XmlAssertNodesByXPathTest {
|
||||
}
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void testNodesByXPath_withNull_shouldFailed() {
|
||||
|
||||
thrown.expectAssertionError(format("%nExpecting not blank but was:<null>"));
|
||||
diff --git a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java
|
||||
index 7e2dc0e..f743cc4 100644
|
||||
--- a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java
|
||||
+++ b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java
|
||||
@@ -14,6 +14,7 @@
|
||||
package org.xmlunit.assertj3;
|
||||
|
||||
import org.junit.ClassRule;
|
||||
+import org.junit.Ignore;
|
||||
import org.junit.Rule;
|
||||
import org.junit.Test;
|
||||
import org.xmlunit.TestResources;
|
||||
@@ -91,6 +92,7 @@ public class XmlAssertValidationTest {
|
||||
}
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void testIsValidAgainst_withEmptySourcesArray_shouldPass() {
|
||||
|
||||
StreamSource xml = new StreamSource(new File(TestResources.TEST_RESOURCE_DIR + "BookXsdGenerated.xml"));
|
||||
@@ -100,6 +102,7 @@ public class XmlAssertValidationTest {
|
||||
}
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void testIsValidAgainst_withBrokenXmlAndEmptySourcesArray_shouldFailed() {
|
||||
|
||||
thrown.expectAssertionError("1. line=9; column=8; type=ERROR;" +
|
||||
@@ -112,6 +115,7 @@ public class XmlAssertValidationTest {
|
||||
}
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void testIsValid_shouldPass() {
|
||||
|
||||
StreamSource xml = new StreamSource(new File(TestResources.TEST_RESOURCE_DIR + "BookXsdGenerated.xml"));
|
||||
@@ -120,6 +124,7 @@ public class XmlAssertValidationTest {
|
||||
}
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void testIsValid_withBrokenXml_shouldPass() {
|
||||
|
||||
thrown.expectAssertionError("1. line=9; column=8; type=ERROR;" +
|
||||
@@ -140,6 +145,7 @@ public class XmlAssertValidationTest {
|
||||
}
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void testIsInvalid_shouldField() {
|
||||
|
||||
thrown.expectAssertionErrorPattern("^\\nExpecting:\\n <.*"
|
||||
diff --git a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java
|
||||
index 3ce5284..63c3db0 100644
|
||||
--- a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java
|
||||
+++ b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java
|
||||
@@ -14,6 +14,7 @@
|
||||
package org.xmlunit.assertj3;
|
||||
|
||||
import org.junit.ClassRule;
|
||||
+import org.junit.Ignore;
|
||||
import org.junit.Rule;
|
||||
import org.junit.Test;
|
||||
import org.xmlunit.assertj3.util.SetEnglishLocaleRule;
|
||||
@@ -31,6 +32,7 @@ public class XmlAssertValueByXPathTest {
|
||||
public static SetEnglishLocaleRule locale = new SetEnglishLocaleRule();
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void testValueByXPath_withNull_shouldFailed() {
|
||||
|
||||
thrown.expectAssertionError(format("%nExpecting not blank but was:<null>"));
|
||||
diff --git a/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java b/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java
|
||||
index 6f26927..bf9a153 100644
|
||||
--- a/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java
|
||||
+++ b/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java
|
||||
@@ -13,6 +13,7 @@
|
||||
*/
|
||||
package org.xmlunit.matchers;
|
||||
|
||||
+import org.junit.Ignore;
|
||||
import org.junit.Rule;
|
||||
import org.junit.Test;
|
||||
import org.junit.rules.ExpectedException;
|
||||
@@ -79,6 +80,7 @@ public class ValidationMatcherTest {
|
||||
}
|
||||
|
||||
@Test
|
||||
+ @Ignore
|
||||
public void shouldSuccessfullyValidateInstanceWithoutExplicitSchemaSource() {
|
||||
try {
|
||||
Class.forName("java.nio.file.FileSystem");
|
||||
--
|
||||
2.25.4
|
||||
|
@ -0,0 +1,156 @@
|
||||
From c81eb91d7b9aa9728dfc83d68a881b4e2a0fa8d2 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Thu, 29 Aug 2019 13:58:24 +0200
|
||||
Subject: [PATCH 2/4] Port to hamcrest 2.1
|
||||
|
||||
---
|
||||
.../src/main/java/org/xmlunit/matchers/CompareMatcher.java | 3 ---
|
||||
.../main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java | 2 --
|
||||
.../src/main/java/org/xmlunit/matchers/HasXPathMatcher.java | 2 --
|
||||
.../src/main/java/org/xmlunit/matchers/TypeMatcher.java | 5 -----
|
||||
.../main/java/org/xmlunit/matchers/ValidationMatcher.java | 3 ---
|
||||
5 files changed, 15 deletions(-)
|
||||
|
||||
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java
|
||||
index 6452081..226399c 100644
|
||||
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java
|
||||
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java
|
||||
@@ -33,7 +33,6 @@ import org.xmlunit.util.Predicate;
|
||||
|
||||
import org.hamcrest.BaseMatcher;
|
||||
import org.hamcrest.Description;
|
||||
-import org.hamcrest.Factory;
|
||||
import org.hamcrest.Matcher;
|
||||
|
||||
import java.lang.reflect.Constructor;
|
||||
@@ -112,7 +111,6 @@ public final class CompareMatcher extends BaseMatcher<Object>
|
||||
* <p>
|
||||
* As input all types are supported which are supported by {@link Input#from(Object)}.
|
||||
*/
|
||||
- @Factory
|
||||
public static CompareMatcher isIdenticalTo(final Object control) {
|
||||
return new CompareMatcher(control).checkForIdentical();
|
||||
}
|
||||
@@ -128,7 +126,6 @@ public final class CompareMatcher extends BaseMatcher<Object>
|
||||
* <p>
|
||||
* As input all types are supported which are supported by {@link Input#from(Object)}.
|
||||
*/
|
||||
- @Factory
|
||||
public static CompareMatcher isSimilarTo(final Object control) {
|
||||
return new CompareMatcher(control).checkForSimilar();
|
||||
}
|
||||
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java
|
||||
index 6eb23e5..1e9b8b5 100644
|
||||
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java
|
||||
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java
|
||||
@@ -16,7 +16,6 @@ package org.xmlunit.matchers;
|
||||
|
||||
import org.hamcrest.BaseMatcher;
|
||||
import org.hamcrest.Description;
|
||||
-import org.hamcrest.Factory;
|
||||
import org.hamcrest.Matcher;
|
||||
import org.w3c.dom.Node;
|
||||
import org.xmlunit.builder.Input;
|
||||
@@ -93,7 +92,6 @@ public class EvaluateXPathMatcher extends BaseMatcher<Object> {
|
||||
* @param valueMatcher matcher for the value at the specified xpath
|
||||
* @return the xpath matcher
|
||||
*/
|
||||
- @Factory
|
||||
public static EvaluateXPathMatcher hasXPath(String xPath, Matcher<String> valueMatcher) {
|
||||
return new EvaluateXPathMatcher(xPath, valueMatcher);
|
||||
}
|
||||
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java
|
||||
index 08325cd..6fbf0ac 100644
|
||||
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java
|
||||
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java
|
||||
@@ -16,7 +16,6 @@ package org.xmlunit.matchers;
|
||||
|
||||
import org.hamcrest.BaseMatcher;
|
||||
import org.hamcrest.Description;
|
||||
-import org.hamcrest.Factory;
|
||||
import org.hamcrest.Matcher;
|
||||
import org.w3c.dom.Node;
|
||||
import org.xmlunit.builder.Input;
|
||||
@@ -135,7 +134,6 @@ public class HasXPathMatcher extends BaseMatcher<Object> {
|
||||
* @param xPath the target xpath
|
||||
* @return the xpath matcher
|
||||
*/
|
||||
- @Factory
|
||||
public static HasXPathMatcher hasXPath(String xPath) {
|
||||
return new HasXPathMatcher(xPath);
|
||||
}
|
||||
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java
|
||||
index b9002a1..7cd6843 100644
|
||||
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java
|
||||
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java
|
||||
@@ -15,7 +15,6 @@
|
||||
package org.xmlunit.matchers;
|
||||
|
||||
import org.hamcrest.Description;
|
||||
-import org.hamcrest.Factory;
|
||||
import org.hamcrest.Matcher;
|
||||
import org.hamcrest.TypeSafeMatcher;
|
||||
|
||||
@@ -128,7 +127,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
|
||||
* @param valueMatcher valueMatcher for the converted value
|
||||
* @return the BigDecimal matcher
|
||||
*/
|
||||
- @Factory
|
||||
public static TypeMatcher<BigDecimal> asBigDecimal(Matcher<? extends BigDecimal> valueMatcher) {
|
||||
return new BigDecimalTypeMatcher(valueMatcher);
|
||||
}
|
||||
@@ -146,7 +144,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
|
||||
* @param valueMatcher valueMatcher for the converted value
|
||||
* @return the Double matcher
|
||||
*/
|
||||
- @Factory
|
||||
public static TypeMatcher<Double> asDouble(Matcher<? extends Double> valueMatcher) {
|
||||
return new DoubleTypeMatcher(valueMatcher);
|
||||
}
|
||||
@@ -164,7 +161,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
|
||||
* @param valueMatcher valueMatcher for the converted value
|
||||
* @return the Integer matcher
|
||||
*/
|
||||
- @Factory
|
||||
public static TypeMatcher<Integer> asInt(Matcher<? extends Integer> valueMatcher) {
|
||||
return new IntegerTypeMatcher(valueMatcher);
|
||||
}
|
||||
@@ -182,7 +178,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
|
||||
* @param valueMatcher valueMatcher for the converted value
|
||||
* @return the Boolean matcher
|
||||
*/
|
||||
- @Factory
|
||||
public static TypeMatcher<Boolean> asBoolean(Matcher<? extends Boolean> valueMatcher) {
|
||||
return new BooleanTypeMatcher(valueMatcher);
|
||||
}
|
||||
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java
|
||||
index 3126349..51f58ec 100644
|
||||
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java
|
||||
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java
|
||||
@@ -27,7 +27,6 @@ import org.xmlunit.validation.ValidationProblem;
|
||||
import org.xmlunit.validation.ValidationResult;
|
||||
import org.hamcrest.BaseMatcher;
|
||||
import org.hamcrest.Description;
|
||||
-import org.hamcrest.Factory;
|
||||
|
||||
import javax.xml.transform.Source;
|
||||
import javax.xml.validation.Schema;
|
||||
@@ -121,7 +120,6 @@ public class ValidationMatcher extends BaseMatcher {
|
||||
}
|
||||
}
|
||||
|
||||
- @Factory
|
||||
public static ValidationMatcher valid(final Object schemaSource) {
|
||||
return new ValidationMatcher(schemaSource);
|
||||
}
|
||||
@@ -129,7 +127,6 @@ public class ValidationMatcher extends BaseMatcher {
|
||||
/**
|
||||
* @since XMLUnit 2.3.0
|
||||
*/
|
||||
- @Factory
|
||||
public static ValidationMatcher valid(final Schema schema) {
|
||||
return new ValidationMatcher(schema);
|
||||
}
|
||||
--
|
||||
2.21.0
|
||||
|
@ -0,0 +1,60 @@
|
||||
From 9866f331db726db0ac6af64649c308b01b34ea56 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Tue, 5 Nov 2019 12:14:08 +0100
|
||||
Subject: [PATCH 4/4] Drop support for JAXB
|
||||
|
||||
---
|
||||
xmlunit-core/src/main/java/org/xmlunit/builder/Input.java | 4 ++--
|
||||
.../src/test/java/org/xmlunit/builder/InputTest.java | 7 -------
|
||||
2 files changed, 2 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java b/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
|
||||
index 27d9c5a..81165cc 100644
|
||||
--- a/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
|
||||
+++ b/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
|
||||
@@ -153,8 +153,8 @@ public class Input {
|
||||
/**
|
||||
* Build a Source from a Jaxb-Object.
|
||||
*/
|
||||
- public static JaxbBuilder fromJaxb(Object jaxbObject) {
|
||||
- return new JaxbBuilder(jaxbObject);
|
||||
+ public static Builder fromJaxb(Object jaxbObject) {
|
||||
+ throw new RuntimeException("This implementation has JAXB support removed");
|
||||
}
|
||||
|
||||
/**
|
||||
diff --git a/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java b/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
|
||||
index e767f38..98e3fe7 100644
|
||||
--- a/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
|
||||
+++ b/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
|
||||
@@ -31,7 +31,6 @@ import org.w3c.dom.Document;
|
||||
import org.xmlunit.NullNode;
|
||||
import org.xmlunit.TestResources;
|
||||
import org.xmlunit.XMLUnitException;
|
||||
-import org.xmlunit.builder.jaxb.ComplexNode;
|
||||
import org.xmlunit.util.Convert;
|
||||
import org.xmlunit.xpath.JAXPXPathEngine;
|
||||
|
||||
@@ -132,10 +131,6 @@ public class InputTest {
|
||||
allIsWellFor(s, "furry");
|
||||
}
|
||||
|
||||
- @Test public void shouldParseJaxbObject() throws Exception {
|
||||
- allIsWellFor(Input.fromJaxb(new ComplexNode()).build(), "complexNode");
|
||||
- }
|
||||
-
|
||||
@Test public void shouldParseUnknownToSource() throws Exception {
|
||||
// from Source
|
||||
allIsWellFor(Input.from(Input.fromByteArray(readTestFile()).build()).build());
|
||||
@@ -153,8 +148,6 @@ public class InputTest {
|
||||
allIsWellFor(Input.from(new URI("file:" + TestResources.ANIMAL_FILE)).build());
|
||||
// from URL
|
||||
allIsWellFor(Input.from(new URL("file:" + TestResources.ANIMAL_FILE)).build());
|
||||
- // from Jaxb-Object
|
||||
- allIsWellFor(Input.from(new ComplexNode()).build(), "complexNode");
|
||||
// from InputStream
|
||||
try (FileInputStream is = new FileInputStream(TestResources.ANIMAL_FILE)) {
|
||||
allIsWellFor(Input.from(is).build());
|
||||
--
|
||||
2.29.2
|
||||
|
@ -0,0 +1,20 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
|
||||
name=xmlunit
|
||||
version="$(sed -n 's/Version:\s*//p' *.spec)"
|
||||
|
||||
# RETRIEVE
|
||||
wget "https://github.com/xmlunit/xmlunit/releases/download/v${version}/${name}-${version}-src.tar.gz" -O "${name}-${version}.orig.tar.gz"
|
||||
|
||||
rm -rf tarball-tmp
|
||||
mkdir tarball-tmp
|
||||
pushd tarball-tmp
|
||||
tar xf "../${name}-${version}.orig.tar.gz"
|
||||
|
||||
# CLEAN TARBALL
|
||||
rm */GPATH */GRTAGS */GTAGS
|
||||
|
||||
tar -czf "../${name}-${version}.tar.gz" *
|
||||
popd
|
||||
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"
|
@ -0,0 +1,296 @@
|
||||
%bcond_with bootstrap
|
||||
|
||||
Name: xmlunit
|
||||
Version: 2.8.2
|
||||
Release: 6%{?dist}
|
||||
Summary: Provides classes to do asserts on xml
|
||||
# The whole package is ASL 2.0 except for xmlunit-legacy which is BSD
|
||||
License: ASL 2.0 and BSD
|
||||
URL: https://www.xmlunit.org/
|
||||
BuildArch: noarch
|
||||
|
||||
# ./generate-tarball.sh
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
# Remove bundled binaries which cannot be easily verified for licensing
|
||||
Source1: generate-tarball.sh
|
||||
|
||||
Patch1: 0001-Disable-tests-requiring-network-access.patch
|
||||
Patch2: 0002-Port-to-hamcrest-2.1.patch
|
||||
Patch3: 0003-Drop-support-for-JAXB.patch
|
||||
|
||||
BuildRequires: maven-local
|
||||
%if %{with bootstrap}
|
||||
BuildRequires: javapackages-bootstrap
|
||||
%else
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(net.bytebuddy:byte-buddy)
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
BuildRequires: mvn(org.assertj:assertj-core)
|
||||
BuildRequires: mvn(org.hamcrest:hamcrest-core)
|
||||
BuildRequires: mvn(org.hamcrest:hamcrest-library)
|
||||
BuildRequires: mvn(org.mockito:mockito-core)
|
||||
%endif
|
||||
|
||||
%description
|
||||
XMLUnit provides you with the tools to verify the XML you emit is the one you
|
||||
want to create. It provides helpers to validate against an XML Schema, assert
|
||||
the values of XPath queries or compare XML documents against expected outcomes.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
Javadoc for %{name}
|
||||
|
||||
%package assertj
|
||||
Summary: Assertj for %{name}
|
||||
|
||||
%description assertj
|
||||
This package provides %{summary}.
|
||||
|
||||
%package core
|
||||
Summary: Core package for %{name}
|
||||
|
||||
%description core
|
||||
This package provides %{summary}.
|
||||
|
||||
%package legacy
|
||||
Summary: Legacy package for %{name}
|
||||
|
||||
%description legacy
|
||||
This package provides %{summary}.
|
||||
|
||||
%package matchers
|
||||
Summary: Matchers for %{name}
|
||||
|
||||
%description matchers
|
||||
This package provides %{summary}.
|
||||
|
||||
%package placeholders
|
||||
Summary: Placeholders for %{name}
|
||||
|
||||
%description placeholders
|
||||
This package provides %{summary}.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}-src
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# Tests compare the string constent of thrown exceptions
|
||||
# and we use a different version of assertj
|
||||
find xmlunit-assertj3/src/test -name '*.java' -exec sed -i 's/\(Expecting not blank but was:\)<\(.*\)>/\1 \2/' {} +
|
||||
sed -i 's/\(expected:\)<\\"\[\(something\)\]\\"> but was:<\\"\[\(abc\)\]\\">/\1 \\"\2\\"\\nbut was : \\"\3\\"/' xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/ValueAssertTest.java
|
||||
|
||||
%pom_disable_module xmlunit-assertj
|
||||
|
||||
%pom_remove_plugin org.codehaus.mojo:buildnumber-maven-plugin
|
||||
%pom_remove_plugin :maven-assembly-plugin
|
||||
%pom_remove_plugin -r :maven-shade-plugin
|
||||
|
||||
%mvn_alias org.xmlunit:xmlunit-legacy xmlunit:xmlunit
|
||||
%mvn_alias org.xmlunit:xmlunit-assertj3 org.xmlunit:xmlunit-assertj
|
||||
|
||||
# JAXB and JAF are not available in JDK11
|
||||
%pom_remove_dep org.glassfish.jaxb: xmlunit-core
|
||||
%pom_remove_dep jakarta.xml.bind: xmlunit-core
|
||||
rm -rf xmlunit-core/src/{main,test}/java/org/xmlunit/builder/{jaxb/,JaxbBuilder.java,JaxbBuilderTest.java}
|
||||
|
||||
%build
|
||||
%mvn_build -s
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles-xmlunit-parent
|
||||
%doc README.md CONTRIBUTING.md RELEASE_NOTES.md
|
||||
%license LICENSE
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%files assertj -f .mfiles-xmlunit-assertj3
|
||||
%files core -f .mfiles-xmlunit-core
|
||||
%files legacy -f .mfiles-xmlunit-legacy
|
||||
%files matchers -f .mfiles-xmlunit-matchers
|
||||
%files placeholders -f .mfiles-xmlunit-placeholders
|
||||
|
||||
%changelog
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2.8.2-6
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Jun 18 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.8.2-5
|
||||
- Clean tarball from content with questionable licensing
|
||||
- Resolves: rhbz#1973743
|
||||
|
||||
* Wed Jun 09 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.8.2-4
|
||||
- Rebuild to workaround DistroBaker issue
|
||||
|
||||
* Tue Jun 08 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.8.2-3
|
||||
- Bootstrap Maven for CentOS Stream 9
|
||||
|
||||
* Mon May 17 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.8.2-2
|
||||
- Bootstrap build
|
||||
- Non-bootstrap build
|
||||
|
||||
* Thu Feb 04 2021 Merlin Mathesius <mmathesi@redhat.com> - 0:2.7.0-7
|
||||
- Update previous patch to use improved version that was merged upstream
|
||||
|
||||
* Fri Jan 29 2021 Merlin Mathesius <mmathesi@redhat.com> - 0:2.7.0-6
|
||||
- Fix FTBFS by patching ValueAssertTest to adjust for changed format of
|
||||
mismatched string exception
|
||||
|
||||
* Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.7.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jan 26 2021 Marian Koncek <mkoncek@redhat.com> - 2.8.2-1
|
||||
- Update to upstream version 2.8.2
|
||||
|
||||
* Wed Jul 29 2020 Marian Koncek <mkoncek@redhat.com> - 2.7.0-1
|
||||
- Update to upstream version 2.7.0
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 20 2020 Mat Booth <mat.booth@redhat.com> - 0:2.7.0-3
|
||||
- Allow building against JDK 11
|
||||
|
||||
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 0:2.7.0-2
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Wed May 13 2020 Dr. Tilmann Bubeck <bubeck@fedoraproject.org> - 0:2.7.0-1
|
||||
- Update to version 2.7.0.
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.6.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.6.3-2
|
||||
- Mass rebuild for javapackages-tools 201902
|
||||
|
||||
* Mon Jul 29 2019 Fabio Valentini <decathorpe@gmail.com> - 0:2.6.3-1
|
||||
- Update to version 2.6.3.
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed Jun 26 2019 Marian Koncek <mkoncek@redhat.com> - 2.6.3-1
|
||||
- Update to upstream version 2.6.3
|
||||
|
||||
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.6.2-2
|
||||
- Mass rebuild for javapackages-tools 201901
|
||||
|
||||
* Mon Mar 04 2019 Marian Koncek <mkoncek@redhat.com> - 0:2.6.2-1
|
||||
- Update to upstream version 2.6.2
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Mar 01 2017 Michael Simacek <msimacek@redhat.com> - 0:1.6-5
|
||||
- Install with XMvn
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Jan 04 2015 Dr. Tilmann Bubeck <tilmann@bubecks.de> - 0:1.6-1
|
||||
- update to upstream's xmlunit-1.6
|
||||
|
||||
* Wed Nov 5 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.5-3
|
||||
- Remove workaround for RPM bug #646523
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri Oct 11 2013 Dr. Tilmann Bubeck <tilmann@bubecks.de> - 0:1.5-1
|
||||
- update to upstream's xmlunit-1.5
|
||||
|
||||
* Fri Sep 27 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.4-4
|
||||
- Enable test suite
|
||||
- Resolves: rhbz#987412
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jun 12 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0:1.4-2
|
||||
- Update to latest packaging guidelines
|
||||
- Cleanup BuildRequires
|
||||
|
||||
* Fri Feb 15 2013 Dr. Tilmann Bubeck <t.bubeck@reinform.de> - 0:1.4-1
|
||||
- update to upstream's xmlunit-1.4
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Dec 30 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3-3
|
||||
- Build javadoc only.
|
||||
|
||||
* Thu Dec 30 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3-2
|
||||
- BR java 1.6 to prevent gcj failure.
|
||||
|
||||
* Thu Dec 30 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3-1
|
||||
- Update to new upstream.
|
||||
- Drop gcj.
|
||||
- Rebuild docs.
|
||||
|
||||
* Thu Mar 11 2010 Peter Lemenkov <lemenkov@gmail.com> - 0:1.0-8.3
|
||||
- Added missing Requires jpackage-utils
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.0-8.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.0-7.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.0-6.2
|
||||
- drop repotag
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.0-6jpp.1
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Thu Jan 17 2008 Permaine Cheung <pcheung@redhat.com> - 0:1.0-5jpp.1
|
||||
- Update to the same version as upstream
|
||||
|
||||
Tue Dec 18 2007 Ralph Apel <r.apel at r-apel.de> - 0:1.0-5jpp
|
||||
- Add poms and depmap frags
|
||||
- Make Vendor, Distribution based on macro
|
||||
- Add gcj_support option
|
||||
|
||||
* Mon Mar 12 2007 Permaine Cheung <pcheung@redhat.com> - 0:1.0-4jpp.1
|
||||
- Add missing BR, patch to build javadoc, and other rpmlint issues
|
||||
|
||||
* Mon May 08 2006 Ralph Apel <r.apel at r-apel.de> - 0:1.0-4jpp
|
||||
- First JPP-1.7 release
|
||||
|
||||
* Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.0-3jpp
|
||||
- Build with ant-1.6.2
|
||||
|
||||
* Wed Dec 17 2003 Paul Nasrat <pauln at truemesh.com> - 0:1.0-2jpp
|
||||
- Fix license and improved description
|
||||
- Thanks to Ralph Apel who produced a spec - merged version info
|
||||
|
||||
* Wed Dec 17 2003 Paul Nasrat <pauln at truemesh.com> - 0:1.0-1jpp
|
||||
- Initial Version
|
Loading…
Reference in new issue