Merge branch 'master' of ssh://pkgs.fedoraproject.org/xl2tpd

This also updates xl2tpd-1.3.1-Makefile to use full relro
Conflicts:
	xl2tpd.spec
epel9
Paul Wouters 12 years ago
commit 74843537d0

@ -0,0 +1,21 @@
diff -Naur xl2tpd-1.3.1-orig/Makefile xl2tpd-1.3.1/Makefile
--- xl2tpd-1.3.1-orig/Makefile 2013-04-01 16:05:42.459122589 -0400
+++ xl2tpd-1.3.1/Makefile 2013-04-01 16:06:03.800359414 -0400
@@ -98,6 +98,7 @@
#LIBS= $(OSLIBS) # -lefence # efence for malloc checking
EXEC=xl2tpd
CONTROL_EXEC=xl2tpd-control
+CONTROL_OBJ=xl2tpd-control.o
PREFIX?=/usr/local
SBINDIR?=$(DESTDIR)${PREFIX}/sbin
@@ -114,7 +115,8 @@
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LDLIBS)
$(CONTROL_EXEC): $(CONTROL_SRCS)
- $(CC) $(CONTROL_SRCS) -o $@
+ $(CC) $(CFLAGS) -c $(CONTROL_SRCS)
+ $(CC) $(LDFLAGS) -o $@ $(CONTROL_OBJ)
pfc:
$(CC) $(CFLAGS) -c contrib/pfc.c

@ -0,0 +1,29 @@
--- xl2tpd-1.3.1-orig/control.c 2011-10-06 21:22:05.000000000 +0200
+++ xl2tpd-1.3.1/control.c 2013-03-30 21:45:04.641605756 +0100
@@ -898,7 +898,7 @@
po = add_opt (po, c->lac->pppoptfile);
}
};
- po = add_opt (po, "ipparam");
+ po = add_opt (po, "remotenumber");
po = add_opt (po, IPADDY (t->peer.sin_addr));
start_pppd (c, po);
opt_destroy (po);
@@ -974,7 +974,7 @@
po = add_opt (po, "file");
po = add_opt (po, c->lns->pppoptfile);
}
- po = add_opt (po, "ipparam");
+ po = add_opt (po, "remotenumber");
po = add_opt (po, IPADDY (t->peer.sin_addr));
start_pppd (c, po);
opt_destroy (po);
@@ -1034,7 +1034,7 @@
po = add_opt (po, c->lac->pppoptfile);
}
};
- po = add_opt (po, "ipparam");
+ po = add_opt (po, "remotenumber");
po = add_opt (po, IPADDY (t->peer.sin_addr));
start_pppd (c, po);

@ -1,11 +1,17 @@
# upstream is switching to github, but has not released a new tar ball there yet
%global commit 3be48f8b7fc0e8de8cef7675a9861484b8b68c52
%global shortcommit %(c=%{commit}; echo ${c:0:7})
Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661)
Name: xl2tpd
Version: 1.3.1
Release: 10%{?dist}
Release: 12%{?dist}
License: GPL+
Url: http://www.xelerance.com/software/xl2tpd/
Url: https://github.com/xelerance/xl2tpd
Group: System Environment/Daemons
Source0: http://www.xelerance.com/software/xl2tpd/xl2tpd-%{version}.tar.gz
#Source0: https://github.com/xelerance/%{name}/archive/v%{version}.tar.gz
#Source0: https://github.com/xelerance/%{name}/archive/%{commit}/%{name}-%{version}-%{shortcommit}.tar.gz
Source1: xl2tpd.service
Source2: tmpfiles-xl2tpd.conf
Patch1: xl2tpd-1.3.1-Wunused.patch
@ -13,17 +19,17 @@ Patch2: xl2tpd-bz80693.patch
Patch3: xl2tpd-1.3.1-kernelmode.patch
Patch4: xl2tpd-1.3.1-conf.patch
Patch5: xl2tpd-1.3.1-pty.patch
Patch6: xl2tpd-1.3.1-Makefile
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Patch6: xl2tpd-1.3.1-ipparam-to-remotenumber.patch
Patch7: xl2tpd-1.3.1-Makefile
Requires: ppp >= 2.4.5-18, kernel-modules-extra
# If you want to authenticate against a Microsoft PDC/Active Directory
# Requires: samba-winbind
BuildRequires: libpcap-devel
BuildRequires: systemd-units
Requires(post): systemd-sysv
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
Requires(post): systemd
Requires(preun): systemd
Requires(postun): systemd
%description
xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
@ -51,6 +57,8 @@ Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com>
It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
%prep
# for git version
#% setup -qn %{name}-%{commit}
%setup -q
%patch1 -p1
%patch2 -p1
@ -58,11 +66,17 @@ It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
rm linux/include/linux/if_pppol2tp.h
%build
#make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH"
make DFLAGS="$RPM_OPT_FLAGS -g "
export CFLAGS="$CFLAGS -fPIC -Wall"
export DFLAGS="$RPM_OPT_FLAGS -g "
export LDFLAGS="$LDFLAGS -pie -Wl,-z,relro -Wl,-z,now"
make
%install
rm -rf %{buildroot}
@ -79,24 +93,13 @@ install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2
install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample
install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd
%clean
rm -rf %{buildroot}
%preun
if [ $1 -eq 0 ]; then
# Package removal, not upgrade
/bin/systemctl --no-reload disable xl2tpd.service > /dev/null 2>&1 || :
/bin/systemctl stop xl2tpd.service > /dev/null 2>&1 || :
fi
%systemd_preun xl2tpd.service
%post
%systemd_post xl2tpd.service
%postun
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
if [ $1 -ge 1 ] ; then
# Package upgrade, not uninstall
/bin/systemctl try-restart xl2tpd.service >/dev/null 2>&1 || :
fi
%systemd_postun_with_restart xl2tpd.service
%triggerun -- xl2td < 1.3.1-3
# Save the current service runlevel info
@ -108,7 +111,6 @@ fi
/bin/systemctl try-restart xl2tpd.service >/dev/null 2>&1 || :
%files
%defattr(-,root,root)
%doc BUGS CHANGES CREDITS LICENSE README.* TODO doc/rfc2661.txt
%doc doc/README.patents examples/chapsecrets.sample
%{_sbindir}/xl2tpd
@ -124,6 +126,13 @@ fi
%ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control
%changelog
* Mon Apr 01 2013 Paul Wouters <pwouters@redhat.com> - 1.3.1-12
- rhbz#929447 - Fix ipparam so ipv6-up does not fail (Michal Bruncko)
- rhbz#850372 - Introduce new systemd-rpm macros in xl2tpd spec file
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Thu Jul 19 2012 Paul Wouters <pwouters@redhat.com> - 1.3.1-10
- Updated comments in config files on how to authenticate against
a Windows PDC / Active Directory

Loading…
Cancel
Save